[closed] WordPress 3.6 and jQuery.BlockUI Version problem - solution (22 posts)

  1. ChipsOnFire
    Posted 2 years ago #

    I saw that many people have been having some issues with jQuery.BlockUI versions after upgrading to WordPress 3.6. So did I. Having looked into it, this is what I discovered (and fixed) in my setup.

    1. WordPress 3.6 uses the newer (latest) version of jQuery, which is 1.10.2.

    2. Lots of plugins use a function call jQuery.BlockUI which requires jQuery 1.2.3 or above.

    3. Now, 1.10 IS higher than 1.2, but older versions of the jQuery.BlockUI code used by plugins have a little 'buglet' - the code tests for versions BUT drops the trailing '0', so instead of asking is 1.10 greater than 1.2, it tests if 1.1 is greater than 1.2, and so it fails.

    4. This is NOT a WordPress problem - WordPress 3.6 merely uses the latest version of jQuery. Previous versions up to 1.9 would obviously pass the buggy test in jQuery.BlockUI code.

    5. The answer is NOT to downgrade jQuery in WordPress. Well - that might work, but don't do it!

    6. The answer is to get your PLUGIN provider to update their plugin.

    7. My plugin used a file called wf-an-jqery-plugins.js. Inside that file was a chunk of jQery.BlockUI code that said it was v2.39.

    8. I went to the following link for the latest jQuery.BlockUI code (v2.64) and then just replaced the v2.39 code in that plugin file with the code from this link. Hey presto, it all works again: http://malsup.github.io/jquery.blockUI.js

    9. So, folks, find out which plugins you have that are using OLDER jQuery.Block UI code and have your plugin provider update it - and in the meantime if you understood what I wrote above, perhaps you can fix your plugin(s) yourself.

    I hope this helps.

  2. ChipsOnFire? Much thanks for this (really!) but instead of re-posting all this text in multiple jQuery related topics (for 3.6) it may be more productive to point them to this topic via the link.


    or even this one which I'm sure will get updated as more info such as yours comes in:


  3. ChipsOnFire
    Posted 2 years ago #

    Yeah, I'm new to the forum. Thanks for the tip, I will do that form now on :-)

  4. ChipsOnFire
    Posted 2 years ago #

    By the way, that link to the Master List doesn't really give the full picture. It seems to imply that the problem could be caused just by people using their own version of jQuery. This is one possibility (which I had not considered - I didn't think people would be doing that!!). The real problem associated with the plugin errors people are seeing that talk about jQuert version numbers are NOT to do with jQuery, but the jQuery.BlockUI code in the plugin, which is entirely different to version of jQuery.

    Wow, how many times can I - or should I - type "jQuery"! lol

  5. No no, it's all good. You found a problem and want to help others. That's very cool and thanks for contributing. ;)

  6. By the way, that link to the Master List doesn't really give the full picture.

    Yes, that's true but moderators will be updating that thread as more information like yours comes in. I'm on a train and my jQuery chops are lacking or I'd do it myself (if I had the jQuery skills that is).

    It's not a thread that can be added to by regular members but it is intended to be updated and will be.

  7. Added via my iPad, and WELL SPOTTED!

    It's funny none of us were apparently using BlockUI in beta/trunk testing.

  8. ChipsOnFire
    Posted 2 years ago #

    I like to live dangerously - I beta test with 'released' code on my live site. It's one way to gets kicks :-) [Children - do not do this at home!!]

  9. ChipsOnFire? I've updated your title on the forums appropriately. :)

    Much thanks and great job contributing!

  10. ChipsOnFire
    Posted 2 years ago #

    Thanks. I wil continue to do my best to help people :-)

  11. cardened
    Posted 2 years ago #

    Thank you very much ChipsOnFire!

    I found the jQuery.Block.UI file on my plugin that was causing the problem and changed it with the updated version that you mentioned (http://malsup.github.io/jquery.blockUI.js), and it solved the problem.

    I event sent the Plugin Author the update so that he could fix it!!!

  12. hugofreak
    Posted 2 years ago #

    cardened Greatness!!!

  13. ChipsOnFire
    Posted 2 years ago #

    I sent it to my plugin author too, so they can roll out the fix to other less technical people hopefully much sooner.

    I'm glad I was able to help :-)

  14. msmedusa
    Posted 2 years ago #

    Oh wow, I am having this problem too but I have no idea which plugin is the culprit. The plugins I have are Akismet, Anthologize, Block Bad Queries, Blog as PDF, Facebook Like Button, Hello Dolly, IBegin Share, Official StatCounter,Print Friendly and Share Buttons by Add to Any. Do I have to contact all of them?

  15. Drew Jaynes
    Docs Czar
    Posted 2 years ago #

    Hi msmedusa,

    One of the best ways to narrow it down would be to disable your plugins one at a time until you're not receiving the error anymore.

  16. msmedusa
    Posted 2 years ago #

    Drew, thank you! Got it on the second try and if if it useful to anyone else, Anthologize was the culprit.

  17. ChipsOnFire
    Posted 2 years ago #

    msmedusa, let us know if the fix worked for you. Were you able up update Anthologize successfully?

  18. msmedusa
    Posted 2 years ago #

    Didn't try. I haven't been using it, so just deactivated, Too busy to spend more time than I need to on this.

  19. vtwinfitness
    Posted 2 years ago #

    Thanks for the tips everyone. Anthologize was also the culprit for me. I haven't been using it either but I'll message the author.

  20. vistazifta
    Posted 2 years ago #

    The plugin causing issues by me is WP Deals and the infringing file is wpdeals_plugins.js found in the "wpdeals-assets > js" folder i tried replacing the entire file with a renamed jquery.blockUI.js but its to different. Do i need to have the author rewrite it?

    sorry if i'm asking for help in the wrong place, and if i am please redirect me.

  21. dharma3d
    Posted 2 years ago #

    I'm sorry to say that I did what you said but I still have the same problem with plugin All-in-One Calendar by Then.ly

    I found the file in wp-content/plugins/all-in-one-event-calendar/app/view/admin/js/

    and replaced it with the one you mentioned but that didn't solve the issue...

  22. esmi
    Forum Moderator
    Posted 2 years ago #

    People: Please post in the relevant plugin forum with these issues.

    Closing topic.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.