Support » Fixing WordPress » WordPress 3.6 and 3.6.1 so so slow on Dreamhost, anyone else?

  • Hi
    I use 1click install of WordPress on Dreamhost shared hosting. My site has been running increasingly slowly for a few months, both the site and the admin backend, it was taking about 5 seconds to load either. I contacted their support twice and was told everything was normal. It’s only a small site and I don’t get too many visitors so far. Less now!

    I upgraded to WordPress 3.6 and 3.6.1 the other day and both the site and admin take a minimum of 15-20 seconds to load any page! I have wasted nearly 3 days trying to find out why and as you can imagine having to wait 15 or 20 seconds everytime I change something to test is really frustrating, never mind lost work and site users!

    Verification of results:
    – connected through a UK VPN to check from a different location, still slow.
    – used a variety of browsers, slow.
    – other people also reporting site as slow. reports 15-20s for first byte typically 17s to laod site
    – website inspector reports 20s for the network request and then a few seconds to render the page
    – connecting to is near instant, so it’s something to do with WordPress and the Dreamhost servers I thing!

    What I have tried:
    – disabled all plugins, still 15-20s
    – deleted all plugins, no effect
    – followed all the dreamhost faqs on their site inc database optimisation, checking memory and checking database load times, no effect
    – optimised the database. no effect
    – deleted the whole site and did a clean install of wordpress, even with a clean install and an ’empty’ database the site and admin were still about 10seconds
    – using a cache plugin like W3 total cache speeds up site loading, but working in the admin is still awful.
    – created a site on another host and imported my site, and it loaded in a few seconds!
    – hours of googling and trying stuff.

    In essence the site seems to render quickly once it starts, but takes 15-20seconds to get to that point. As the site loads quickly on another host it seems to be something Dreamhost are doing.

    I don’t really want to move to another host, but this is intolerable. I’ve posted on their support but thought I would ask here too given the last two times I have asked for help with this issue on Dreamhost support have not been useful!

    Any ideas or similar experience?

    Thanks in advance, Mike

Viewing 15 replies - 1 through 15 (of 37 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Hi esmi
    Thanks for the super swift reply.

    yes, have deactivated and deleted all plugins
    yes, tried twenty-ten and twenty-thirteen themes

    Any other ideas?

    It’s actually all running so slowly I can’t even re-authorise Jetpack without a timeout! lol is on sale. Where’s the site ?

    Sorry, typo, so tired now:-/

    The site is

    What’s in your htaccess?

    Hi Media X, thanks for reply, the .htaccess in the ‘root’ of the install is:

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>
            # DEFLATE by extension
            AddOutputFilter DEFLATE js css htm html xml
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" [L]
    # END W3TC Page Cache core
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Please, temporarily rename it to .htaccess2

    ok, done.

    Nope. 404 Errors. Please, rename it back.
    Can we, please, see your site with the default theme and with all plugins de-activated ?

    Yes, will take a few minutes, will post back when done.

    Thank you for helping:-)

    9 minutes to disable 13 plugins!

    ok, all plugins disabled and using twenty thirteen theme.



    Forum Moderator

    Any improvement in speed?

    Fraid not, I measure approx 20seconds for site to load, gives 22.77s

    Did you check memory and CPU stats on your server? Any bad news there? Bacause WP without plugins activated and with the default theme CANNOT load this long. No way!

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘WordPress 3.6 and 3.6.1 so so slow on Dreamhost, anyone else?’ is closed to new replies.