BackWPup Free - WordPress Backup Plugin
WordPress 3.6 (3 posts)

  1. jojo8026
    Posted 2 years ago #

    Does this plugin support WordPress 3.6


  2. lernerconsulting
    Posted 2 years ago #

    I have BackWPup version 3.0.13; WordPress version 3.6 in Multi-Site mode.

    With TAR compression, database backup works, for all the multi-site tables. That is the most important feature.

    With other compressions, database backup gives errors, seems to be with the PHP ZIP functions; i.e. getting the database data from MySQL works, combining and compressing the data into a .zip file, in any of the compressed formats, hangs and times out.

    I have only tried backing up my web site (non-database) files with compression; of course bigger files fail being made into zip file as well.

    p.s. The email report says "WARNING: mysqli::mysqli(): Headers and client library minor version mismatch. Headers:50162 Library:50530" which is programmer-ese for "oh, you have newer Library software than is required for this program to work, good". [Author: reword it as "Your server meets the Library version requirements for this plugin"?]

    You may see (if you have enabled warnings at the "strict" level): "STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator", which is programmer-ese for "that's the old way of saying it, here's the new way to say it, a few years from now we won't understand the old way"; in English, you can ignore that unless you're the programmer.


  3. lernerconsulting
    Posted 2 years ago #

    Update on my earlier post:

    There are (older) versions of PHP that have bugs with zip/unzip, hang with no error messages -- and make WordPress Update fail, make BackWPup compression fail, anything using zip/gzip. http://lcblog.lernerconsult.com/2013-php-unzip-bug-makes-wordpress-updates-hang/ has PHP code that demonstrates the bug isn't in WordPress.

    BackWPUp works with compression after talking to my hosting provider; they already had a newer PHP installed, a .htaccess configuration change switched me to the newer PHP.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.