WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress 3.5.1 Visual Editor Not Showing Up Fix (6 posts)

  1. tkinkart
    Member
    Posted 1 year ago #

    When I upgraded my site to WordPress 3.5.1 the visual editor no longer allowed input and was just basically a unusable blank white box. I could use the text tab if I selected it and then refreshed the page.

    So I first tried de-activating all plugins and setting the them back to 'Twenty Eleven' with no success. Finally after checking the console errors in IE I saw:

    LOG: Failed to load: http://localhost/blog/wp-includes/js/tinymce/langs/en.js
    LOG: Failed to load: http://localhost/blog/wp-includes/js/tinymce/themes/advanced/langs/en.js

    So I went to http://www.tinymce.com/ and download the latest version. The I just copied the en.js file to the folders listed above and I had to create a 'langs' folder for the second one to stick en.js into.

    Now my visual editor works great and I hope this can help others with the same problem!

  2. enjoywellbeing
    Member
    Posted 1 year ago #

    Have you received an answer, I still don't have my visual editor working and I tried uninstalling and reinstalling. Got rid of all my plugin and even changed themes and nothing.

    My web page is http://wwww.enjoywellbeing.ca

    Thank you.

  3. tkinkart
    Member
    Posted 1 year ago #

    If you see the post above I was able to fix it by manually adding those two missing files to the tinymce folder.

  4. Andrew
    Forum moderator
    Posted 1 year ago #

    @Connie Seidler,
    If the solution does not work for you then it is likely you are not experiencing the same issue. It would be best if you created your own thread to discuss that.

  5. enjoywellbeing
    Member
    Posted 1 year ago #

    @tkinkart Thank you, I tried that it didn't help and thank you for taking the time to answer my post. I really appreciate it.

    @Andrew Nevins I have created a separate thread but I have not had any responses, so I am looking at other posts. I have had this problem since the last update and it is frustrating for me since I have no coding experience.

  6. DaGenius20
    Member
    Posted 1 year ago #

    Console for me showed a different error - Uncaught TypeError: Object #<Object> has no method 'scrollTo' and Uncaught TypeError: Object #<Object> has no method 'getScrollInfo', both on the file http://.../wp-content/plugins/wp-editor/js/posts-jquery.js?ver=1.2.1.

    What do I do to fix this?

Topic Closed

This topic has been closed to new replies.

About this Topic