Support » Plugin: WooCommerce » WordPress 3.5 & WooCommerce, new variations bug?

  • Resolved ashah888


    Since installing WordPress 3.5 (today), I’ve noticed that updating a variations product resets the variation attribute selection, causing some unwanted behaviours.

    To resolve, I have to manually select all the correct variations from the drop down again and save.

    This seems like a new bug in WP 3.5. Does anyone else experience something similar?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same problem Here, everytime i edit any product i have to manually reselect variations after editing and i have to save again.

    Expecting a fix soon, anyone else with this problem please report it so woocommerce can bring their attention to this.

    I am having the same issue and did open a support ticket.

    Plugin Author Mike Jolley


    This will be fixed in 1.6.6 shortly. Caused by a change in cache handling.

    My problem also is that on a product page, it’s immidiatly slides to the the anchor #tab-reviews.

    If I remove that, the add to cart button won’t appear anymore.

    Check out at:

    Does anybody know why?

    I am also having the same issue with variations only I noticed something extra:

    I had 2 attributes and when setting the variations I left one of them set to the “ANY [ATTRIBUTE]” option by mistake and saved the settings.

    I then noticed it and went back and changed that variation to the specific attribute I wanted and saved again.

    I then noticed that the variation which I originally set correctly had been reset to “ANY [ATTRIBUTE]” but that now the 2nd variation was correct.

    It created a loop where each time I tried to change one it would set the other variation to “ANY [ATTRIBUTE]”.

    In order to fix this I had to set both variations to “ANY [ATTRIBUTE]” then save the changes, then reset each variation to the specific attribute and save the changes

    Finally it worked, but so ridiculously frustrating!

    Hope the release a fix soon coz this is doing my head in :-/

    I am experiencing a variations bug I can use some help with.
    I’m running Thesis 1.8 with Woocommerce 1.66;

    I have one parent attribute with about 16 child attributes under it. I’m applying all the attributes to all my ‘products’ via the ‘copy to a new draft’ as product variations.

    This has worked great for the first few, then after that all the pricing is getting messed up. I have a variation that is setup to be free with no shipping and on some of the products it’s charging $8 even though it’s setup correctly & looks 100% correct on the backend.

    Any help would be great as I have 100’s of ‘products’ and going through each one would take too much time.



    I use a heavily customised version of woocommerce, so updating it would invalidate the majority of my changes. Could you post on git hub the code that solely affects the variations caused by the cache handeling?




    I’m having the same problem. I’m on WP 3.5 and WC 1.6.6.

    Variation assignments are being randomly lost. I just upgraded to WP 1.6.6 hoping it would solve the problem, but it’s still there.



    I possibly spoke too soon. The product with missing variations might have been like that prior to the WC 1.6.6 upgrade. I’ve gone through all my products and made sure the variation assignments are there. I’ll report back if they go missing.

    I’m having the exact same issue and I must admit when you have hundreds of products it becomes a nuisance. If I need to update a product. I do the same click update, then I have to go back into the same product and reset all the variations. Has this issue been fixed yet ?

    Im having similar problems but mine is with new products. I can get the attributes but after I click make attributes visible and use in variations and I go to variations it will not let me use or create the variations, also im trying to upload multiple photos in the add gallery images it just sends me to the top of the page and does not let me. can anyone help or know anything about that?

    I had a few products configured with a size variation and suddenly (i.e. I do not remember doing anything nasty) I do not see any products on the shop URL. It displays the page with message “No products found which match your selection.”

    I see that al products are now listed as “Simple product” (instead of earlier “Variable product”). I do not see my previously defined variation terms for size (Small/Medium/Large etc.). If I add the terms back, I don’t see them again when I refresh the page again. And the terms are there in the database, as the slugs that are automatically added are small-2 etc!

    How to fix this problem? I am using a modified banshee theme, but the problem persists even if I switch to any of woocommerce themes.

    My Variations are all over the place. Is there any fix to this problem yet.

    Try clearing the variations cache
    Go to
    WooCommerce/System Status/Tools

    Click on WC Transients and/or Expired Transients.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WordPress 3.5 & WooCommerce, new variations bug?’ is closed to new replies.