WordPress.org

Ready to get started?Download WordPress

Forums

[closed] WordPress 3.5 upgrade causing issues on some Internet explorer browsers (19 posts)

  1. bdinke01
    Member
    Posted 2 years ago #

    Can anyone help me out, website was working fine on all browsers, but after I upgraded to 3.5 from 3.4.2 it seems to be completely messed up on some Internet explorer browsers but not all (????)...Firefox and chrome seem to be fine:..also wpbakery visual editor does not work at all on anything...this is really jamming my business up...and I have no clue how to make it work universally again???

    Please help!!!

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Twelve theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. bdinke01
    Member
    Posted 2 years ago #

    Yes tried plug in deactivation and it didn't fix, actually it caused more issues on browsers that were ok. It is probably the theme but I do not want to change themes. How can I go back to 3.4.2???

  4. bdinke01
    Member
    Posted 2 years ago #

    Could it be a compatibility issue with WordPress 3.5 and previous versions of Internet explorer (IE 8 or 9)???...also wpbakery visual editor doesn't work in WP 3.5...why is it so different? (So many bugs?) shouldn't a new version be at the very least compatible with everything that came before it???!!!

  5. bdinke01
    Member
    Posted 2 years ago #

    So it was that Internet explorer upgrade to IE 10 fixed the problems, on my computer...by what about all the people that go to my site that haven't upgraded to 10??? They will see a sloppy incoherent website...this is a major problem! When will WordPress 3.5 fix this!!!

  6. I think that a better option would be to fix the theme. If there are loads of errors on lower version of IE, then this is more of a theme issues. The new version comes with new JQuery libraries which are the latest and greatest, so I would start with that.

  7. JDN
    Member
    Posted 2 years ago #

    I'm having the same issue. When i logged into our site to do a little work it said i have an update, so I clicked on it, and now this is what I get: Fatal error: Cannot redeclare sticky_class() (previously declared in D:\Hosting\5635595\html\wp-includes\post-template.php:584) in D:\Hosting\5635595\html\wp-includes\deprecated.php on line 3192
    I cant even login to fix anything.
    Please help!! Have to get this site back online.
    Thank you!

  8. bdinke01
    Member
    Posted 2 years ago #

    Christine, can you help me find out where the problem is? I don't even know where to start? I really wish I could just go back to 3.4.2 it was perfect on that version.

  9. bdinke01
    Member
    Posted 2 years ago #

    How would I fix the theme? where would the problem be???

  10. bdinke01
    Member
    Posted 2 years ago #

    why wouldn't they make the 3.5 upgrade process also convert current builds for compatibility???

  11. WPyogi
    Forum Moderator
    Posted 2 years ago #

    What theme are you using? Can you post a link to your site?

  12. bdinke01
    Member
    Posted 2 years ago #

    using Novus Corporate theme

    http://www.parkerlaine.com

  13. JDN
    Member
    Posted 2 years ago #

    @WPyogi..not sure if you are talking to me or not?! I dont really know where to start either. I'm not sure what my theme name is, we had someone set it up for us, and i just update the information. Our website is supposed to be: http://www.all-chemtx.com

  14. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @JDN - no, please start your own thread per the forum rules. It doesn't work well for more than one person to be trying to get help in one thread -- for just this reason -- it's confusing as to who's talking to who. Someone will help you faster in a new thread too :).

  15. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @bdinke01 - it looks like you have quite a few mark-up errors -- and these can cause major problems in IE. I'd suggest you start tracking those down and if they are in the theme files (rather than your content), you should contact the theme vendor/developer for assistance -- as commercial themes are not supported here.

    http://validator.w3.org/check?uri=http%3A%2F%2Fparkerlaine.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    http://codex.wordpress.org/Validating_a_Website

  16. bdinke01
    Member
    Posted 2 years ago #

    I see, but I do not understand what the errors mean or how to go about fixing them...Everything looks/works fine on every browser but IE 9 (<10)...and even that looked fine on WordPress 3.4.2, it was only when I upgraded to 3.5 did the problems occur. Any chance you could provide some direction on fixing the errors?

  17. Hoz1982
    Member
    Posted 2 years ago #

    Maybe I found a solution. I had the same problem with ie9 and saw it was running on compatibility mode....don't know why.
    However, i solved it putting on the header.php the following meta:

    <meta http-equiv="X-UA-Compatible" content="IE=edge" >

    header.php on line 1. This meta tells IE to run as the highest version possible, hiding the compatibility view button.

    Hope it helps...
    cheers
    Alex

  18. michaellee99
    Member
    Posted 2 years ago #

    Hoz1982 you are a life saver! Added the code you posted and fixed my problem. Thank you!!

  19. nonyx9
    Member
    Posted 1 year ago #

    Thanks to Hoz1982 so easy solution.

    However, i solved it putting on the header.php the following meta:

    <meta http-equiv="X-UA-Compatible" content="IE=edge" >

    header.php on line 1. This meta tells IE to run as the highest version possible, hiding the compatibility view button.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.