Support » Fixing WordPress » WordPress 3.5 Update will not allow page edit & wordcount is 0

  • Resolved RussNealPhoto

    (@russnealphoto)


    I have updated to WordPress 3.5 and now i am unable to edit a page and the wordcount is 0.
    The posts are the same – a blank box with 0

    I have deactivated all plugins
    Reinstalled wordpresss update
    Flushed the browser cache

    Any ideas?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Tried changing to 2011 / 12 Theme – no joy.

    Does anyone know how if I can reinstall 3.42?

    I have the zip file…

    Did you make a pre-upgrade database backup?

    Hi esmi,
    Thanks for the reply.
    Yes I have made backups, but not a recent one. I would prefer not to restore the website content to an earlier point.

    Can I just restore the wordpress side or do you think there will be another update to sort out these issues?

    Can I just restore the wordpress side

    No. The database was upgraded for 3.5 and you cannot run WordPress 3.4 files with a 3.5 database.

    Jeroen

    (@henkdevries)

    No. The database was upgraded for 3.5 and you cannot run WordPress 3.4 files with a 3.5 database.

    How come? Does the upgrade change that much in the database? Or might one get lucky with a little code/DB hacking?

    Does the upgrade change that much in the database

    Oh yes! The actual changes vary from update to update but this time, media handling has been completely overhauled, so I would expect fairly major db changes.

    omg omg omg.
    I am about to cry.

    Please visit this page, it will sort your problem.
    I also upgrade to version 3.5 and step no.2 worked like a charm for me.
    NOTE: IT’S YOUR JAVASCRIPT

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    PLEASE PLEASE PLEASE visit the official WordPress support page by clicking here.
    Thank me later.

    Brb, going to cry I can’t believe I have found how to fix it and now get to enjoy the new updates ;).

    Step 2: Enable SCRIPT_DEBUG
    You need to turn on script debugging. Open wp-config.php and add the following line before “That’s all, stop editing! Happy blogging”.

    define(‘SCRIPT_DEBUG’, true);
    Check to see if you are still having an issue.

    Issue is fixed – turn off script debugging and report the issue on the support forum, telling the volunteers the you turned on script debugging and it solved the problem.
    Issue persists – proceed to Step 3.

    mauricewest – Your a hero, Thanks Thanks and Thanks

    Hero .. this works 🙂

    Glad I could help you guys! 😉

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WordPress 3.5 Update will not allow page edit & wordcount is 0’ is closed to new replies.