Support » Plugins and Hacks » [Resolved] WordPress 3.5, Save, Publish gives 500 – Internal Server Error

[Resolved] WordPress 3.5, Save, Publish gives 500 – Internal Server Error

  • Hi,

    first, thank you for your magnificent plugin, which I use now for some time and am very happy with it.

    Since the update to WordPress 3.5 it seems the plugin does not work with WordPress together anymore. Every time I want to save and/or publish an article results in an 500 – Internal Server Error. Although the article are stored or published, but this bug makes it very difficult to work with WordPress.

    It took me some time to figure out, why WordPress behaves this way, but with disabled OGraphr the save/publish function works fine. Unfortunately, I can not find any entries in a log file, so that the problem can be narrowed down further.

    Is there a way to solve the problem? I would love to continue to use OGraphr on my blog.

    Thank you in advance for your efforts.


Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author idleberg


    can’t really think of something that causes this, but i’ll look into it during the week. for now here are three things you could try and observe what happens

    1. set ographr to Everytime your site is visited (slow, more accurate) in the expert settings. what happens when you visit a page with a player embedded?

    2. open the file meta-ographr_index.php in a text editor and set OGRAPHR_USECURL to TRUE. reload the page from 1., then do the same with 1. reverted

    3. try using an older version of the plugin, try the last 0.6 version. same problem?

    Thank you for your prompt response.

    I have set oGraphr to “Everytime your site is visited (slow, more accurate)” and it works no to saving and publishing the articles without any error!

    Is this the solution now, or should I try the other two approaches too?

    Sorry, it has a typo crept in:
    …and it works now to saving and publishing the articles…

    Plugin Author idleberg


    does this mean that the plugin now works in both modes or only “everytime you visit”? personally i’d prefer other mode, but both modes have their pros and cons. you can try steps 2 and 3 for the other mode, if you like. maybe that way i can find the problem, haven’t been able to reproduce it.

    since the only major change from 0.6 to 0.7 has been the switch from using cURL to wordpress’ http api, i’d like to think that setting the plugin to cURL could solve your problem.

    The plugin not works in both modes, it works only with “everytime you visit” and yes, i prefer also the method “Only once when saving a post”, unfortunately, this leads to this error.

    With “OGRAPHR_USECURL set to TRUE” the method “only once when saving a post” results in 500 – Internal Server Error, the methode “everytime you visit” still works.

    I instelled version 0.6.14 and with that, still the same error, method “only once when saving a post” results in 500 – Internal Server Error, the methode “everytime you visit” still works.

    I also found out that if I want to delete posts in the trash overview with activated oGraphr (no matter which method is enabled), it also results in “Internal Server Error”.

    Please let me know if I can perform further tests to isolate the problem.

    With the new version 0.7.6 still the same problems…

    Plugin Author idleberg


    you previously stated, that you don’t find anything in “a log file”, did you run wordpress in debug mode?

    did you frequently update the plugin and wordpress, do you think it’s possible to nail down from when on you got that behaviour? did this only happen after you upgraded to wp 3.5? what php version are you running? could it be any other plugin interfering? do you use jetpack? does your theme use language attributes? could you try and increase OGRAPHR_TIMEOUT in the source code?

    Yes, i update wordpress and plugins frequently and as mentioned, the problem occurs since the upgrade to wp 3.5. On my server is PHP version 5.3.3-7 running. I also use SharePress, in which I turned off the function for Open Graph and which has not been updated at this time and which has previously worked perfectly with OGraphr. I do not use jetpack and my theme not use language attributes. I increased OGRAPHR_TIMEOUT on 5, 10 and 30 sec, without success…

    With WP_DEBUG mode true I see some notice if i save a post: “Notice: Undefined index: add_adminbar in /var/www/dravenstales/wp-content/plugins/meta-ographr/meta-ographr_index.php on line 2393” and on the seetings page from OGraphr
    “Notice: Undefined index: official_api in /var/www/dravenstales/wp-content/plugins/meta-ographr/meta-ographr_index.php on line 2252”

    And what i noticed also is that when i save a post with the “Only once when saving a post” activated the URL of “http://dravenstales.ch/wp-admin/post.php?post=12345&action=edit&message=1” is changing to “http://dravenstales.ch/wp-admin/post.php” and everything after the question mark is missing…

    Plugin Author idleberg


    phew, it’s probably not cause by my plugin, there are quite a couple of reports on similar problems with wordpress 3.5


    have a look at your .htaccess file

    That may be, I have also been reading about these problems and checked my .htaccess file, unfortunately without success.

    Strange is that everything works fine if OGraphr is disabled or on “Everytime your site is visited”. Only the option “Only once when saving a post” seems to making problems, but that need not be the plugin…

    Plugin Author idleberg


    i’d had to deep dive into the code, but basically both modes run the same functions. there are currently two things to do and both involve waiting.

    1. see if it’s a wordpress bug and hope it will get fixed at some point
    2. see if ographr 0.8 will do any change, as i plan on rewriting the main functionality of the plugin entirely

    Thanks for your efforts, i am also looking more at my blog, if i can find something. Even if a WordPress update comes out, i will try this and keep you informed. Thanks again for all your efforts!

    Hi, after the Update to WordPress 3.5.1. the Option “Only once when saving a post” works fine again. Apparently the problem was definitely not your plugin 🙂

    Plugin Author idleberg


    ah that’s great, thanks for letting me know!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] WordPress 3.5, Save, Publish gives 500 – Internal Server Error’ is closed to new replies.