WordPress.org

Support

Support » Multisite » [Resolved] WordPress 3.5 multisite activation doesn't add "Network Setup" to "Tools" m

[Resolved] WordPress 3.5 multisite activation doesn't add "Network Setup" to "Tools" m

  • Hi,

    I’ve tried again and again and again. Searched the web too for help but I finally decided to seek some help here. Thanks in advance.

    The problem is:
    I’ve carried out a fresh installation of WP 3.5 in my localhost. Everything is fine. However, when I tried activating multisite on this installation by adding “define(‘WP_ALLOW_MULTISITE’, true)” to wp-config.php, “Network Setup” doesn’t appear under “Tools” menu.

    Clueless here. Please help me out.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Where did you put that define line?

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy blogging. */

    Thanks.

    Try putting it up at the top.

    <?php
    
    define('WP_ALLOW_MULTISITE', true);
    
    ....

    Silly but sometimes things are weird.

    Tried. Still no luck. I did a second local installation. Same problem there. I’ll try a real web server. Perhaps it’ll work then.

    Thanks.

    Hello again,

    Network setup works fine on online cloud server. Local host still doesn’t work. I think it has something to do with versions of PHP, MySQL, Apache etc. Probably. I’m not sure. This is where your expert comments matter. Please find versions below.

    Online cloud server
    ——————–
    PHP 5.3.17 (cli)
    Zend Engine v2.3.0
    mysql Ver 14.14 Distrib 5.5.24, for Linux (x86_64) using readline 5.1

    Localhost
    ——————–
    PHP Version 5.3.4
    Zend Engine v2.3.0
    Server version: 5.5.28 MySQL Community Server (GPL)

    Thank you.

    Paulo
    Member

    @pauloen

    You cannot create a network in the following cases:

    • “WordPress address (URL)” uses a port number other than ‘:80’, ‘:443’.
    • “WordPress address (URL)” is localhost.
    • “WordPress address (URL)” is IP address such as 127.0.0.1.

    So, if You try to install WP on your local machine propably it will not work 😉

    At least I know enough of the theory. I never did it and I never looking for solutions so that the local machine is significantly different from virtualnego web server and then always have a lot of things to improve – so I figured it was better to get it right immediately;)

    Read More Here 😉

    I feel so stupid for not reading full documentation.

    Thank you so much Nowak for pointing that out, now I know what’s going on.

    I’m closing this thread since my question was correctly answered, thank you all.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] WordPress 3.5 multisite activation doesn't add "Network Setup" to "Tools" m’ is closed to new replies.