The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WordPress 3.4 - paging problem (7 posts)

  1. SpabRice
    Posted 4 years ago #

    I got the following problem after updating to wp-3.4 for my theme:

    My front page displays is "Your latest posts". So my index/home page is a list of recent posts with pagination. (www.test.com)

    the pagination works with ajax/jquery. So if someone hits the "next" buttons (url = http://www.test.com/?paged=2) jquery loads the content and insert this without refreshing the page (.load function).

    Problem: Since 3.4. the .load function gives no result. Apperently the .load function loads a "blank page" OR "no page".
    But typing the url (.../?paged=2) manually in the browser works fine. The secong page is shown.

    What I've have so far:
    .../?p=1&paged=2 -> works
    .../?paged=2 -> doesn't work
    .../paged/2/ -> doesn't work

    first it seams to be a jquery coding issue but why is .../?p=1&paged=2 working then?? I have no idea why it's not working with the .../?paged=2
    And on 3.3.2 it was working fine, so it has something to be with wordpress.

    Does anyone have an idea?

  2. phillymantis
    Posted 4 years ago #

    im having a similar problem

    i had custom loops used the $paged method for pagination

    soon as i upgraded....they all broke

  3. halloei
    Posted 4 years ago #

    I got the same problem with my own pagination-code after updating to 3.4.

  4. SpabRice
    Posted 4 years ago #

    I did many different tests the whole day but nothing helped.

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  6. UsagiYojimbo
    Posted 4 years ago #

    Same issue since I upgrade to 3.4. I use to have customed loops using $paged and it won't work now.

  7. UsagiYojimbo
    Posted 4 years ago #

    Ok, I have solved the problem with the help of thic topic : http://wordpress.org/support/topic/wordpress-34-broke-my-paginaton-setup?replies=4

Topic Closed

This topic has been closed to new replies.

About this Topic