WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WordPress 3.4 Bug – Page Templates

[Resolved] WordPress 3.4 Bug – Page Templates

  • Hi,

    For some time I have been experiencing a bug with WordPress not showing the Page Templates dropdown on the page editor. I have been able to resolve this by deactivating and reactivating my theme. Not sure why this worked, but it was suggested in threads here and sure enough it works.

    Now, I have upgraded to WordPress 3.4 and everything else being the same but now the technique above no longer works to restore the Page Template dropdown. I have no way to use page templates now at all.

    Any thoughts?

Viewing 15 replies - 16 through 30 (of 60 total)
  • Its happens with me also..

    I am using WordPress theme “Crea WP” and upgraded to wordpress 3.4
    and now i am not getting page templates drop down menu on making a new page.

    There are custom page templates in the theme like “contact page” & “Portfolio page”

    i switched the templates, plugins reactivated. but the drop down is not showing.

    Any one can help ?

    @ All:

    I have tested the following without success:

    1) Change theme
    2) Create a new folder for custom page types and put them there
    3) Delete the custom page files on the server and then copy them over again…

    Anyone who had success, please share!!

    This solution worked for me…. you have to declare the template name on a dedicated row.

    From:

    <?php /* Template Name: Enquire */ ?>

    To:

    <?php /*
    Template Name: Enquire
    */ ?>

    @troyster

    Nice work. This fix seems to be working for me also

    I had a similar issue with the 3.4 update, certain page templates were showing and others weren’t, turns out it was the formatting in the php file

    <?php /*Template Name: 1 Column Page */ ?>

    Won’t work

    <?php
    /*Template Name: 1 Column Page */
    ?>

    Will work.

    Apparently the newline is required in 3.4. This is a pretty silly bug that could potentially break thousands of themes which I hope will be fixed.

    Thanks for posting this fix which worked for me. Wasted an hour or so up to now trying to fix the backend of my sites.

    This was very helpful. Thanks so much!

    Hello everyone,

    Sorry for your trouble on this one. You are right, <?php /* Template Name: ... on one line will not work in 3.4.

    This was not an intentional change, and will be fixed in 3.4.1. (You can find a bug report on this here: http://core.trac.wordpress.org/ticket/20955 )

    In the meantime, if you run into any issues with it not detecting a page template that isn’t covered by the example above, please let us know. Thanks!

    hi, our site is currently ineccessable as sub-pages cannot be clicked this is evidently after the upgrade we are using Modularity Lite as a theme i have tried the fix and the bug just isnt getting fixed i dont know if im am maybe doing it wrong but we have grow desperate pls help.

    @junior89 Unsure if this bug effects the front end display of templates or just the admin.

    the front end and the admin, in the admin the section were you select pages is at the bottom of the page and the side bar with the options is stretched out and abnormal as the options are scarterd and as mentioned when one visits the site you can click on the pages infront such as ie. about us and contact but the sub-pages of that u cannot they do display but as you try to move the curser over a selection it all dissapears, i have currently changed themes as a test im using twenty eleven and it works fine but modularity lite is my problem

    nope i was wrong it not just the modularity lite any theme i put on the pages section admin and front is not functioning correctly

    but using firefox the front end of the site is perfectly fine but on ie its shocking

    Putting the template name on a dedicated line solved this issue for my custom template after upgrading to 3.4. Thanks troyster!

    <?php /*
    Template Name: My Template Name
    */ ?>

    can you please advise the place and process to put this in or were i should find this info.

    thanks in advance

Viewing 15 replies - 16 through 30 (of 60 total)
  • The topic ‘[Resolved] WordPress 3.4 Bug – Page Templates’ is closed to new replies.
Skip to toolbar