Support » How-To and Troubleshooting » [Resolved] WordPress 3.4 Bug – Page Templates

[Resolved] WordPress 3.4 Bug – Page Templates

  • Hi,

    For some time I have been experiencing a bug with WordPress not showing the Page Templates dropdown on the page editor. I have been able to resolve this by deactivating and reactivating my theme. Not sure why this worked, but it was suggested in threads here and sure enough it works.

    Now, I have upgraded to WordPress 3.4 and everything else being the same but now the technique above no longer works to restore the Page Template dropdown. I have no way to use page templates now at all.

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 60 total)
  • Do you see the box called “Page Attributes”? If not, click “Screen Options” at the top right, and select the “Page Attributes” box.

    Moderator Jan Dembowski


    Link please? I suspect it’s your theme but a link would help.

    In the meanwhile have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Edit: mindctrl is on to it, that should have been my suggestion too. 😉

    Thanks for the tips!

    Yes, Page Attributes is checked on and I can see the Page Parent and Order, just not page templates.

    I am actually developing a custom theme, so I can’t switch 🙂 Do you know what part of the theme would cause this conflict? If the problem exists on my end, I need to fix it.

    Also, no plugins are activated.

    For now, I just entered the page template in to the SQL database directly, although I need to figure it out especially if you think it could be the theme Im working on.

    I’ll give the other suggestions a try as well and post back.

    Do your page templates have the name in the top? Similar to this:

    Template Name: My Template Rules

    Yes, they sure do. 🙂

    Also, its not that the templates dont show up in the dropdown, Im actually missing the entire dropdown it’s self.

    Everything was working until I upgraded, and now even my workaround doesnt restore the Page Templates dropdown. Im stumped.

    Interesting. Have you tried enabling debug to see if any errors are showing?

    In wp-config.php you can add the following lines and they’ll show up on the screen and log to the wp-content/debug.log file.

    define('WP_DEBUG', true);
    define('WP_DEBUG_DISPLAY', true);
    define('WP_DEBUG_LOG', true);

    Moderator Jan Dembowski


    mindctrl? Those are good suggestions. 🙂

    Along those lines: create a custom template just as above and call it my-template-rules.php and dump that into the wp-content/themes/twentyeleven/ directory. You can delete it later.

    Now switch to Twenty Eleven, check that the page attributes is still selected and see if you can select that template.

    It won’t do anything, but being able to select it would be an improvement. If that works then it’s probably your custom theme.

    Ok, I just deleted my custom pages and then re-uploaded them. I didn’t do anything else, just delete / reupload. And, it worked!

    That’s mighty odd, but now I know my new workaround.

    Thanks everyone, I appreciate the help! 🙂

    Hi! I have same problem with wordpress 3.4…
    Can explain how did you solve this problem?!

    Sure, all I did was I logged in to my server with FTP, downloaded and deleted my custom page templates.

    Then, I simply re-uploaded them and refreshed the page.

    That was really all, but it solved the problem in my case.

    Hi, I have this issue as well.

    @1stpage: Did delete my custom page files on the server and then re-upload -> didn’t solve.

    Any other workarounds?

    My problem didn’t solve too
    I use custom fields to change my _wp_page_template

    @ behrooz.tahanzadeh

    Did you solve it with setting template in custom field?

    How did you do it?

    there’s record in wp_postmeta that save page templates.
    It’s meta_key is _wp_page_template and meta-value is name of template file for example


    but if you want to change it directly in custom field panel wordpress give and error that says you cant change it!

    To change this record directly in page editor I use Advanced Custom Fields plugin…

    @ behrooz.tahanzadeh thanks…

    So do we haver to do a hack in order to get this work, or is there any better solutions?

Viewing 15 replies - 1 through 15 (of 60 total)
  • The topic ‘[Resolved] WordPress 3.4 Bug – Page Templates’ is closed to new replies.