[resolved] WordPress 3.3.1 has issues with the anchor tag in dashboard (users profiles) (6 posts)

  1. boutros
    Posted 4 years ago #


    I updated to WordPress Version 3.3.1 and I realized that WordPress changes
    the closing 'a' tag (it removes the /), when I add a link in the dashboard -> Users -> Your profile -> Biographical Info

    For example In the 'Biographival Info; box, when I add a link like:
    <a href="http://blueoliveonline.com/">Blue Olive Online</a>
    after I save, WordPress converts it to:
    <a href="http://blueoliveonline.com/">Blue Olive Online<a>

    (notice it removes the forward slash in the closing a tag.)

    This was working fine in prior versions of WordPress and I don't have any other changes to the blog, no new plugins. The only difference is the new version install of WordPress.
    Any ideas how to fix that?

  2. Rev. Voodoo
    Posted 4 years ago #

    Just tested on 3 installs, I'm not able to repeat this problem on 3.3.1

    Even though you don't have any NEW plugins, it may still be a conflict. You'd be best to test that out first off....

  3. boutros
    Posted 4 years ago #

    Deactivating all plugins did not work. Still the same problem as described above. Very weird!

  4. Rev. Voodoo
    Posted 4 years ago #

    Sure is... when you hit save, that slash disappears immediately?

    Because I can save and it stays, and if I leave the page and then return, it's still there

  5. boutros
    Posted 4 years ago #

    Yes when I hit the 'Update Profile" button the forward slash disappears.
    There is no save button.

    @Rev. Voodoo: Thanks for you responses. I actually solved the issue and I will detailed for others to learn:

    From my WordPress Experience, I had a hunch that it had to do with "kses.php" file in "wp-includes" folder. So once I upgraded to 3.3.1 for some reason this file somehow got corrupted. So I got a fresh "kses.php" from wordpress.org (the 2 files were different in size, that's how I knew that something is not right there) and replaced the existing one.

    Once I did that, everything is good to go. The forward slash in the closing 'a' tag is not being removed.

  6. Rev. Voodoo
    Posted 4 years ago #

    Glad you found the issue!

Topic Closed

This topic has been closed to new replies.

About this Topic