TinyMCE Advanced
[resolved] WordPress 3.3.1 and TinyMCE Advanced 3.4.5 not working (19 posts)

  1. Mark Tuttle
    Posted 3 years ago #

    I've been unable to get the TinyMCE Advanced plug in 3.4.5 to work with WordPress 3.3.1. In the visual editor, I can see the first two rows of standard tinymce buttons, but I'm missing the third and fourth rows of advanced buttons.

    Is it still the consensus of the community that the problem is network or browser caching problems or conflicting plugins or javascript concatenation or the particular browser being used?

    The following experiment should be easy for others to reproduce, and makes me think these are not the problems, although I admit the possibility of discrepancy between my actions that this report. On a laptop running Windows 7 and Apache 2.2.21 (Win32) and PHP 5.3.5

    1. From scratch, I built a fresh mysql database test with user testuser and password testuser, and I did a fresh installation of WordPress 3.3.1 into a fresh directory http://localhost/wordpress.
    2. I deleted all plug ins (to eliminate conflicting plug in issues)
    3. I installed and activated plug in tinymce advanced 3.4.5.
    4. I clicked on "+ new" and clicked on "kitchen sink" in the visual editor.
    5. I saw the two rows of standard tinymce buttons and did not see the two rows of advanced buttons.
    6. I rebooted the laptop and turned off wireless networking (to remove the issue of network caches).
    7. For Firefox 9, Internet Explorer 8, and Safari 5.1.2, I cleared all caches (history, cookies, cache, downloads, etc, to remove the issue of local caches), restarted the browser, logged in, and clicked on "+ new", and the advanced tinymce buttons did not appear even after a refresh of the page.
    8. Changing the theme from default 2011 to 2010 gives the same results for Step 7.

    Concerning define('CONCATENATE_SCRIPTS',false) mentioned many places, I added this as the first define in wp-config.php, and repeated Step 7 for all three browsers with the same result.

    Concerning browser caches, network caches, proxies, different computer, different browsers, different service providers mentioned here and many other places, I think the experiment above rules out these issues (the problem exists with a local installation on my laptop and a remote installation on my host provider ICDSoft).

    Concerning editor-style.css mentioned here, I can see content_css:"http://[your site]/themes/twentyeleven/editor-style.css in the html source, and I can see in the Apache log that it is being served up successfully with a 200 return code.

    Concerning the issue with en.js and wp-langs-en.js mentioned here I copied wp-langs.en.js to en.js in the directories mentioned with no effect. Most sigificant, I can see in the access logs that requests for wp-langs-en.js are successful with a 200 return code, and there are no requests in the log for en.js.

    Concerning the request to check the console for JS errors mentioned here I could use some help here. FireBug does not appear to be available for Firefox 9, and pressing F12 in IE and reloading the page the Script->Console panel is blank. I see no js-related error messages in the Apache error log.

    Concerning the missing sprites mentioned here I can load the file http://localhost/wordpress/wp-includes/js/tinymce/themes/advanced/img/icons.gif.

    I think I've read through all the discussion on the tinymce advance forum here.


  2. Anas
    Posted 3 years ago #

    Solution :
    Step 1 : Change the theme
    Step 2 : Clear the cache
    Step 3 : Go to your editor
    Step 4 : Change to 'HTML'
    Step 5 : Change to " Visual Editor'
    Step 6 : Now you can find the Visual Editor Options
    Step 7 : Change to your original theme

    If Problem Persists, Add ' WP-Super Edit / Use Google Library ' Plugins, then check it. :)

  3. Mark Tuttle
    Posted 3 years ago #

    Thanks. You must be referring to the final sentence of the installation instructions that reads, Set your preferences at “Settings -> TinyMCE Advanced” or “Manage -> TinyMCE Advanced” for WordPress 2.6 and older. Your response is the most polite "read the manual" response I've ever received. :) Thanks.

  4. gilomen2
    Posted 3 years ago #


    i'm having the same problem you described, but i'm having trouble following the steps you tried to fix it.

    were you able to solve the problem and if so, can you please explain again what eventually solved the issue for you?

    Thanks very much!

  5. Mark Tuttle
    Posted 3 years ago #

    What I had missed (forgotten) was that the installation of the TinyMCE Advanced plugin adds a configuration page to the dashboard. Go to Dashboard -> Settings -> TinyMCE Advanced. There I have the ability to drag and drop the new editing buttons I want into the rows of editing buttons in the visual editor. I saved that, and the buttons now appear in the visual editor. I had thought they would appear in the visual editor by default after installation. I had forgotten that I have to choose the buttons I want.

  6. Ilan
    Posted 3 years ago #

    Peace, all.
    Anas's "solution" worked for me. Thanks!
    But then again, this is obviously a bug, and I'd rather get to the root cause...

  7. little_kostas
    Posted 3 years ago #

    You can add your styles in the default tinymce css.

    The file that uses for the default classes that you see in the editor are in the content.css file in:

    Not the best sollution but it works.

  8. webdotcom
    Posted 3 years ago #

    Yea this doesnt work. I tried anas steps too...


  9. photographypool1
    Posted 3 years ago #

    I just installed - uninstalled + deleted cache twice and it worked

  10. cvetkoff
    Posted 3 years ago #

    Anas's "solution" worked and for me. Great respect!

  11. dvaryani
    Posted 3 years ago #

    Hi , I want to you the TinyMCE plugin in WordPress Forum server , so that the users in the forum can make some amendments in their Post is it possible.

    Awaiting your reply

  12. Scott Grayban
    Posted 3 years ago #

    It's a nice plugin but if you use more then 2 rows it doesn't show and the text area is broken.

  13. Scott Grayban
    Posted 3 years ago #

    Actually it breaks with any of the following checked...

    Advanced image
    Advanced link

  14. ModelCarsMag
    Posted 3 years ago #

    I have tried everything here, twice.
    I can't see the visual editor and the HTML editor on the top right of the text/content box in a page on the MacBook Pro 10.6, or the iMac 10.6. However, on the MacBook Air, running Lion 10.7, I can. I have reinstalled, installed, activated, reset cache, etc., nothing works on the 10.6 Mac.

  15. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 years ago #

    Have you tried installing different browser on the 10.6?

  16. annedawn
    Posted 3 years ago #

    similar problem - I tried the fixes and got the tiny mce to dislpy in the visual editor. when i add linebreaks they display on the website. strangely the system creates paragrphes in the html view but they have no effect.

    any idea what else i could do?

  17. miniwod
    Posted 2 years ago #

    I have been struggling with this for 2 days now.
    Have tried everything I can find.
    Disabling all plugins.
    Renaming plugins folder to plugins-old to refresh them.
    Switching to Twenty-Ten theme.
    Making new users of different levels.
    Renaming the language file to en.js and copying it to both locations
    Downloading WP Super Edit
    Hardcoding the paths inside wp-tinymce.php
    Unzipping the gzip version of wp-tinymce.js.gz and putting the.js version in the folder.
    Reinstalling WordPress.

    In FireFox when I open a Page to edit, these errors always pop:
    [20:23:07.256] SyntaxError: missing ; before statement @ http://minimalwod.com/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=349-21274:2
    [20:23:07.594] ReferenceError: tinyMCE is not defined @ http://minimalwod.com/wp-includes/js/tinymce/langs/wp-langs-en.js?ver=349-21274:1

    This is CRAZY that no consensus exists on the nets on how to resolve this. Please, for god's sake, if you have the answer, please post it.

    I think the only thing I *didn't* try was a post about messing with the Unix permissions of the files because that seemed like it would do more harm than good (like the post where someone suggest just commenting out the admin-footer line in the wordpress code--which i tried anyway).


  18. kayb14
    Posted 2 years ago #

    I am having TINYMCE Advanced issues as well. I deactivated and it and cleared the cache and then reactivated and it still is not working. I sure could use some help on this one. The theme is the twenty-ten theme and the Plugin version is 3.4.9 and the WordPress theme is updated to 3.4.2. I would appreciate step by step instructions please.


  19. miniwod
    Posted 2 years ago #

    Sorry to say, but I rebuilt mine from scratch. Good news is that did not take a lot of time. Far less time than hunting the internet for the multiple bug(s) that cause this issue.

    I setup a test site first to make sure everything came out copacetic. It did. Just:

    1. back it up
    2. export the whole blog (Tools-Export)
    3. blow the instance away.
    4. install WordPress+theme+plugins+import blog
    5. redo settings for plugins
    6. chances are you've resolved the issue

    If that doesn't work I suggest a large glass of whiskey.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic