WordPress 3.2 Visual Tab Greyed Out (15 posts)

  1. jdvieira
    Posted 4 years ago #

    The "Visual" tab in new (or edit) post (or page) is greyed out. This is a clean install (new files, new database table, no plugins, default theme).

    Server (archlinux) is running:
    php 5.3.6
    php-apc 3.1.9
    php-fpm 5.3.6
    nginx 1.0.4
    mysql 5.5.13

    Clients tested:

    1. Ubuntu 11.04; Firefox 5.0
    2. Windows 7; Google Chrome 12.0.742.112
    3. Windows 7; Internet Explorer 9
  2. Have you checked the settings for the affected user to make sure the visual editor is not deactivated for some reason? I'm not seeing this behaviour on several clean installs.

    User > Profile > Disable the visual editor when writing

    Try adding a brand new user. Same thing?

  3. jdvieira
    Posted 4 years ago #

    Hello zoonini,

    Yes, I've tried that. It was enabled. I tried disabling and enabling again but the problem persists. I believe it's related to jquery not loading on specific admin pages like add/edit posts/pages.

    What php version are your clean installs running?

  4. 5.3.5 (MAMP) and 5.3.6 (CentOS).

    Next, I would try re-uploading the wp-admin, wp-includes folders, and root WP files to make sure nothing got corrupted during upload.


  5. jdvieira
    Posted 4 years ago #

    Hello zoonini,
    Thanks for your sugestion.
    I tried that multiple times (in despair) but didn't solve the problem. Other users are reporting similiar problems so I guess I'll just downgrade to 3.1.4 and wait.

  6. I would be very curious to log in and take a peek to see if it works over here. I actually haven't seen too many reports like this. If you want, you could send your login deets & URL via my About.me profile, linked from my username.

  7. It could be a PHP issue. A lot more things are shuffled into javascript, and if PHP isn't compiled with json correctly, this could happen.

  8. Ah - interesting. jdvieira - you could upload a phpinfo() file to show if JSON is enabled or not. Look for something like json support enabled

  9. PositiveMostOfTheTime
    Posted 4 years ago #

    ok I just looked at my server logs...I have been having this same problem...this is on a fresh install of 3.2 no plug ins installed. No visual editor, no graphic buttons, no WP logos show up anywhere

    Server says:

    [error] [client xx.xx.xx.xx] File does not exist: /home/xxxxxx/public_html/wp-admin/images/media-button-video.gif/, referer: http://my-url-here.com/wp-admin/index.php

    Any thougts?

  10. PositiveMostOfTheTime - sounds like some files didn't get uploaded at all, or perhaps got corrupted. Try re-uploading the wp-admin folder entirely.

    If you need further help, please continue in the thread you already started here - thanks. http://wordpress.org/support/topic/32-is-giving-me-a-headache

  11. PositiveMostOfTheTime
    Posted 4 years ago #

    Ok thanks will give this a try ...sorry about the dupe threads! Getting desperate!

  12. joshua strebel
    Posted 4 years ago #

    We have seen this issue a few times on page.ly. 99% of the time it turns out to be a javascript issue. Use firebug in firefix and watch the console for errors.

    I wager a plugin or your theme is trying to load jquery, or a version of jquery that is nixing the jquery the editor/core loads.

    We have had to comment out the jquery loads from a few plugins to resolve.

  13. underclass
    Posted 4 years ago #

    We are having this problem, images show up fine in front end but just not in the visual editor

  14. underclass
    Posted 4 years ago #

    I solved this error by setting permalinks to default and removing .htaccess – it had become corrupt with some strange .jpg rewrite rules.

  15. adam_smith
    Posted 4 years ago #

    Have done it but now the whole system has become slow. Can anyone tell why?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.