Support » Fixing WordPress » WordPress 3.2 errors in admin: jQuery not defined

  • Juandbb

    (@juandbb)


    Hello,

    I have three websites based on WordPress on different hostings and the three of them are giving me the same error after upgrading to wordpress 3.2:

    When in admin (the front page works ok, the error is only in admin) I get these two errors:
    missing } after property list in load-scripts.php
    jQuery is not defined

    I have tried disabling the plugins, uploading again the admin folder and changing to Twenty Eleven theme, but no success.

    It’s very strange, but I have one of the three websites in local and it gives no error.

    The three hostings are ok for WordPress installation (PHP and MySQL versions)

    I would really appreciate your help, as I don’t know what else can I do.

Viewing 15 replies - 1 through 15 (of 21 total)
  • iwbyte

    (@iwbyte)

    Exactly what version of PHP do you have? We’re trying to see if there’s an issue with a specific version.

    krispy_b

    (@krispy_b)

    i have the same, in both 3.2 and an untouched (and prev working) 3.14 wordpress install, all 3 on the same server.

    all sites running php 5.3.6 (latest build) on windows 2003, the non threadsafe version running on fastcgi. i have turned off wincache to see if it was that, and rebooted the server, didn’t help.

    krispy_b

    (@krispy_b)

    oh and it effects jquery, and the tinymce javascript, so i can no longer edit / create posts or pages using anything visual

    Juandbb

    (@juandbb)

    Hello,

    Each website has a different version:
    PHP version 5.2.14 and MySQL version 5.0.92
    PHP version 5.2.17 and MySQL version 5.0.91
    PHP version 5.2.14 and MySQL version 5.1.50

    iwbyte

    (@iwbyte)

    @juandbb Well, that doesn’t help 🙁 I was hoping you had PHP 5.3.6 so we had a consistent issue. I’m afraid i’m not sure what you’ve got on there.

    kuzjnvn

    (@kuzjnvn)

    i have same problem with you , now i can add new post remote only , and wait for new update .

    I’m do anything like you , clear plugin folder , disable plugin , but still cant write any thing in add new post page .

    My server is ok for 3.2

    esmi

    (@esmi)

    Forum Moderator

    Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Albert

    (@planetshaker)

    Same problem here! Called my IT Support, there everything worked.
    Tried it in FF5, Safari (newest) and Chrome on Mac. Then tried it on Windows in FF4, same behavior: no JQuery effects.
    THEN tried it in IE8 in Windows and it worked! Strange?!

    Any ideas for that?

    iwbyte

    (@iwbyte)

    Here’s a solution that may apply to you:

    http://wordpress.org/support/topic/new-post-page-broken-linksmenu-expansion-in-32

    Install and enable JSON extension for PHP

    It worked great for me on a similar but not quite the same issue but i’m just grasping at straws here 🙁

    Juandbb

    (@juandbb)

    Hi planetshaker, yes it works with IE8. Strange…

    xabierrolan

    (@xabierrolan)

    Same problem with mac browsers… able to edit post on IE8 (running under virtualization)…

    What was the cause and the solution to this issue?

    I’m having the exact same problems, I even tried a fresh wordpress install (3.1) and worked fine, I did the live upgrade to 3.2.1 and stopped working. No premium themes or any plugins installed, just the default plugins and twenty-eleven.

    I can’t edit posts using Firefox 6, can’t drag widgets, the dropdowns don’t work in the admin panel…

    In Firebug I see these errors when I click on any option in the admin panel:

    missing } after property list
    http://mydomain.org/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=fb5c271ac01e8186b23ece33d5ce4961
    Line 2
    http://mydomain.org/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=fb5c271ac01e8186b23ece33d5ce4961

    And plenty of errors like:

    jQuery is not defined
    http://mydomain.org/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,suggest,wp-lists,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,post,thickbox,media-upload&ver=87a4c4284991be39a40fcf5225c50d94
    Line 1
    http://mydomain.org/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,suggest,wp-lists,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,post,thickbox,media-upload&ver=87a4c4284991be39a40fcf5225c50d94

    It’s working in IE9, though…

    Albert

    (@planetshaker)

    It helped to clear all cache and reload the page again. Now I have it working in all browsers!

    Thanks for rreplying, PlanetShaker!

    Unfortunately, that didn’t work for me. I emptied the cache completely, but I still receive the same errors.

    Any additional sugegstions?

    Albert

    (@planetshaker)

    I think it’s just because the new jQuery, which is used here, is not being loaded correctly. Try it on other computers. What happens?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘WordPress 3.2 errors in admin: jQuery not defined’ is closed to new replies.