WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress 3.1.2 Permalink Problem (24 posts)

  1. Eff Ess
    Member
    Posted 2 years ago #

    I've been developing a couple of websites locally and installed the latest version of WordPress - 3.1.2.

    When I attempted to look over the sites to make sure everything was running correctly, Only the main page of the website was viewable. The blog section could not be accessed and kept throwing up an error 404.

    The strange thing is, when I go to a particular post and save it back to Draft, it is then possible to view it. When published, nothing.

    I changed the permalink structure from /%postname%/ back to the WP default, low and behold, everything is running as it should. However, this particular structure is not suitable for the running of the website and I need to use the /%postname%/ permalink structure.

    It would appear that this latest version of WP has broken the permalink structure in some way.

    Is there a workaround for this does anyone know??

    Thanks in advance.

  2. govpatel
    Member
    Posted 2 years ago #

    Is mod_rewrite ON in your Apache

  3. Eff Ess
    Member
    Posted 2 years ago #

    Yes it is on Govpatel. Everything was working perfectly prior to this upgrade. :)

  4. govpatel
    Member
    Posted 2 years ago #

    I do not have any problem and I am using the same version
    with /%postname%/ in custom structure.

  5. Eff Ess
    Member
    Posted 2 years ago #

    Well I'm happy to hear your having no problems with the permalink structure. The fact that I am after this upgrade is all that matters here.

    As a rule, most WP installs go fairly well. This is the first time in 10 years that I have any kind of problem.

    I am looking for a solution here.

  6. Eff Ess
    Member
    Posted 2 years ago #

    It's been resolved.

  7. govpatel
    Member
    Posted 2 years ago #

    Can we know what you did to solve the problem

  8. ollesvensk
    Member
    Posted 2 years ago #

    Been experiencing the same problem. It works with the default permalink structure, but not with any modified. so Eff Ess, if you've came up with a solution it'd be great if you could post it.

  9. g01010
    Member
    Posted 2 years ago #

    I just upgraded a site from 3.1 to 3.1.2. I found that pages were fine but custom posts returned 404.

    Downgrading to 3.1 fixed it.

  10. nbablogs
    Member
    Posted 2 years ago #

    How do you downgrade back?!

  11. g01010
    Member
    Posted 2 years ago #

    I followed the process for manually upgrading - http://codex.wordpress.org/Updating_WordPress - but used an older version of WordPress instead of a new one.

    However, for this particular permalink problem, I'm not convinced it's a 3.1.2 problem. If you find that your custom posts return 404, try clicking Permalinks in Settings in the Admin, then reloading your custom post page.

  12. nbablogs
    Member
    Posted 2 years ago #

    What about the fatal error problem

  13. bigbt25
    Member
    Posted 2 years ago #

    I am having the same problem now also. My custom Permalink structure is "/index.php/%postname%/" If I change to use the default Permalink, everythign works great. Anytime I change to one of the other permalinks, I receive the 404 errors.

    What other options are there, other than downgrading?

    - Brendan

  14. govpatel
    Member
    Posted 2 years ago #

    Try just /%postname%/

  15. bigbt25
    Member
    Posted 2 years ago #

    Gov, thanks for the quick feedback, but no luck. :( I still receive the same error. Did you have to change any other code (i.e. function.php) to get this working?

    http://sjrtheater.com/btw/

  16. govpatel
    Member
    Posted 2 years ago #

    Check with your host if they Mod_rewrite ON as that is what you need to rewrites links.

  17. bigbt25
    Member
    Posted 2 years ago #

    I have the same theme installed on that server in a different folder, but it is on WordPress v3.0 It is working fine with the Permalink redirection.

    http://sjrtheater.com/sjr/

  18. govpatel
    Member
    Posted 2 years ago #

    try and rename .htaccess file and then reset your permalinks

  19. bigbt25
    Member
    Posted 2 years ago #

    It's a windows server, so there is no .htaccess file.

  20. bigbt25
    Member
    Posted 2 years ago #

    Just an update. I found a plug-in which you can download and then upload to WP. It fixed the problem... :)

    http://wpcodesnippets.info/blog/wcs-custom-permalinks-hotfix.html

  21. Luke America
    Member
    Posted 2 years ago #

    @bigbt25:

    Thanks for the bump. Glad the plug-in worked for you. My tracking indicates that it solves the issue for about 85% of the WP installations that suffer from the bug.

    Hopefully, the WP team will implement a permanent fix in the 3.2 upgrade. Well ... er ... ah ... restore the functionality that was used for the last 3 years. :)

    Nonetheless, because of the way I coded the hotfix to use internal canonical URI structures, it should work in perpetuity.

  22. thebosscv
    Member
    Posted 2 years ago #

    Hi all,

    thanks, for your help as govpatel said this error is not a problem of permalinks in other mode but a problem of mod_rewrite of apache is off.

    I tested it on the version wp 3.1 and 3.1.2 and if you have mod_rewrite off both error accur, so in order to solve this issue on both version you have to do the follow:

    1 - go to the httpd.conf file: F:\wamp\bin\apache\Apache2.2.17\conf\httpd.conf
    2 - open the file and uncommented the follow line:
    #LoadModule rewrite_module modules/mod_rewrite.so -default version
    LoadModule rewrite_module modules/mod_rewrite.so - uncommented
    3 - now i

  23. thebosscv
    Member
    Posted 2 years ago #

    3 - now it will work ok :)

    Once again thanks for your help

    Regards,

    theboss

  24. roger.bankes
    Inactive
    Posted 2 years ago #

    I have applied the fix but still get 404s on Permalinks. The current discussion is at

    http://wordpress.org/support/topic/cannot-find-page-after-changing-settings-to-use-year-month-name-system?replies=2#post-2140277

Topic Closed

This topic has been closed to new replies.

About this Topic