Support » How-To and Troubleshooting » WordPress 3.1.1. but still HTTP error with flash-upload

WordPress 3.1.1. but still HTTP error with flash-upload

  • Hi all!

    I just updated to 3.1.1 and I know there are already some posts but there is also no real solution (I think).

    When trying to use the Flash-uploader I still get the HTTP error.

    How can I fix this problem. I already tried a lot “fixes”…

    Thanks for ideas! šŸ™‚


Viewing 15 replies - 1 through 15 (of 36 total)
  • esmi


    Forum Moderator

    Hi esmi

    Thanks for trying to help but maybe I expressed wrong.

    I can upload with the normal Browser-uploader – this works perfect!

    But when I try to switch to the Flash-Uploader I get the HTTP error in red!

    The “solution-link” you provided is only fixing the issue “no upload at all”.

    Many posts in the internet have the same problem but it seems that this is a serious wordpress problem.

    Does somebody knows a working flash-fix? (In my opinion i has nothing to do with Mac or PC)


    I have the same problem as this and been looking for a answer but no luck so far.

    Now the 3.2 update is nearly waiting and I hope for a solution! šŸ™‚

    Hi, I have the same problem and I solved it temporary via Flexupload multithread uploader plugin.
    But still waiting a real solution.

    Thanks, but Flexupload wasn’t able to solve that problem…..

    Update: Installed WP 3.2 but sill http error…

    I have the same problem, but it is with all files. It worked then i did something and it stopped working

    I am working on it and will psot with my fix when i find it, but heres a few brain dumps so that others may have ideas

    1) It could be a plugin ( there was a post online stating that a plugin applied a security mod to .htaccess that screwed flash player security rights)
    2) .htacces file that works on my old site have module loads for the upload.php file, but this doesnat appear to work on my latest wordpress

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Regards mccay_A

    Dear All
    Now I use WordPress 3.2.1 with flash player for chrome and for other browsers and I try all suggested fixes here but with no luck, I am still have the issue mentioned by rangitoto.

    moreover when I add AddType x-mapp-php5 .php to my .htaccess file and try to upload image via flash uploader I got this

    post_type ) wp_die( __( 'Unknown post type.' ) ); $post_type_object = get_post_type_object( 'attachment' ); if ( ! current_user_can( $post_type_object->cap->edit_post, $id ) ) wp_die( __( 'You are not allowed to edit this item.' ) ); if ( 2 == $_REQUEST['fetch'] ) { add_filter('attachment_fields_to_edit', 'media_single_attachment_fields_to_edit', 10, 2); echo get_media_item($id, array( 'send' => false, 'delete' => true )); } else { add_filter('attachment_fields_to_edit', 'media_post_single_attachment_fields_to_edit', 10, 2); echo get_media_item($id); } exit; } check_admin_referer('media-form'); $id = media_handle_upload('async-upload', $_REQUEST['post_id']); if ( is_wp_error($id) ) { echo '
    ' . __('Dismiss') . '' . sprintf(__('ā€œ%sā€ has failed to upload due to an error'), esc_html($_FILES['async-upload']['name']) ) . '
    ' . esc_html($id->get_error_message()) . '
    '; exit; } if ( $_REQUEST['short'] ) { // short form response - attachment ID only echo $id; } else { // long form response - big chunk o html $type = $_REQUEST['type']; echo apply_filters("async_upload_{$type}", $id); } ?>

    in textarea instead of image

    I still waiting true solution for this issue

    God bless you and Best regards

    Hi Again
    After I posted the issue that I faced above, I’ve continue digging out for a solution, I am trying using three different OS’s : winXP, win7 and ubuntu with google chrome the browser that I love, On the ubuntu the flash uploader works fine without any error, but on winXP and win7 it’s encountered an error HTTP Error after uploading one image, moreover when I used IE on both OS’s the uploader works as charm
    Finally I realized that the above issue causes by the fash plugins not in flash activeX, I am not sure if this is a bug in flash plugins and should be reported in adobe.com site because that I was used the uploader in the past with chrome without any error
    I hope this post help someone in somehow



    nice Job – thanks for testing!
    have you reported it to adobe?



    nice Job – thanks for testing!
    have you reported it to adobe?


    No, not yet


    Hello there

    I am using WP 3.2.1, fresh copy without any plugins or themes installed and i still get the same error. It seems that is a server configuration problem because when i try to upload an image to website that is hosted to another provider it works. One provider is using CentOS with Cpanel another is using Plesk (works on plesk).

    I hope someone from WP could resolve this bug. I want to mention that this error is only appearing to certain images, but i wasn’t able to determine an pattern.

    I tried all (and belive me i spent 3 days on this one) solution provided here and on other blogs, but still no success. Can anyone tell me a fix?

    Regards gents.


    I am using WP 3.2.1, fresh copy without any plugins or themes installed and i still get the same error

    What’s your browser ?? your OS ?? you don’t mentioned any info about that




    Forum Moderator

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘WordPress 3.1.1. but still HTTP error with flash-upload’ is closed to new replies.