Support » Fixing WordPress » WordPress 3.1 stable – can't view post excerpts or custom fields

  • Resolved Curtis

    (@curtis782)


    Is anyone having an issue viewing the excerpt and custom fields when they add/edit a post? Using 3.1 stable, downloaded today.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am having the exact same issue. 3.1 stable, downloaded today, running the Prototype theme.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Look in the top right corner of the screen. There’s a Screen Options link. Click it to open the drop down. Turn on the excerpt and custom fields boxes if you want to see them.

    Why don’t i see screen options?

    I’m having the same issue but there’s no screen options link. I checked my other WordPress blogs and the screen options link appears in all of them, as well as everything else.

    I disabled all the plugins on my blog and the issue still exist. I went to my profile and checked the box “Disable the visual editor when writing,” then clicked “Update Profile.” Next, I unchecked the same box and clicked “Update Profile” again. The issue still exist so now I don’t know what else to do. I also, updated WordPress 3.1 again and that didn’t correct it either.

    I have been using the Mozilla Firefox browser and recently installed the new update — the issue still exist. I tried the Safari browser and behold the post excerpts or custom fields and Screen Options link are visible.

    So there seems to be a conflict between that one WordPress blog and Mozilla Firefox. I am completely baffled by this!

    Once final note, any link I click such as Post, Appearance, Tools, Settings or whatever, I get this odd appearance as if the form isn’t going to display completely but then it does. This may be all related to the issue.

    Any ideas on how to correct this will be greatly appreciated. In the meantime, I’ll continue my research.

    Are you enqueuing any javascripts in your theme? Out of interest, if you are, try commenting out the custom scripts to see if you can see screen options after that. I’ve had the occasional issue with various admin panels, caused by some extra jquery.

    Hello SpankMarvin,

    Thanks for responding. I’m not sure what that means… “Are you enqueuing any javascripts in your theme?” I’m using a Semiologic 0.9.6 theme by Denis de Bernardy for my blog at http://internettvdotcom.com. I haven’t done anything to the theme that I know of that could have caused the issue. Everything worked just fine until the last 3.1. upgrade.

    But you could be on to something because QuickPress in my dashboard isn’t showing either and is telling me “This widget requires JavaScript.”

    Keep in mind, this issue only occurs when using my Mozilla Firefox browser for that one blog, not my other WordPress blogs. Also, everything appears just fine when using my Safari browser.

    I even tried using the WordPress default theme “Twenty Ten” and still no Custom Fields and Help links.

    Does disabling the Semiologic plugin correct the issue? If so, must be a conflict going on with that plugin.

    I’m having the same problem, I dont have ” add new custom field ” in edit > post option’s. Did anyone find a solution by any chance?

    Hello SpankMarvin,

    There’s no Semiologic plugin to disable but I went as far as replacing my theme with the WordPress default theme mentioned earlier. That didn’t do the trick either. I’ve been using this Semiologic theme for a few months now and had no problem with it until now.

    Right now my thinking is there could be something wrong with my Mozilla Firefox browser, since the issue seems to be associated with Mozilla and Semiologic theme. All my other WordPress blogs work fine but they don’t have the Semiologic theme and the exact same plugins.

    There’s another issues where a few widgets on the Semiogic theme don’t appear anymore in Mozilla, such as Twitter and Sharebar widgets but everything works okay in my Safari browser.

    At the moment, I’m waiting to hear back from Mozilla support. Hopefully, they can help me resolve this puzzling issue.

    RESOLVED!… EVERYTHING BACK TO NORMAL…

    The issues I was having are now fixed and had nothing to do with plugins, template, or WordPress. I uninstalled and installed the Mozilla Firefox browser again, but this time created a new profile which corrected everything.

    Here’s the source that helped me correct the problem (#6, #7 & #8)…

    http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting

    Hey guys, I wasn’t able to see custom fields, whatever browser I worked with. Then I found out that you can see the custom field item only in the Option Screen of “New Post”. After you have set them on, you’ll see them also in the editing panel of old posts.
    It’s simple… if only you know it!

    Deactivate Jetpack. Add custom fields, reactivate Jetpack.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WordPress 3.1 stable – can't view post excerpts or custom fields’ is closed to new replies.