[resolved] [closed] wordpress 3.1 new install: can't create subblogs (29 posts)

  1. sortofme
    Posted 5 years ago #

    I have upgraded a multisite to wordpress 3.1 and that worked fine, but then created on another Domain a fresh install of WP3.1, followed process for enabling multisite, but the subblogs I create (admin and frontend) are not found.
    also in the blogs.dir folder, no new folders get created when I add a new blog (permissions 777).
    I use .htaccess from Network admin->settings->Network setup.
    I chose subfolders as network option.
    otherwise clean install, no plugins except maintenance mode.

  2. Are the DB tables being created?

  3. also in the blogs.dir folder, no new folders get created when I add a new blog

    And they will not. This folder is not where blogs will live - they are *virtual*. this folder is for media up-loads ONLY.

    Subfolder blogs are based on your htaccess file. If your server isn't reading it properly, there's your problem.

  4. sortofme, do you mean the blogs.dir/NUMBER/files folders or something else?

  5. praeix
    Posted 5 years ago #

    I'm having a similar issue. Here's what I've done so far:

    1. I just installed a fresh copy of WP3.1 and setup the multisite network on it (to point to subdirectories) with no issues.
    2. wp-config.php and .htaccess contain exactly what the install told me to put in there.
    3. In Network Admin->Sites->Add New, I created a new site named "newsite" to point to the subdirectory "newsite".
    4. It told me the site was setup, I can access the dashboard of the newly created site, it sent me the email confirmation, etc. At this point, I didn't check if the outward facing site was live.
    5. I then went in to my hosting (GoDaddy, although don't read too much into that because I have a totally different WP3.1 install that I've made this work before with GoDaddy) and created a domain to point to the "newsite" folder.
    6. After giving some time for that to propagate to DNS, I attempted to access it directly and it gives me a Forbidden 500 error. I then attempted to access it through parentdomain.com/newsite/ and that gives me a 404 error.
    7. This is where I'm stuck. The sites don't have any data on them, so I could delete the entire thing and start over, but I'm curious as to how I could make this same setup work with a different hosting account, but this one isn't. Any ideas are greatly appreciated and welcomed.

  6. praeix - Same question. Did the DB tables get created?

  7. sortofme
    Posted 5 years ago #

    @Andrea_r: sorry, I thought blogs.dir/NUMBER/files/gets created on blog creation, not first upload of media to the new blog.
    @Ipstenu: no tables are created.
    still stuck with that.

  8. sortofme
    Posted 5 years ago #

    @praeix: deleting and creating a new blog does not help. I also notice anoterh weirdness while creating the sub-blog: I entered an email adress as blog admin.. and it adds a new user, with the blog name as user name. this can later not be changed though.(might be a new thread)

  9. sortofme
    Posted 5 years ago #

    interesting: since I installed WP database manager, the tables DO get created... might have been a wrong info before.

  10. praeix
    Posted 5 years ago #

    @Ipstenu - It appears as though my database is all out of whack. There are a total of 43 tables in there (should be more like 17 or so by my estimates). I don't believe that I deleted my previous WP install tables (3.1 beta) before I installed 3.1 final release. I'm going to empty my database and re-install.

    @sortofme - mine appears to have done the exact same thing. There is a new user named "newsite" on mine, which is the same name as the subsite itself.

  11. praeix
    Posted 5 years ago #

    @Ipstenu & @sortofme: I emptied my database, deleted all remote server WordPress files, reupped them and went through it again and now everything works just fine.

    I really think my issue was having the old install tables of WordPress 3.1 beta in there.

  12. @praeix Shouldn't have mattered, unless you're using the same DB for a totally separate install with the same wp prefix... that might do it.

    The new user newsite is as it should be. When you register for a new account AND a new site at once, the default name of the new site is your username.

    @sortofme - Sounds like DB weirdness, like it's detecting the wrong site or something. That really is weird! You don't have multiple installs on one DB do you?

  13. praeix
    Posted 5 years ago #

    @Ipstenu: I might have jumped the gun initially on my last post. I did empty the database table and reinstalled WP3.1, and it WAS working, but now it's right back to where it was again. I think before it was using the same prefix in the database, but this time it shouldn't have.

    Would attaching a domain to this subsite cause any issues? For instance, the root domain (for example) is domain.com/ The subsite is at domain.com/newsite and I want to attach newsite.com/ to the new subsite. Would this be causing 500 and 404 errors when I attempt to access it? And also, why would it work immediately after I did the reinstall and not work 1 hour later?

  14. No, pointing a domain would NOT cause this, but I cede to Andrea, who's savvier at that than I am.

    That it suddenly STOPPED working sounds like your DNS is acting up.

  15. praeix
    Posted 5 years ago #

    @Ipstenu: I appreciate your help here. I double checked and the database tables were created properly, all settings appear to be in order... So, I'm going to give it some time before I go changing anything else with the DNS. I know it can take up to 24-48 hours to propagate, so if it's still acting up in 2 days, I'm going to contact my hosting and see if this can be resolved. Will post any useful info I find. Thanks again!

  16. @praeix are you using the domain mapping plugin to "attach" your other domain to the subsite? If not, that could be why.

  17. sortofme
    Posted 5 years ago #

    Ha!! solved. NOT a wordpress bug. I am using a dedicated Server, and my server admin had to add this to vhost section in apache config, to force Appache to search for htaccess files.
    @praeix, this might also be your solution. Let us know if it is.

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    Allow from all

  18. praeix
    Posted 5 years ago #

    It's been 2 days and my issue still exists, so it wasn't the DNS propagating that was causing the issue...

    @andrea_r: I'm currently not using any plugins for domain mapping. I know you've suggested that to me before on other forum posts, but I thought all that would need to be done for the domains could be accomplished through the cpanel on my hosting... I'll give it a shot.

    @sortofme: I'm on GoDaddy shared grid hosting and (as far as I know) don't have access to edit/change anything with httpd.conf or anything of that nature. I do know that they allow you to modify .htaccess, but if the problem is that it's not properly reading .htaccess, that kind of puts the kibosh on that... I'm not a server guru, can you please explain what those directives mean?

    I'm going to try the domain mapping plugin first and see if that works. However, if not, I'll revisit the configuration stuff to see if there's something going on in there.

  19. but I thought all that would need to be done for the domains could be accomplished through the cpanel on my hosting... I'll give it a shot.

    no, because internally WordPress needs to know where to go. and on the server side that folders/subdomains are virtual, so you can;t really tell them to go somewhere specific.

    I'm immersed in domain mapping all day. I have a handful of sites that are all domain mapped. This is what works.

  20. praeix
    Posted 5 years ago #

    I suppose now that I think about it, that makes sense. I couldn't figure out why pointing it to a folder location (that I thought existed physically) wouldn't work. Which domain mapping plugin do you prefer Andrea?


  21. well considering I sell one, my answer is obviously biased...

    but Donncha's is fine.

  22. praeix
    Posted 5 years ago #

    @Andrea_r: thanks for all your help here. I finally figured it out. Hopefully this might help anyone else looking.

    I had already read Otto's article (http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/) on this and thought that I followed all the steps verbatim, but I missed the part that said it wouldn't work if you install the plugin from the plugin menu. You absolutely HAVE to install this manually as it states in the article.

    Another article that helped me tremendously was to read this one:
    http://gmichaelguy.com/blog/2010/11/28/my-wordpress-3-0-multi-site-domain-mapping-with-godaddy/. Since I'm on GoDaddy shared hosting, this made perfect sense.

    Hope that helps somebody else out there and thanks again everybody!

  23. Andreas Beer
    Posted 5 years ago #

    Since I updated to 3.1 my multisite is giving me a funny (well, not really) answer when I try to install another subdomain blog.

    After the usual procedure there is a white screen that asks me "Do you really want to do this?" As the only choice for an answer it give me a link labelled "Try again". That link gets me back to the network admin dashboard but the new blog doesn't appear.

    It says this in my .htaccess

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    and this in wp-config

    define('WP_MEMORY_LIMIT', '512M');
    define('WP_DEBUG', false);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.smmp.de' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'SUNRISE', 'on' );
    define( 'WP_POST_REVISIONS', FALSE);
    define( 'EMPTY_TRASH_DAYS', 5 );

    Any ideas why I can't add a new blog?

  24. Andreas - Make a new topic eh? If something is RESOLVED, it means we don't need to keep tabs on it anymore :)

    Start with turning off all your plugins. If that doesn't help, make your own topic, please and thank you :)

  25. Andreas Beer
    Posted 5 years ago #

    Grmpf. OK.

  26. Donald McIntyre
    Posted 4 years ago #

    @Ipstenu and @Andrea_r I have WP 3.2.1/BuddyPress 1.5.1/Multisite I have been creating sites with no problems from the Network Admin > Sites > Add New, but suddenly today it is happening exactly what was described above:

    1. The site appears to be created
    2. Try to go to the site and "Error establishing a database connection"
    3. The "Visit Site" link points to "http://www.pilarsocial.com/wp-admin/network/sites.php" instead of "http://www.pilarsocial.com/newsite"
    4. I checked the dbase and it didn´t create the tables
    5. Absolutely weird: From the BuddyPress Main site on the front end at http://www.pilarsocial.com/sitios/create DOES WORK!! (it´s transalated to Spanish)

    Summary: from the back-end it is not possible (suddenly) to create new sites.

    I read this and other topics that say "resolved", but because I am not programmer I don´t know what is the solution!

    Can you help me please?

    Thank you, Donald.

  27. Donald McIntyre
    Posted 4 years ago #

    I checked my .htaccess files and they had dissappeard!! I tried to create new and they are deleted in a flash!! that is the problem... Is it WordPress or is it the host (DreamHost)

  28. Donald McIntyre
    Posted 4 years ago #

    @Ipstenu my multisite ad new is not creating the new databases, all the rest is ok (.htaccess, wp-comfig.php, etc.) I created the new .htaccess that disappeard above, but to no avail. DreanHost works perfectly with multisite and haven´t changed any policies. I am lost. The only thing that I can tell you is that on new site creation no new tables are being created...that´s for sure. I saw that you tried to ask this several times above, but no one answered directly. But it is that, no new tables created.

    Can you help me please?

  29. donmcint - You too should make a NEW topic.

    Guys, come on, a topic is flagged Resolved, that's a huge hint, innit? I'm closing this.

Topic Closed

This topic has been closed to new replies.

About this Topic