Support » Fixing WordPress » WordPress 301 not working (maybe related to SSL?)

  • I’m having a very strange issue in a new website I am working on.

    This is the first time I had to work with SSL in a WordPress environment. Basically, my setup involves the free SSL offered with CloudFlare paid services and a setup mainly via “W3 Total Cache” and “CloudFlare Flexible SSL” plugins.

    I don’t know if this may be related to the 301 redirect issuse I’m having, but this is my best guess.

    First of all, the issue is NOT related with 301 redirect from http to https: this is working totally fine.

    The problem is: this WordPress website is an eCommerce store, which was previously online using Magento platform. We moved to WordPress and now I need to properly 301 redirect all old pages to new ones, so we stop losing juice and visitors.

    The problem is, I just can’t seem to make .htaccess redirect from old pages to new pages work! I also tried several 301 redirect plugins for an easy fix and even my preferred one (Simple 301 Redirects) didn’t help me out this time.

    This is an example of URl I need to redirect: http://abracei.com.br/decoracao/cofre-mini-geladeira.html

    This needs to be redirected to: https://abracei.com.br/cofre-mini-geladeira/

    I tried to use RewriteRule many times in several ways, but it didn’t work. Note that we have several problems here:

    HTTP is already redirecting to HTTPS;
    the old URLs are being called in HTTP…this means any new rule we apply should specify the redirect to the new HTTPS URLs;
    we have a .html by the end of the old URLs.
    Although I’m a developer, I don’t have much experience with this kind of 301 redirects and I hope someone can help me to achieve these results. 🙂

    Thanks A LOT for your time and advice!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘WordPress 301 not working (maybe related to SSL?)’ is closed to new replies.