Support » Fixing WordPress » WordPress 3.0 upgrade static page not working

  • I recently upgraded to 3.0 from 2.8.3 and now my static page settings are not working. I have chosen the page I want to display as my homepage in the Reading Settings and click apply its stays. Also the d database (at least where I knew to look) seems to save the settings but when I visit the site its not the page I selected.

    Anyone else experience this problem??

Viewing 14 replies - 1 through 14 (of 14 total)
  • Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    I didn’t want to believe it but it was a plugin, now the hunt to find the culprit.


    The plugin that cause issues with my 3.0 configuration was User Messages. After disabling that plugin my static page settings began working again. I am using the older free version available here, the updated commercial version works in 3.0.

    I’ve experienced a similar problem after upgrading to WordPress 3.0. The problem in my case was in the “Bueno” theme, from Woo Themes.

    In the Reading settings I was specifying a frontpage (home) and a posts page (blog).
    After the upgrade, the posts page started showing the content of the home page, but formatted as it if were a post. Very strange.



    I suspect the culprit is the Redirection plugin. See this post –

    I am having the same problem with “Gotham news” from Woo themes.

    In the Reading settings I was specifying a frontpage (home) and a posts page (blog). After the upgrade, the posts page started showing the content of the home page, but formatted as it if were a post.

    My plugins are all deactivated. I’ve deactivated them before upgrade so i don’t believe it’s some of the plugins that cause the problem.

    On Woo themes said that it’s WordPress bug and that they are waiting for the fix, but when i switch to Twenty Ten posts page shows the right content.

    So, is this a WordPress bug or theme has to be changed some how?

    If you need i can post a link to snapshots of how our blog looks like after upgrade with these themes.

    I would appreciate any answer because we want to upgrade our WordPress as soon as posible.

    Thanks in advance

    I’m having the same problem! I’m using the newest version of wordpress… I want to see the comments, but I get directed to the homepage.

    I can’t get the comments or “post a reply” to show upon the blogsite. The “post a reply” shows up on my portfolio site where I have enabled comments though. But I can’t get any comments to show up right.
    I tried installing a plugin for comments too called “IntenseDebate”, but that too would only work on other sites, and not where I have my blogposts…

    It’s getting frustrating.

    I just started working on the site, and there is lots to do still…Here’s the link: I’m pretty new at this (although I have some webdesign class skills) so I’d really appreciate any small tip or help you might have.


    Same problem, no plugins. Works on default theme and Hybrid parent themes, but not on Hybrid News child theme 🙁

    I had this problem too on a custom theme.

    I solved it by changing the name of the template file that presents the home page.

    The bug occurs when the the template file for the home page is named “home.php”. The blog posts page will use that template, even if it is specified to use a different template.

    When I renamed the home page template file from home.php to page_home.php, the blog posts page used the correct template.

    This is clearly a WordPress bug. It may not appear in all themes because it is based on the file names of specific template files. In essence home.php is a reserved word and should not be used.

    Henry – You’re describing a wordpress feature, not a bug. I mean this in the sense that home.php is documented as a reserved name for a template file. See the template hierarchy.

    I see. I do wonder, since the existence of home.php reproduced the problem described in this thread whether it’s really working as it should.

    Consider: In the admin “Reading” settings I set the Front Page to be a static page. I assign a page to be the Front Page. It works fine. I create another page named “Blog” that uses a template named “Blog” with a filename of “blog.php”. But when I go to the published “Blog” page I find that the it is ignoring its assigned template and instead using “home.php”.

    Is this really how home.php is supposed to work?

    Hi Henry,
    In order to induce the behaviour you’re describing, you would also need to set “Blog” to be your blog’s Posts Page.
    It’s important to note the distinction between home.php and front-page.php. The front-page.php template will be called for the front page of the blog, whether that is a static page or a posts page. home.php will never be called for a static page. It is for your blog’s Posts Page, which may or may not be the front page.
    I think the behaviour makes sense, but perhaps the name home.php is a bit misleading.
    Again though, the template hierarchy is a useful reference document. Particularly this bit.

    I seem to have the same problem with a theme that has no home.php or any other special template files.

    twenty ten works but not my new theme that only has about 5 files.

    This hack seems to have done the trick. Shame we are hacking something as far along as 3.0

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WordPress 3.0 upgrade static page not working’ is closed to new replies.