Support » Networking WordPress » WordPress 3.0 Multisite using sub-directories not creating

  • Good Evening All,

    I’m using dreamhost and have installed wordpress using their advanced option of the one click installers. It is in sub-directory WP.

    I have setup multisite and have the superadmin menu and the option to create sites using sub-directories.

    However when I create a site i enter:
    ‘TBLog’ into the site address field

    and then an appropriate site title and email address (tried with existing and non-existing user email)

    It then goes through and creates according to the console but it gives the site url as: http://mysite.commysite_com_1tblog

    which is not a valid url.

    I cannot see where it has actually tried to create the site at all and I cannot make the site work.

    I’m not sure what exactly i’ve missed but am sure it is probably something small.

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 36 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    “I’m using dreamhost “

    If you are on their bottom-line shared hosting package they may not support it.

    Also, the blogs are virtual, and not created in folders on the server. they work via mod_rewrite and the htaccess file.

    but. Some shared hosts are preventing it from working if they don’t want to support it.

    g’day thanks for your reply.

    what i have found on dreamhost is that their policy does not specifically prevent multisite using sub-directories. they just don’t let you have wildcard dns without purchasing a private server.
    http://discussion.dreamhost.com/thread-126948.html?highlight=multisite

    My understanding is that I do not require wildcard dns to use multisite via sub-directories.

    To me everything appears correct except when i actually try to create the site it does not make the path correctly.
    For starters it misses the \ after the mysite.com

    Would this be something to do with the mod_rewrite and htaccess file?

    Could it be permissions related?

    just trying to establish what i should be looking at to find the cause of my problem.

    Thanks.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    I’ve been dealing with the same issue in other threads, and the thing most people have in common is Dreamhost.

    no, you don’t need the wildcard subdomains to use subfolders. that doesn’t preclude DH doing something to disable even subfolders being run properly. The wildcards is a good technical reason for them to not allow it on the shared level.

    Yes, the blogs are created using mod_rewrite and reading the htaccess file. Everyone I’ve checked so far has the right settings.

    I have just decided to install wordpress twice because I only wanted two sites.

    Thanks for your help.

    I am unable to create blogs within WordPress 3.0.1. Here’s what I’ve done so far: I did a complete removal of previous installation of WordPressMU (including the database). I did a clean install of WordPress 3.0.1., I “created a network” as instructed via the online documentation. with updating the .htaccess file and the wp-config.php file. When I add a new “site” everything appears normal until I try to go to that site and I get the 404 error page not found. I had no problem with creating new sites with WordPressMU, no changes have been made to the server. Any ideas or suggestions on how to get my new sites to show up online?

    Thanks for the help.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Subfolders or subdirectories?

    subdirectories not subdomains

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Crap. I’m hoping this is not a bug, but if they worked in wpmu and not now, evidence is starting to pile up. :-/

    Check these things:
    – pretty permalinks work
    – mod_rewrite is enabled
    – AllowOverride FileInfo Options is in the vhost entry for that domain (it forces mod_rewrite to pay attention to the htaccess file)

    Hello, I’ve got exactly the same problem as Troberts. Andrea, I would like to follow your advice, but I don’t understand your sugesstions – I am a new user of WP.
    So, how to check if permalinks work and mod_rewrite is enabled?

    Thanks in advance

    Probably the problem is in .htaccess file. I didn’t update the file as sugessted (because I didn’t find it), so I created .htaccess.txt with all the staff sugessted in online documentation and put it into server via my ftp client. Everything seems to be OK, but my sites don’t show up online.

    What shall I do?

    mod_rewrite is enabled, AllowOverride FileInfo options in vhost is set to ALL. I am not sure about pretty permalinks, as I’ve not really used them before. However, I went into the Permlinks module and made a change, I received a pop up message that the change was successful.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    so I created .htaccess.txt

    It has to be .htaccess with the dot in front, just exactly like you see it. Take the one you created with the .txt at the end and rename it.

    I did it, but I have only text on my blog, without theme. I am doing sthg wrong, but I don’t know what’s that. Any sugesstion?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    @benek71 – tell your webhost you made htaccess changes and they are not happening.

    Any additional ideas/thoughts on my problem with my sites not showing up online?

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘WordPress 3.0 Multisite using sub-directories not creating’ is closed to new replies.