Global Translator
WordPress 3.0 Menu Editor slow or stuck with Global Translator (7 posts)

  1. Josh Leuze
    Posted 6 years ago #

    Since updating to 3.0 and adding a custom menu, the menu has been running very slowly. After adding too many links the menu editor freezes and goes to a white screen.

    All other parts of the admin area work fine, as does the front end of the site.

    I found this post where it says the problem is caused by Global Translator.

    I tried disabling Global Translator and that fixed the problem with the menu editor.

    Couldn't find any other reports of this, has anyone else had this problem?


  2. Griff Wigley
    Posted 5 years ago #


    I haven't seen the white screen you describe but after adding a few dozen pages to the custom menu, every gets VERY slow, eg, takes forever to just SAVE. The rest of the WP dashboard pages/functions are zippy.

    I don't have the Global Translator plugin installed.

  3. Josh Leuze
    Posted 5 years ago #

    Hi griffin, from my tests, I confirmed from my tests that the problem I was having was a conflict with Global Translator.

    But your problem could be a conflict with another plugin. I'd suggest deactivating all of your plugins and testing the menu editor. It could also be a theme conflict, I'd try switching to the default 2010 theme and testing it as well.

  4. WPJunky
    Posted 5 years ago #

    I can confirm deactivating Global Translator allows my menu to be saved and edited. The white screen of death does not happen when this plugin is deactivated.

  5. artcoder
    Posted 5 years ago #

    I'm trying to add a 4th menu item to one of my WP3.0 custom menu, and the circular spinner next to the "add to menu" button just keeps spinning and spinning. I do not have Global Translator plugin.

  6. Josh Leuze
    Posted 5 years ago #

    Hi artcoder, I'd suggest disabling your plugins and see if that has any effect on the menu editor.

  7. artcoder
    Posted 5 years ago #

    For me, it was the Redirection plugin. When I deactivated it temporarily, the menus worked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Global Translator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic