Support » How-To and Troubleshooting » WordPress 3 Bug

WordPress 3 Bug

  • I have found a bug in WP 3.0 but the Trac system makes no sense to me, it’s not very easy to submit bugs I have no idea where you do it!

    The bug is when you go to Settings > Reading and select a static page as your home and for your posts page. This should make the page you have chosen for your posts automatically use the index.php file from your theme, but in WP 3.0 it will use home.php (if it exists) this didn’t happen in previous versions, and after upgrading, it’s breaking my site!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator keesiemeijer


    The default template file for pages is page.php. If you use a static front page and you selected a “Posts Page” index.php is not used. from the codex : Settings Reading SubPanel

    * Front page – Select in the drop-down box the actual Page that you want displayed as your front page. If you do not select a choice here, then effectively your blog will show your posts on both the blog’s front page and on the Posts page you specify. If you would like to create a static home page template file, do not name it home.php, otherwise you will encounter problems when you try to view the “blog”/”posts” section of your site. To get around this, just name it anything but home.php, for example, myhome.php
    * Posts page – Select in the drop-down box the name of the Page that will now contain your Posts. If you do not select a Page here, your Posts will only be accessible via other navigation features such as category, calendar, or archive links. Even if the selected Page is Password protected, visitors will NOT be prompted for a password when viewing the Posts Page. Also, any Template assigned the Page will be ignored and the theme’s index.php (or home.php if it exists) will control the display of the posts.

    I still think index.php should be used for your posts page over home.php as index.php is the main template file, and home.php is if you want a separate home page template (not CMS-based page).

    Moderator keesiemeijer


    Don’t select a “Posts Page” and delete home.php if you want.

    I had this same problem except now I can’t fix it. There isn’t a home.php file in my directory and I didn’t change anything else aside from making my default page my About page. Now it says file not found and gives me the 404 page. So I tried to immediately go back and reset it, but now that option is completely gone from the settings menu. I can’t change the default page at all.

    I have the home.php as my site home page as I don’t need a static WP page as all the content on it is dynamic and wouldn’t need the CMS stuff like adding text etc.

    I have my news which is then using a WP page called news, this used to automatically grab index.php as WordPress looked at it as the new loop page, but suddenly in WP 3 this is no longer the case. Instead I have opted to use a custom page template for news and deselecting a “Posts Page”. However in WP semantics calling home.php for your Posts Page is incorrect, it should be index.php!

    Moderator keesiemeijer


    This is how wordpress uses the Home Page display. If your theme has a home.php it is used before wordpress uses the index.php. Read the Template Hierarchy to see when what template file is used on a WordPress site. The “Posts Page” always uses a Page template file, unless you have no Page template files or you don’t select a “Posts Page

    But in pre 3.0 it didn’t do this!

    Moderator keesiemeijer


    home.php is essentialy the same as index.php. It just gets called before index.php.
    There is nowhere in the codex that states that home.php is used differently, or that you have to setup your static frontpage or Posts Page differently than pre 3.0!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordPress 3 Bug’ is closed to new replies.
Skip to toolbar