Support » Requests and Feedback » WordPress 3 and 500 errors solved – suhosin php_ini culprit

  • Hi,
    Last night I had no sleep. It took me 9 hours of frustration so I”m posting this here to help anyone else who has the problem.

    1. I have several sites using WordPress
    2. Last night I turned on mod_deflate which compresses files by around 70%, recommended by Google
    3. Rebuilt apache…. then couldn’t log into any WordPress admin areas.
    4. After alot of pain, my last resort was to turn OFF mod_deflate
    5. STILL I get errors.

    By now I was stressed, very stressed. The server was exactly as compiled before the errors so I emailed my dedicated support guys. Angelo rebuilt apache and all was fine.

    I found out what caused the error.

    – Angelo compiled apache without suhosin php hardening

    – To trace the error I recompiled it again WITH suhosin and the error returned, this proved it was not mod_deflate which caused the error. It was WordPress 3 and suhosin

    csf firewall says
    Check php for ini_set disabled <<< was not done
    Check php for Suhosin

    WordPress version 3 has an ini_set in admin.php which tries to change the php memory allocation, and suhosin doesn’t allow this = which meant we got a server error on login

    I went to Service Configuration >> PHP Configuration Editor >> advanced mode >> Safe Mode disable_functions

    and added ini_set

    The server error disappears… and security in csf increases

    I’ll add this to the forum as I didn’t find this information anywhere on the internet last night.
    It might help others,

    By recompiling the server without suhosin my datacentre guy Angelo, highlighted where the problem was. I’d spent 9 hours thinking it was mod_deflate…which was th eobvious culprit as I’d just turned it on.

    Cheers
    Simon

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘WordPress 3 and 500 errors solved – suhosin php_ini culprit’ is closed to new replies.