WordPress 2.9: your attempt to edit this post has failed (70 posts)

  1. bwnunnally
    Posted 6 years ago #

    Upgraded to 2.9 and also have this error when I try to save a draft of a new post:
    Create new post
    Add Title and some text.
    Save Draft.
    "Your attempt to edit this post has failed. Please try again"

    Going to the dashboard, the autosave appears to have saved the drafted posts. If I preview those posts, or add info then save draft or preview it is successful. Just the initial 'save draft' after creating a post is failing.

    If I create a new post it appears autosave is firing more than once, and then is hanging on "Saving Draft…"

  2. bwnunnally
    Posted 6 years ago #

    This behaviour appears to have been corrected by upgrading my hosting account from PHP 4.x to PHP 5.
    See also http://wordpress.org/support/topic/342975?replies=6

  3. DenBolle
    Posted 6 years ago #

    I've got the same issue, upgrading to php5 did solve it. WP 2.9 relies more in php5 than advertised I think.

  4. DenBolle
    Posted 6 years ago #

    Eh.. that didn't solve it. What I've noticed is this :
    - 2.9 hasn't got any default category when you're posting a new post (in 2.8.x it was "Uncatagorized") and leaves that empty. Meaning the post will be submitted without any category, and that causes I think the error we're seeing.

  5. DenBolle
    Posted 6 years ago #

    Some more testing :
    php5/upgrade wp2.9 / default category set up.

    --> creating post title bla, body "bla" , save draft --> error.
    When I look into the draft what actually is saved anyway --> no catagory is present.....

  6. jpmidnight
    Posted 6 years ago #

    I had the same problem. The cause was "Twitter Tools" plugin. I have found out this by
    1. disable all plugins.
    2. enable plugins one by one and write a post to test.

    It is worth doing the procedure to see every plugin you installed are compatible with 2.9.

  7. stepanov
    Posted 6 years ago #

    I have the same problem under PHP 5.1.6. Will try to disable "Twitter Tools" plugin to see if it'll help.

    UDPATE: The Twitter Tool cases that problem. Already sent bug-report to its developer.

  8. RexFromArs
    Posted 6 years ago #

    I'm having the same problem, and disabling Twitter Tools *does* fix it.

  9. Jblundell
    Posted 6 years ago #

    I don't have Twitter Tools and I'm getting the same problem - and my server should be PHP 5


    I've also noticed the revision history is gone. Don't know if that's part of WP 2.9 or something else. I have a feeling it was another plug-in that was updated today. Will have to try and do some more testing to see.

  10. wphelpcenter
    Posted 6 years ago #

    Is there anything else in common with your installations? I just tried this with an upgraded install of 2.9 and the latest version of Twitter Tools. I created a new post with the post title of "Test" then pressed tab to move to the body and typed "Test". Then I clicked Save Draft and it saved correctly. "Notify Twitter about this post" was set to Yes and I tried it multiple times with new posts.

    I also tried it with "bla" for the title and content since it was specifically outlined in the steps to reproduce the error here.

    I'm just looking for something else in common with the installations so I can share it with the developer. Thanks.

  11. jpmidnight
    Posted 6 years ago #

    > wphelpcentre
    Twitter tools worked fine on 2.8.3 having a little bug to double post a daily/weekly digest. I automatic update wordpress to 2.9 and the problem occurred.

    The problem happens in both Notify Twitter about this post set to "Yes' and "No".

  12. jpmidnight
    Posted 6 years ago #

    my bad, it's 2.8.6, not 2.8.3.

  13. venusww
    Posted 6 years ago #

    I deactivate tweeter tool by Alex King and problem is soleved, but can anyone tell which tweeter tool should i use now to send my blog posts to tweter

  14. laetizia
    Posted 6 years ago #

    Hy guys,

    I agree totally. I disable Twitter Tools, was the release 2.0.
    Now the blog work fine.

    I think we need to wait the update from the developer.
    At this moment its better to update Twitter by hands!

  15. Jay Fingers
    Posted 6 years ago #

    To everyone who keeps suggesting we disable Twitter Tools ... it's already been mentioned that this also happens to those of us without Twitter Tools.

    We'd also appreciate a solution of some sort as well. Tks!

  16. jpmidnight
    Posted 6 years ago #

    Do you still have the problem when you disable all plugins?

  17. Desi Matlock
    Posted 6 years ago #

    Disabling Twitter tools worked for me - on three separate client installs on unique servers.

  18. Alex King
    Posted 6 years ago #

    I haven't been able to reproduce this at all. If you can provide information to the WordPress HelpCenter (http://wphelpcenter.com - see the comment above), they can try to isolate the issue and provide a verified bug report to me or to the core WordPress team - whichever is appropriate.

  19. spacebooger
    Posted 6 years ago #

    I am having problems with two sites.
    One site just has three plugins: askimet, category cloud, and twitter tools.
    The other one has eight plugins: askimet, all in one seo pack, bookmark me, Google Analyticator, Plugin Output Cache, StatCounter, Text Link Ads.
    Both sites give the error if Twitter Tools is activiated.

  20. drknd
    Posted 6 years ago #

    I'm having the same problem on my blog, http://drkblog.com. Haven't tried deactivating twitter tools, but c'mon, shouldn't have to, right?! I trusted the update to 2.9, was that the mistake?

    Dr. K

  21. jpmidnight
    Posted 6 years ago #

    It was a mistake to upgrade it without testing... I reckon...

    Anyway, I've made a test environment.

    • a clean installation of 2.9 on my server making the problem on the other 2.9 WP hosted, different database newly created.
    • put define('WP_DEBUG', true); right after ?php in wp-config.php.
    • Download "Twitter tools 2.0" and placed it in plugin directory and chown -R apache:apache ./my_web_folder/*.
    • No modification made here to "Twitter tools" on Admin panel.
    • Add new post, type a in subject, press Tab to move, type something and press Save Draft then error messages showed up.

    Notice: Undefined index: aktt_notify_twitter in /my_web_folder/wp-content/plugins/twitter-tools/twitter-tools.php on line 1752

    Notice: Undefined index: aktt_notify_twitter in /my_web_folder/wp-content/plugins/twitter-tools/twitter-tools.php on line 1752

    I enter my username and password of Twitter to then update. I got

    Notice: Undefined index: aktt_last_tweet_download in /my_web_folder/wp-content/plugins/twitter-tools.php on line 217

    Notice: Undefined index: aktt_doing_tweet_download in /my_web_folder/wp-content/plugins/twitter-tools.php on line 217
    Notice: Undefined index: aktt_doing_digest_post in /my_web_folder/wp-content/plugins/twitter-tools.php on line 217
    Notice: Undefined index: aktt_install_date in /my_web_folder/wp-content/plugins/twitter-tools.php on line 217

    This is the info I can provide.

    Commenting out define('WP_DEBUG', true); got me to "Your attempt to edit this post: "" has failed."

  22. mizkatie
    Posted 6 years ago #

    I was having a similar problem. I wasn't getting an error message, but every time I made adjustments to my post, it wouldn't save. It would revert back to the previously saved, and completely disregard my corrections.

    I disabled the All in One SEO Pack plugin, and now it works properly.

  23. eladear
    Posted 6 years ago #

    Deactivating the Twitter Tools plugin has resolved the issue for me too.

  24. Siira
    Posted 6 years ago #

    I have been testing a bit. It seems Twitter Tools does work. Initially I disabled Twitter Tools as well to get posting working again and it worked. Tonight I have been testing and I found out it's the combination of Bit.ly support and twitter tools. I have Twitter Tools enabled now, while bitly is disabled and all works fine.

    Alex, anything you want from me to find the exact cause? I'm a developer as well, not in php though :)

  25. jfrenaye
    Posted 6 years ago #

    I am having several problems.

    1. The tweets were not including the URL shortened by Bit.Ly. THis was resolved by removing the trailing space after the last character in the API key.

    2. The video embed in 2.9 (putting a URL alone on a line) causes an error. Disable Twitter tools and it is fine!

    3. When creating a new post and either save to draft, or publish there is a generic error (mostly a white page) saying the post cannot be saved. Retry. It is indeed saved as draft, but the categories, tags and any info put into Headspace2 or All in One SEO (title, excerpt or keywords) are all gone.

    I am keeping it disabled till there is a fix. I liked the plug in, but I am not so sure I want to participate in the $14.99 support plan for 3 to 24 minutes for them to troubleshoot.

  26. jibecc
    Posted 6 years ago #

    I've the same probleme with Twitter Tools and I see the following tip (WP 2.9, TT 2.0, with or without bit.ly). The default of saving occure the first time I try to save the post, for publish or for draft. The message said that the saving is not good and retry, but the post is reaaly in the list of post. Only the title is good and the content of the post is delete.
    When I display the post, it's possible to write the content, save than draft (few times) and after publish it, and the tweet is good. I see only, that in the second read there is a "aktt_notify_twitter" with value = "no" (create automaticaly, I think). I try with this in the first publishing, but it's not the solution.
    My solution (temp !!) : begin to save the post than draft with only a title (error, but not important !), return on the post, write all, publish it with "Notify Twitter about this post? " = YES.
    I agree it's not a clean solution, but for waiting the release...

  27. magius2244
    Posted 6 years ago #

    I had the same issue with a client trying to schedule posts or save them as drafts running WP 2.8.6. Disabling the "All In One SEO Pack" plugin resolved the issue it seems.

  28. Gary_Petersen
    Posted 6 years ago #

    Alex, I don't see a way to provide information to the WordPress Help Center without also providing them money. Here's what I found on my system, which is running WordPress 2.9 with Akismet 2.2.7 the only other active plugin (and Hello Dolly and the Twitter Tools suite the only other installed plugins).

    With all of the Twitter Tools plugins deactivated, if I create a new post, type Testing in the post header and body, then click Save Draft, the post saves just fine.

    If I then move that draft post to the trash, activate only the main Twitter Tools plugin (leaving the Twitter Tools - Bit.ly URLs, Twitter Tools - Exclude Category, and Twitter Tools - Hashtags plugins deactivated), create a new post with Testing in the post header and body, and click the Save Draft button, I get the "Your attempt to edit this post: “Testing” has failed. Please try again." error message. When I re-navigate to my weblog (not using the browser Back button), I find the post saved as a draft but with only the post header field filled. The body is empty.

    I can edit that draft post, type Testing in the body, click the Save Draft button again, and the post saves without error.

    The Twitter Tools settings are:

    - Enable option to create a tweet when you post in your blog? Yes
    - Tweet prefix for new blog posts: New blog post
    - Set this on by default? No
    - Create a blog post from each of your tweets? No
    - Create a daily digest blog post from your tweets? No
    - Title for daily digest posts: My Tweets for %s
    - Create a weekly digest blog post from your tweets? No
    - Title for weekly digest posts: Twitter Weekly Updates for %s
    - Order of tweets in digest? Oldest first (chronological order)
    - Category for tweet posts: General
    - Tag(s) for your tweet posts: twitter
    - Author for tweet posts: gary-petersen
    - Exclude @reply tweets in your sidebar, digests and created blog posts? No
    - Tweets to show in sidebar: 5
    - Create tweets from your sidebar? Yes
    - JS Library to use? jQuery
    - Give Twitter Tools credit? Yes

    Disabling the Twitter Tools plugin restores the blog to normal performance.

    Thanks for the plugin and your help in fixing this issue. Gary

  29. atmasphere
    Posted 6 years ago #

    I was able to quickly fix this problem thanks to this thread. On Media Temple I just switched PHP to 5 from 4 and it worked right away. I've got twitter tools enabled as well as quite a few other plugins ... no issues anymore.

  30. jibecc
    Posted 6 years ago #

    Hi all,
    just some informations about my case (see above).
    @magius2244: I've not "All In One SEO Pack" plugin installed.
    @Gary_Petersen: I've exactly the same situation and the same default.
    @atmasphere: my config is WP 2.9, TT 2.0, Apache, php 5.2.1.
    I make a test on a WP with:
    * only Twitter Tools plugin activate
    with "Enable option to create a tweet when you post in your blog? Yes", other settings on default values,
    * no activate Tweetter Tools Bit.ly URLs, Exclude Category, Hashtags,
    * I disable all other plugins,
    ... the default describe above is still present.
    Happy new year!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 6 years ago by bwnunnally
  • Latest reply from อนุรักษ์เพลงชาติไทย Thailand
  • This topic is not resolved
  • WordPress version: 2.9