Support » Fixing WordPress » WordPress 2.9 dashboard html editor inserting <p> tags

  • When I type code into the html editor and update the page, the html does not display correctly. When I look at the html source code via ‘view source’ in the browser, <p> tags have been inserted around the code.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same/similar problem following upgrade to 2.9. I posted a query about it 15 hours ago but no response yet.

    Someone in the forum said WordPress upgraded TinyMCE which is the editor in WP 2.9 and that may be the problem.

    I’m having the same problem. Switching between Visual and HTML messes things up and leaves difficult to edit HTML text.

    One partial work-around is to be in Visual mode, copy the text you want, then go to HTML mode and paste it in over where you want it. This will clean things up a little.

    Need 2.9.1 to be pushed out with the editor fix.

    Same issue here. And it at times switches to an earlier auto draft when you try and publish the post.

    I think I may have found the solution. My problem turned out to be using Safari on Mac with WordPress 2.9.

    To solve the problem I believe it may have been Google Gears messing things up.
    Go to Safari>Google Gears Settings
    and wipe out any WordPress setting in there.

    Also I closed my Safari windows (for Windows users you probably have to just open a blank page). Empty your cache.

    I also went into my Library subdirectories and wiped-out any cached Safari pages.

    Try the Gears trick first.

    I dont think this is related to TinyMCE, since all previous posts I published are being affect by this issue (I didn’t edited them, so they still the same in database).

    I FOUND the solution …
    Edit wp-includes/default-filters.php

    line 110, change from:
    add_filter( ‘the_content’, ‘wpautop’);


    add_filter( ‘the_content’, ‘wpautop’, 0);

    One more solution without touching WP core is to try WP Unformatted plugin.

    When using the HTML editor to force a line break or BR or P and carriages returns, the WordPress wpautop filter will ignore

    <br clear="none" />

    That’s pretty easy wpautop relief!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordPress 2.9 dashboard html editor inserting <p> tags’ is closed to new replies.