WordPress.org

Support

Support » Plugins and Hacks » WordPress 2.8 “The plugin does not have a valid header.”

WordPress 2.8 “The plugin does not have a valid header.”

  • After installing wp 2.8, one plugin automatic disable and msg shows “
    The plugin does not have a valid header.”

Viewing 15 replies - 1 through 15 (of 23 total)
  • I have the same problem when I try to enable any plugin. I just updated to WP 2.8 with the automatic update.

    likewise…
    and further the forcibly deactivated plugins no longer show up in the plugin list.

    Same here, and I upgraded WP via automatic method too.

    []’s!

    Guys, I’ve found an workaround. Just move plugin files to /plugin root. For example:

    /wp-content/plugins/akismet/akismet.php

    Move akismet.php to

    /wp-content/plugins/akismet.php

    Your plugins’ folder will be a messy, but at least missed plugins will come back and work.

    Anyway, I’m still waiting an official solution from Automattic. WP 2.8.1, may?

    []’s!

    rghedin:

    I’ll try that.

    I’m getting tons of spam since I upgraded to 2.8 on Wednesday. It’s like the spam filter is not there!

    My plugins look fine within the the plugin listing in the WP8.0 Dashboard, but am getting tons fo spam since the upgrade.

    Yes… the Askimet seems to be activated, but not working well.

    I am wondering if the rules have changed. I did manually upgrade to the new version of Askimet as was requested of me. Is that not working too?

    What a mess!

    Thanks in advance.

    Just wanted to share real quick that this issue also is present in SVN managed installs. A quick switch from tags/2.8/ to /trunk/ does NOT resolve this issue either, just in case anyone in a similar setup was thinking of trying.

    I still have the problem. I have tried both suggestions and I still get the same error.

    No official solution yet? I really can’t get along with this trouble. Some plugins, which have many files into folders, doesn’t work with tips said above. I just can’t use some plugins in my blog anymore 🙁 .

    Hope Automattic give us at least an explanation about what happened.

    []’s!

    Having the same issue here.

    WPMU 2.8.3
    Buddypress 1.0.3

    I was able to activate it by moving it manually into plugins. When you use the installer it has a file and within it there were multiple folders ie. screenshot and the one I needed. Moved it out of that folder into plugins and it activates.

    I’ve already solved this – for any plugins. I wrote an article here.

    WP 2.8.3 and plugins

    As someone mentioned, some plugins will only install manually like we used to do before the automatic install feature.

    Unzip the plugin folder and upload it via FTP into the wp-content/plugins/ folder.

    Make sure you ONLY upload the plugin folder:

    wp-content/plugins/askimet = good
    wp-content/plugins/askimet/askimet = not good

    That’s why the header can’t be found, it doesn’t seem to discard the “shell” folder.

    Hope this helps!

    styzer

    Hi, I am sorry, but I am new to WP, how do you “move these files out of the plugins folder and into the root folder” ? I have no WP folders on my Mac, and I can’t find any directory under http://www.globalmacroblog.com/wp-admin/

    Any help would be great as I am unable to install any plugins at all – I get the same message. Do you know if this will ever get fixed, it seems people have had problems for months now.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘WordPress 2.8 “The plugin does not have a valid header.”’ is closed to new replies.