Support » Plugins » WordPress 2.8 RC breaks post types in More Fields plugin

  • I noticed as soon as I upgraded to WordPress 2.8 RC (due to need for some functions added to the new version) that my custom post types no longer have the ‘publish’ box to the right of the content editor. End result: I can’t click ‘publish’ to save anything.

    Anything that can be done about it, and/or has anyone had a similar experience?



Viewing 15 replies - 1 through 15 (of 32 total)
  • Yep same here… I’m guessing More-Fields 1.2.10 isn’t working well with the javascript changes for the screen options of the edit page in WordPress 2.8RC1.
    For me anything that is in the right column on the edit page disappears (such as the publish box in the default layout) when the plugin is activated; also the show/hide capability of the write boxes are either stuck open or collapsed according to how they were set before the plugin was activated.
    One simple workaround is to deactivate the plugin set the screen options to one column and toggle open all the boxes then reactivate the plugin. Not elegant but should work until the plugin comes up to speed with 2.8

    Hats of the the dev this is a useful plugin for idiot proofing WP as a CMS

    Cross posted at

    Ok, I’ve almost completely fixed this problem. Thanks to this blog post:

    I added some code to the more-fields-object.php file that enables the right sidebar again, and it also saves your open/close toggle states on the boxes:

    more-fields-object.php, function init(), at the bottom of the function (before the } ):
    add_filter(‘screen_layout_columns’, array(&$this, ‘screen_layout_columns’), 10, 2);

    then, immediately *after* the final closing brace ( } ) of the init() function:

    function screen_layout_columns($columns, $screen) {
    $columns[$screen] = 2;
    <script type=”text/javascript”>
    jQuery(document).ready( function($) {
    // close postboxes that should be closed
    // postboxes setup
    postboxes.add_postbox_toggles(‘<?php echo $screen; ?>’);
    return $columns;

    This will enable the “Screen Layout – Number of Columns: 1 2 ” options under the “Screen Options” pulldown. Probably not the cleanest way, but it’s a quick fix.

    NOTE: The one thing that does NOT work is if you choose 1 column layout, it moves all the sidebar items over to the main column, then if you switch back to 2 columns, the sidebar items remain in the main column, and you can’t drag them back. I’m not sure if this is a bug in 2.8 or what, because it still happens on the normal Edit Post page if I deactivate the More Fields plugin. I haven’t tried deactivating all my other plugins.

    Something to note as well. I think the 2.8 + More Fields bugs are not adequately solved yet.

    After implementing Jazbek’s fixes on a new installation of WP 2.8 I am unable to expand/contract many Admin area panels and menus and am unable to grab onto draggable items like widgets in the Appearance –> Widgets page.

    After deactivating the plugin, everything worked as it should.

    Such a bummer, because morefields was a dream come true for the kind of wordpress work i do.

    EDIT: i’ve tested this in Safari 4, and Firefox 3 (mac)

    Yeah, I think that is related to the problem that I mentioned above, of the admin boxes all moving to the main column when you choose 1 column layout, and then not being able to move them back to the sidebar if you switch back to 2 columns. The strange thing is, when I deactivated the More Fields plugin, this problem remained for me. I am using the same browsers as you, mongushu

    As for not being able to expand/collapse some boxes, I tried all the boxes on the edit post page, and had no trouble with any of them except 1 that was added by another plugin. Which boxes are you having trouble with?

    jazbek – here are the bugs ive seen since applying your edit. all of the expected behaviors occur when the plugin with your edit is diabled

    Bug 1 Location: Posts>Edit or Pages>Edit or Media>Library etc.
    Expected behavior: if clicking on the “post” checkbox to check all the below list of checkboxes for bulk action then all the posts checkboxes in the list below should toggle to checked. (this behavior occurs when more fields with your edit is disabled)
    Problem behavior: when clicking on the “post” checkbox to check all the below list of checkboxes for bulk action none of the check boxes in the list below toggle to checked.

    Bug 2 Location: Posts>Edit or Pages>Edit or Media>Library etc.
    Expected behavior: clicking the screen options would reveal screen options for Posts>Edit
    Problem behavior: clicking the screen options does nothing

    Bug 3 Location: Posts>Edit or Pages>Edit (or More-Fields Custom Post/Page types in main nav)
    Expected behavior: clicking on any toggles of the left column admin main nav items ( i.e. dashboard, posts, tools , appearance etc.) would expand the child nav list without leaving the current page
    Problem behavior: clicking the toggle does nothing.

    Bug 4 Location: Appearance>Widgets
    Expected behavior: Widgets should be draggable in to sidebar right column
    Problem behavior: Widgets aren’t draggable

    the code-styling page is definitely pointing in the right direction for a fix. For the time being i’ll revert back to the workaround I mentioned. At the moment its the lesser of evils till things get sorted.

    jazbek’s fix works without issues for me!
    Clean WordPress 2.8 with no other plugins in Firefox 3 and IE 7.

    Switching form 2 to 1 columns indeed throws all the boxes to the left and does not recover them to their previous positions but I think that’s a 2.8 issue.

    This thread is kind of forked here and at (sorry) but just thought I’d post my fix files:


    Thanks for your patience jaz- it was totally a copy paste error using your file and/or typing the code solved the problem.

    jazbek, you are the man !

    glad i could help! i am a lady, btw.. haha 🙂


    well then, Maa’aam, I would love to take you out any given day!


    Worked for me too!
    A very warm thankyou from sunny Rome Jessica!

    cheers jazbek

    I am _not_ running the More Fields plugin.

    This bug first occurred for me running the official 2.8 release. 2.8.1 did not rectify the situation.

    I selected the “Number of Columns: (1)” option under “Screen Options” on the new post page. I then selected “Number of columns: (2)”. The columns narrowed, but the publish/tag/category divs did not move back to the right sidebar.

    Is there a fix for this? I really do not like working in the one column layout.

    kingjeffrey, i think you have to drag the boxes back over to the right sidebar, if i’m not mistaken. it’s an annoying thing about wp 2.8 as far as i understand.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘WordPress 2.8 RC breaks post types in More Fields plugin’ is closed to new replies.