WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 2.8 Plugin Update Problem

WordPress 2.8 Plugin Update Problem

  • Hi there,

    I’ve just updated my WordPress 2.7.1 to 2.8 via auto update. It finished updating without problems.

    I also wanted to update one of my plugins which was adjusted to the new 2.8 version. But it gave me this error.

    Warning: unpack() [function.unpack]: Type V: not enough input, need 4, have 0 in /home/***/public_html/***/wp-admin/includes/class-pclzip.php on line 4770

    PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    So I tried 2 other plugins which have their new versions but getting the same errors. My auto plugin update was working very well before updating my WordPress version. So anyone knows anything about it?

    PS: I can upload media, I can update WordPress but I can’t update my plugins. That’s my problem.

Viewing 15 replies - 16 through 30 (of 46 total)
  • Brilliant! Thank you so much Ryan. I overwrote http.php and the plugin installs seem to function correctly now.

    Hope you don’t mind if I ask a dumb question. Should I replace http.php on another WP 2.8 blog installation that is not showing the bug just as a precaution or is it really not required?

    Uthfull, this is dependent on which http transports are available on a given host. If it’s working for you, there is no need to replace.

    Thanks go to demetris, who isolated the problem.

    Uthfull, no. If the other installation works, you donโ€™t need to do anything.

    It seems this issue depends on the server setup. So, it only appears on some installations.

    Eh! Ryan was faster by 20 seconds this time. Iโ€™m catching up.

    @ryan : Both blogs are hosted on the same host and the same server but exhibit opposite behaviour with regard to this bug.

    @demetris : Alright. Even though they’re both on the same server, I’ll let the other installation be the way it is till it starts going crazy on me(if ever).

    Thank you once again, both of you.

    I thought I’d let you guys know that the other blog on the same server just started giving me the error. That’s cool, since I already have a cure. :). demetris is right to say that it is due to some server setups.

    The fix posted worked to correct the issue I was having. Thanks!

    Since I’ve installed 2.8, I cannot successfully install plugins through the Dashboard interface at all. Every time I try, I get an “ERROR 500” page from my server.

    I’ve tried both the original HTTP.PHP file from the full download as well as the changed version that Ryan posted a few days ago. Both versions give the same result.

    Meh… now I see that I’m getting errors upon attempts to ACTIVATE plugins as well.

    I am getting the:

    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    error after changing the http:php file. It was doing this before as well. Not sure what else to do.
    Running php 5.2.9 libxml2 2.7.3 and wordpress 2.8

    I was able to fix my wp 2.8 problem by deleting all my old inactive plugins. I don’t know why this worked, but it did.

    thanks all for the help with the link to the http.php. It save me a few of my hair I did not have to pull out… ๐Ÿ™‚

    The replacement of http.php fixed my issue. Thanks!

    I also have the problem, even after downloading the new http.php. ๐Ÿ™
    What might be interesting, besides the error message that everybody here receives, I also get the following:

    Warning: unlink(/***/***/***/html/blog/wp-content/upgrade/wp-syntax.0.9.8.zip) [function.unlink]: No such file or directory in /***/***/***/html/blog/wp-admin/includes/class-wp-upgrader.php on line 146

    And I watched my upgrade folder closely while trying to auto-update: WordPress DOES download the zip file, but it seems that it deletes it again before unpacking!

    In case this helps anybody since 2.8 rolled out my error log created a huge file that took up all the available space for my account and then there wasn’t enough room to download and upack the upgrade files.

    So everytime I tried to upgrade I got PCLZIP_ERR_BAD_FORMAT (-10)

    I deleted the error log and it all works fine now.

    So I tried overwriting the http file given by Ryan, it worked and then after some time it didn’t.

    So what I did, I deleted all inactive plugins I have. And guess what? Its working now.

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘WordPress 2.8 Plugin Update Problem’ is closed to new replies.
Skip to toolbar