WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 2.8 Plugin Update Problem

WordPress 2.8 Plugin Update Problem

  • Hi there,

    I’ve just updated my WordPress 2.7.1 to 2.8 via auto update. It finished updating without problems.

    I also wanted to update one of my plugins which was adjusted to the new 2.8 version. But it gave me this error.

    Warning: unpack() [function.unpack]: Type V: not enough input, need 4, have 0 in /home/***/public_html/***/wp-admin/includes/class-pclzip.php on line 4770

    PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    So I tried 2 other plugins which have their new versions but getting the same errors. My auto plugin update was working very well before updating my WordPress version. So anyone knows anything about it?

    PS: I can upload media, I can update WordPress but I can’t update my plugins. That’s my problem.

Viewing 15 replies - 1 through 15 (of 46 total)
  • Btw it gives this error while unpacking, not loading.

    Any idea?

    Can anyone help me with this situation plz? I reinstalled wp but all same, I cant update my plugins anyhow.

    I’m having exactly the same problem with my blog. I can’t figure out how to upgrade the plugins as I keep getting this error.

    Downloading update from http://downloads.wordpress.org/plugin/adminimize.zip.
    
    Unpacking the update.
    
    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    Alright arzlonga, I think I’ve found the cure. Do you by any chance have the WP Greet Box plugin running on your blog? If you have the “WP Greet Box” plugin running, disable it and then try to upgrade your plugins. I think it somehow messes up with the system. I’m not 100% certain though.

    UPDATE:
    To test out what I had pointed, I specifically installed WP Greet Box on a WP 2.8 blog that did not have it previously. I then tried to upgrade the plugins. It went and finished the operation smoothly. No problems with WP Greet Box. But what I do know is that the error we get is resolved for me by either disabling all the plugins or the greet box plugin and then upgrading the plugins that I want to.

    I get this to, but I don’t have the WP Greet Box plug installed… Anyone any ideas?

    WP Greet Box is not causing the error. I apologize for the confusion due to my previous statement. I tried installing a plugin through the plugin browser and I was returned with this error:

    Downloading install package from http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.0.5.zip.
    
    Unpacking the package.
    
    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    and this is when WP Greet Box is disabled as well. I do not think this is a server issue because another blog is installed on the very same server and gives no such errors.

    Another interesting thing that I’ve noted is that no errors I returned while trying to upgrade a theme or install a new theme via the theme browser. It only happens with the plugins. And this time, even disabling the plugins has not helped. Any help would be appreciated.

    Yeah, I don’t have that plug-in either. In fact I only have 6 plugins that are the most popular ones in WP list. They didn’t give any errors while updating since now. Also I didn’t have any problems with installing new plugins too. So it seems like new version comes with a weird bug.

    Weird bug it is. Like I pointed out after further diagnosis that it is infact not related to any of the plugins. While everything works flawlessly on another blog, this blog gives the error when trying to install plugins and upgrading them. Themes work perfectly while upgrading and installing. 2.7 used to work perfectly. Anyone know how to file an official bug report regarding this?

    I’ve found lots of unanswered questions in this forum about this subject. I don’t think people will notice this post until they have this error.

    I’ll tweet about this. Lets see if I can draw some attention.

    Another thing I’ve noticed, if you download the plugin ZIP to your PC and then upload it using the upload plugin feature in the dashboard, it installs correctly without any error whatsoever.

    arzlonga, I opened a ticket earlier today about this same issue:

    http://core.trac.wordpress.org/ticket/10104

    I think we’ll have to wait for 2.8.1. Until then, we can upgrade our plugins manually if an upgrade can’t wait. 🙂

    Edit. Ah! Ryan was faster by 43 seconds. 😀

    Try this version of http.php. Download that and install it over wp-includes/http.php. Does that help?

    Worked great for me! Thanks, Ryan!

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘WordPress 2.8 Plugin Update Problem’ is closed to new replies.
Skip to toolbar