WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 2.7.1 can’t write to any file on Fedora 10

WordPress 2.7.1 can’t write to any file on Fedora 10

  • I recently migrated a wordpress install to a new Fedora 10 box.

    The new wordpress install is running, but it exhibits some really weird behavior.

    First, I can’t write to any files using the wordpress editor. Even if I chmod 777 the themes for example, wordpress still says this file is unwritable.

    I am not running selinux. I uninstalled it.

    Any body have any suggestions? Is it something in php.ini?

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m going to guess that Otto’s advice might apply:
    http://wordpress.org/support/topic/242936?replies=23#post-984183

    It would be worth a try, but Fedora 10 doesn’t seem to have a suphp package yummable. I get:

    yum install suphp
    Loaded plugins: refresh-packagekit
    fedora | 2.8 kB 00:00
    fedora/primary_db | 6.6 MB 00:42
    Setting up Install Process
    Parsing package install arguments
    No package suphp available.
    Nothing to do

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    In Fedora the package is “mod_suphp”.

    Thanks. Still no joy. I installed it. Do I have to do something special to configure it to run as apache?

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    That I can’t tell you. I think that if you have the normal apache Php installed then you need to remove it for it to use suphp, or something to that effect. No idea, really.

    I finally figured it out. I just thought I had SELinux removed (because I thought I had chosen not to install it when i first set up the box). Turns out it was what was causing the problem.

    To fix it, I changed the line in /etc/selinux/config to read:
    SELINUX=disabled

    I don’t think the suphp had anything to do with my problem. Thanks anyway though.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WordPress 2.7.1 can’t write to any file on Fedora 10’ is closed to new replies.