Support » Fixing WordPress » WordPress 2.7 Visual Editor has Vanished on some Posts

  • IQmatrix

    (@iqmatrix)


    At times when I save a post, the page editor disappears and I can only view what has been written out in HTML. However, once the VISUAL button is pressed I can no longer access the editor unless the page is refreshed. Also pressing the HTML button again does not work either. I simply cannot see the post.

    The only way to get the HTML back is to refresh the page, yet this still doesn’t allow me access the Visual Editor. The only option is to delete the post and copy the HTML into a fresh page and resubmit it.

    Also all the previous saved posts are not accessible.

    This is the 2nd time this has now happened since upgrading to WP 2.7. It does this after pressing the SAVE post button.

    WordPress was upgraded using INSTANT UPGRADE plugin.

    I hope there is a fix for this. Thanks.

Viewing 15 replies - 1 through 15 (of 85 total)
  • Shimshon9

    (@shimshon9)

    I have the same problem. I can only use html to write a new post. If I want to use the Visual editor it just doesn’t work.

    Help please:)

    tilmannroe

    (@tilmannroe)

    Hey,
    i have also the same problem after updating my installation to 2.7 i can only use html…

    would be thankful for a solution…

    tilmann

    tilmannroe

    (@tilmannroe)

    hi,
    after deinstalling the plugin “All in One SEO Pack” it worked just fine…

    tilmann

    Shimshon9

    (@shimshon9)

    What if I do not want to uninstall the “All in One SEO Pack”?

    IQmatrix

    (@iqmatrix)

    I don’t use the “All in One SEO Pack” and I still get this error. Instead I use “HeadSpace2” which does the same thing.

    The error doesn’t happen all the time when I save a post or page. However, when it does occur, I have no choice but to create a new page or post and copy the HTML over.

    I don’t think that it’s an error originating from a plugin. It must have something to do with WP 2.7 version.

    Shimshon9

    (@shimshon9)

    So where is the solution?

    genuwine4532

    (@genuwine4532)

    I am also having problems with the editor, buttons are dead, like kitchen sink.

    Can you guys tell me is the new post editor different than the old one? Mine looks exactly the same as 2.6, same icons and everything is gray and white on the dashboard, and all over the admin there is no color, is this how it’s supposed to be?

    IQmatrix

    (@iqmatrix)

    Yes, the interface is composed of shades of gray.

    Today I discovered that I don’t actually have to save a post in order to get this error. For some unknown reason, when I go back to edit some posts the Visual editor is not accessible and I can only view the HTML.

    I have taken a screen capture of the Visual Editor. Click HERE to View.

    As you can see the Visual Editor is selected, however it does not display any visuals, just html. When the HTML button is clicked than I am unable to even access the HTML unless the page is refreshed. My Post revisions have also vanished for some unknown reasons.

    Does the WordPress development team acknowledge this error? Can a forum moderator confirm or provide any further insight into this?

    factor10

    (@factor10)

    Yep, +1 to the above posts. No visual editor, right from the start. Only HTML. When I click on either the Visual of HTML tabs, the text in the editable box disappears, until the page is refreshed.

    Hosting my site locally using xampp, no issues in previous versions of WP. Don’t have the SEO Pack installed.

    Anyone out there able to help on this please?

    goofydg1

    (@goofydg1)

    I’m having the same issue. But it’s only happening on one of my blogs. The other one I upgraded is working fine. I deleted all the files except those in wp-content and it still happens.

    MarkRH

    (@markrh)

    Mine seems to be fine with both the SEO Pack and TinyMCE Advanced plugins installed. Using FireFox 3.0.4. Might clear any browser cache/temporary internet files. Make sure any ad blockers are disabled for the sites you’re on.

    paulorear

    (@paulorear)

    Same here. I upgraded to 2.7 because all the experts were saying it’s the best thing since sliced bread. Now I can’t access the visual editor, and there is no button to insert an image using the “wizard”. Any response from someone at WordPress?

    techguyboy.net

    (@techguyboynet)

    **How I Solved This Problem**

    1- Backup your 2.7 Database
    2- Backup all your 2.7 WordPress Files
    3- After backing up all your 2.7 WordPress Files, delete all the files.
    4- Do a FULL FRESH INSTALL of WordPress 2.7
    5- After you are done installing the fresh install of WordPress 2.7, try to create a new post and see if the Visual Editor comes up (it did for me)
    6- Upload your 2.7 Database (the one you backed up in Step 1) If the Database is large, use bigdump.
    7- Check and see if the Visual Editor is up for your old posts.

    I did this and now it works for me. Hope it works for you guys.

    Andrew Ozz

    (@azaozz)

    WordPress Dev

    There are some steps to try to troubleshoot this: http://azaozz.wordpress.com/2008/12/11/troubleshooting-tinymce-in-wordpress-27/

    Usually most errors are due to either stale cache or failed upgrade as in the other threads about the editor not working properly.

    infected

    (@infected)

    Same here. I updated to 2.7 and IE7 doesn´t display any visual editor buttons. In Firefox all buttons are displayed. I tried nearly everything what´s mentioned in azaozz post. Nothing helped so far… I also using tinymce advanced as well as all in one seo pack. Deactivation of both plugins doesn´t helped, too.

    IE 7 returns this error message in statusbar (translated from german language):

    Row: 2
    Character: 62298
    Error: The process couldn´t continoued due the following error 80020101

    Code: 0
    URL: http://example.com/wp-admin/post-new.php

Viewing 15 replies - 1 through 15 (of 85 total)
  • The topic ‘WordPress 2.7 Visual Editor has Vanished on some Posts’ is closed to new replies.