Support » Fixing WordPress » WordPress 2.7 upgrade and nothing happened

  • I just finished an upgrade from 2.6.2 to 2.7… deactivated all plugins first, deleted wp-admin and wp-includes folders, preserved wp-content folder contents and wp-config (followed instructions, basically). No change, nothing happened, good or bad… it’s as if I never upgraded. I used the 2.7 download. I am using wp-cache, but cleared it as well as my browser data/cookies. I ran the upgrade script, and it said there was no need to update the database.

    I don’t want to try again in case it royally screws up my site. Anyone else have this issue?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Did you close and restart your browser? Deactivate WP-Cache?

    I recommend that you try again. You are on the right track, but all it takes is a glitch in the uploading files to ruin the whole cake.

    If you’re using Firefox, go to Tools > Clear Private Data and make sure Cache is checked. On Safari I believe there’s a Clear Cache under File. Refresh the page.

    If you’re using an FTP client make sure the transfer type is set to Auto and not ASCII or Binary. Also make sure that you’re overwriting and not merging files (depending on your client).

    Be sure to compare the file listings of the downloaded zip file and what’s on your server because sometimes the client will not upload some file(s) for whatever reason. (this has happened to me before).

    You won’t see the “Your database needs to be upgraded” message until your reach the admin login page (/wp-admin/).

    Check here for info on backing up your db (among other things):

    Sigh… all plug-ins disabled (including WP-Cache), cleared all private data in both browsers, restarted both browsers, re-installed WP 2.7 with a new download… no change. All transfers in Auto mode, all files are accounted for on the server. Both times I tried logging in via the /wp-admin/ page AND running the upgrade script, nada.

    That is bizarre. So you still see WP, but it’s the older version? Or do you see nothing at all?

    My site works fine and I see the Dashboard, etc. as WordPress 2.6.2, including the notice to upgrade to WP 2.7! It’s as though I never touched the files. FTP is working properly, because I’m able to upload, delete and overwrite with no problems.

    I deleted WP-Cache and all associated files (including cache folder via FTP). I’m wondering if there’s a situation with leftover WP-Cache stuff in the options table that’s preventing the upgrade from “taking.” I upgraded a local install using the same download, just to make sure I’m not going crazy — and it worked beautifully.

    Why does just a supposedly straightforward upgrade seems so frustrating, having to delete some stuff so as to be able to ungrade?
    Read from the forum that we need to have a web hosting a/c before we can “one-click to upgrade” instead of doing manually. Well, Bluehost is my web hoster yet I dond’t see any “one-click” for this version 2.7. Anyone knows how to upgrade for my case? I’ve also tried uploading to my host server, but still the same. Anyone can help?

    OK, so something is up with my server in general… tried uploading some image and HTML files to my site this a.m., and nothing… they’re listed in various FTP programs’ directories, but when I attempt to access them via Firefox or Safari, I get “File Not Found.” They’re not listed in the index file for the directories I uploaded them to in the web browsers, either.

    I wasn’t having this problem before I tried the 2.7 upgrade, and I’m only having this problem on the domain I attempted the 2.7 upgrade on. But then, this could be why the 2.7 upgrade wasn’t working.

    Sigh… I’ll post again once I hear from my web host.

    I did the 2.7 upgrade and everything works EXCEPT the blog’s home page – it’s a complete blank, whether you get there by entering the URL directly or via a link to it from any other page or post (which all work fine). What happened??? Any ideas how I can fix it?

    Both times I tried logging in via the /wp-admin/ page AND running the upgrade script, nada.

    So, did the upgrade script run?

    I wonder if FTP is failing to overwrite files, but am really not sure what might be causing the issue. Maybe the path to your directories was changed by your host so everything you’re uploading is going to the wrong spot? Not likely, though.

    @bearyinbooks: The common auto-installer/upgrader is Fantastico. Since you are using Bluehost you also have Simple Scripts, which is much better than Fantastico, IMO, however, you will still have to do a manual upgrade to migrate your site to Simple Scripts unless it was initially installed with it and, beginning at WP 2.7 the ability to upgrade is automatically built in.

    @taxpolicy: Could be a problem with Permalinks, or could be you are missing a needed file. Check out the following threads to see if any apply:

    The update ran successfully. This morning, I renamed [blog_root}index.php so wordpress couldn’t find it and uploaded an index.html that contained a redirect to one of the page permalinks. Everything broke, but after I put it back, I was able to get the default page from it’s permalink (though it took a really long to come up for the first time). Maybe caching something? Anyway, the [blog_root] is still blank – that’s the only thing not working. Everything else is fine, permalinks are all fine.

    It’s working now. After renaming index.php to something that wordpress couldn’t find, trying to access a permalink (which of course failed), putting [blog_root]index.php back, AND reloading the [blog_root], it displayed just fine. Had to be caching of some kind.

    My host says it’s a server upgrade/DNS propagation problem… although this is the THIRD time I’ve tried upgrading after their twice promising to have fixed it… sigh.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WordPress 2.7 upgrade and nothing happened’ is closed to new replies.