WordPress.org

Forums

WordPress 2.7 Editor not working (21 posts)

  1. romerican
    Member
    Posted 6 years ago #

    I have tried to clear the cache, manually and with the web developer toolbar.

    I have tried to replace wp-config

    I have set WPLANG

    I have deleted everything in wp-includes/js/

    I have removed the htaccess file

    I have disabled all plugins, including Akismet

    There is no tiny_mce_gzip.php, in the 2.5.x+ but as a test I uploaded a the file from 2.3.3 with no difference.

    I have had this problem since 2.5.x and nothing makes it go away.

    The most information I have is tiny_mce_config.php results in a 404 error, as do all php files in the /wp-includes/js/tinymce/ directory, although they exist when checking by FTP and it should be said that all other extensions (.css, .js, .htm) display without a 404. Permissions are the same on all files.

    Any help? It's been a long time with this issue and my hope for 2.7 did not bear fruit.

  2. MichaelH
    Member
    Posted 6 years ago #

    Looks like you've tried everything, but get a new host.

    Or the drastic step of Exporting (Tools->Export) then delete and reinstall WordPress, then do Tootls->Import->WordPress.

    Make sure you are totally backed up if you try that!

  3. brun0
    Member
    Posted 6 years ago #

    im also having troubles to get the editor running on 2.7!!! it worked on the 2.6.3.. but now! i just cant get it to start.

    what could it be? maybe some file attribute? does anyone more having this issue?

  4. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @romerican this is strange:

    ... results in a 404 error, as do all php files in the /wp-includes/js/tinymce/ directory...

    Have you tried deleting wp-includes and replacing it with a fresh copy? There may be some changed permissions on the sub-directories or .htaccess files there. Also check the .htaccess file in the root directory and/or WordPress' installation directory if it's installed in one to make sure they have the default rules only.

    There's no tiny_mce_config.php file any more as the configuration of the editor has changed in 2.7, more details here: http://azaozz.wordpress.com/2008/12/11/troubleshooting-tinymce-in-wordpress-27/

  5. joeralt
    Member
    Posted 6 years ago #

    I have also an upgrade problem with the 2.7.
    The dashboard doesn't show any of the tabs including plugins and all the rest.
    Please anybody? help!

  6. ml kay
    Member
    Posted 6 years ago #

    Help? I upgraded to 2.7 on my test site (thank goodness) and cannot get the visual editor to work at all. Tried the all the suggestions from azaozz - but zip. All that seems to work is the html editor. The visual editor has no menu and won't accept any input. NONE. Serious headache this. What's going on?

    And the suggestion of MichaelH is ridiculous. A stable upgrade should not call for a complete delete and reinstall. That merely sounds like an excuse for releasing 2.7 too soon.

    Here is a screenshot of my "so called" visual editor.
    http://shortpoem.org/editor_screenshot.jpg

  7. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @ml kay if you tried all suggestions, what is the first js error you see on the write page?

    Also MichaelH's suggestion is a very good one. This is also one of the steps in "Troubleshooting TinyMCE in WordPress 2.7". Several things can go wrong while upgrading: the zip file may not be extracted properly on your computer's hard disk, your FTP program may not be set properly to overwrite all files or may not upload new files or may not set the upload type correctly, either text or binary. Also there may be some file permission problems or old .htaccess files that need to be removed.

    Deleting wp-includes and wp-admin and uploading fresh copies from freshly downloaded and unzipped installation package is a must when troubleshooting.

  8. ml kay
    Member
    Posted 6 years ago #

    see next

  9. ml kay
    Member
    Posted 6 years ago #

    @azaozz

    Since it was my test site. I deleted all wp my files, I deleted every file in the test directory. Then I reinstalled. So far, so good. I'll be adding things back in one at a time and let the forum know if I find any conflicts.

    I have way too much stuff going on at my main site right now to risk a disruption, so will not be doing anything with it until mid Jan. Thanks.

    I seem to have gotten over my initial shock that a WP! update didn't work.

  10. infosoak
    Member
    Posted 6 years ago #

    I have a specific problem with the visual editor:

    I cannot create a link using the built in editor, no matter what permissions I give to anything, even 777 to all WP directories and files. When I press the link button in the built-in editor (the Visual part of the editor, not the HTML part of the editor), I get this error in a window that pops up in the middle of the browser:

    FORBIDDEN - You don't have permission to access /wp-includes/js/tinymce/themes/advanced/link.htm on this server.

    Any thoughts? I am using Safari 3.x, but this happens with Firefox as well.

    Thanks.

  11. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @ml kay that's a good approach. When running a big/busy site you ought to have a test install (preferably on the same server) where things can be checked out before deploying.

    @infosoak was just about to suggest that this is a server error, but I see in your other thread that you found the problem.

  12. Mike Rawlins
    Member
    Posted 6 years ago #

    I had this problem in IE but no other browsers

    I deleted wp-admin & wp-includes and uploaded fresh copies from WP 2.7 with no luck. I then started to remove plugins and the one that 'seems' to have caused the issue was podpress which had been hanging around for a while and I had missed deactivating it..

    Dunno if this is of any use to you but it worked for me :)

  13. thomasfrank
    Member
    Posted 6 years ago #

    I had the same problem.

    I removed all plugins, and then all is working.

    I uploaded one plugin at the time, and found that this plugin "kimili-flash-embed" removed the editor html buttom.

  14. websuccessdiva
    Member
    Posted 6 years ago #

    I had same issue Kimili Flash Embed removes the editor in post and page management, once I deactivated it, back to normal :-)

  15. fele
    Member
    Posted 6 years ago #

    Obviously some plugin that ads an additional button to the editor seems to breack the visual editor. In my case it was RB Internal Links 0.21: by deleting it, all works fine.

    Regards

  16. talie2
    Member
    Posted 6 years ago #

    Kimili Flash Embed was the issue for me too - can someone post this info at the top of the thread? Much easier than reading through all the previous suggestions for a fix - and much easier to fix too!

  17. mauiman
    Member
    Posted 6 years ago #

    Peeps - it took me hours to find this solution and it's in this thread...

    DISABLE ALL PLUGINS and then ENABLE then one by one until the culprit is discovered. Disable it until a fix is found or the plugin is updated.

    Sheesh, what a pain that was...

    Thank you all above for posting!

  18. madhatterdesign
    Member
    Posted 6 years ago #

    Kimili Flash Embed was also my issue, just FYI. :) Deactivated it and the Visual editor is back!

  19. kwc_jr
    Member
    Posted 6 years ago #

    Both MM Forms and Dean's FCKEditor For WordPress seem to break the TinyMCE editor as well.

  20. tiendx2002
    Member
    Posted 6 years ago #

    Another solution for kimili flash embed is comment out their tinymce hack lines.
    Like this:
    //add_filter( 'mce_external_plugins', 'kml_flashembed_plugin', 0 );
    //add_filter( 'mce_buttons', 'kml_flashembed_button',0 );

    And:
    //echo 'tinyMCE.loadPlugin("kfe", "'.$pluginURL.'");'."\n";
    Back end TinyMCE works, and your kimili posts still works as well.

  21. tiendx2002
    Member
    Posted 6 years ago #

    However, the fix mentioned above is just a quick fix not a complete solution which should cover the KML button of TinyMCE to work.

Topic Closed

This topic has been closed to new replies.

About this Topic