[resolved] WordPress 2.7 Blank Page Problem (Upgrade & Fresh Install) (41 posts)

  1. Certificateno
    Posted 7 years ago #

    For the last couple of days I've been trying to get 2.7 working. But seen I'm posting here I've had no success. I tried installing it fresh on my server and by upgrading 2.6.2.

    I've tried:
    *Installing fresh from source to FTP server (in the root of httpdocs)
    *Installing by upgrading from existing 2.6.2 version provided by auto installation (4PSA Integrator) from my hosting provider.
    *Installing by upgrading from existing 2.6.1 version by using the InstantUpdate and Automatic Updater Plugins. InstantUpdate works perfectly, but leaves me with the blank page problem. Automatic Updater for some reason cannot read my files (despite their permissions being 755 and 777)

    I've also on the above the following
    *Using different FTP programs (Transmit, Cyberduck Filezilla)
    *Using ASCII, Binary and Auto upload function
    *Disabling PHP safe mode (my host had turned it on for some reason)
    *Giving all my wp-files (recursively) 777 and 755 permissions (despite it being stupid, i know)
    *Uploading content to overwrite old files, twice. (worked for others)
    *Deleting old files before uploading
    *Googled extensively and tried all other solutions offered on WP forums.
    *Shouting at it...

    Anybody an idea about what i should try next?

    Thanks in advance

  2. djpushplay
    Posted 7 years ago #

    I had this exact same problem using Firefox 3. When I tried looking at the same page that was blank with Firefox 3, using IE 7, it works. There's some minor issues even with IE 7 but at least I can look at my website. Hope that helps.

  3. Certificateno
    Posted 7 years ago #

    I'm on mac and tried both Firefox (3.0) and Safari 3.2.1 but both fail to load the page. With Firefox displaying a blank page for everything, and Safari displaying a connection error.

  4. neverblink
    Posted 7 years ago #

    I have the same problem. After uploading the files for 2.7, I tried calling wordpress/wp-admin/install.php -- this gave me a blank page (in FF, IE, Safari).

    Adding echo "test"; to install.php will output 'test' to the page when placed before line 19: require_once('../wp-load.php'); after that it fails.

    Might this be due to the restrictions on include/require that came with PHP5?

  5. neverblink
    Posted 7 years ago #

    My previous assumption about the restrictions on include/require seems to be correct.
    When I try to include/require a file outside the current directory the script fails and dies quietly. When I copy the same file to be in the same directory.. it works!

    So this seems to be a WordPress+PHP5 issue.. can anyone confirm this?

  6. Niteblade
    Posted 7 years ago #

    I think I might be able to confirm what you're talking about. Just for kicks, add the code:

    echo ABSPATH;

    to see if WP and/or PHP is getting the correct values for script location.

    My problem is that while my blog works fine, I cannot get into the administration interface, and I attempted to change a few require_once to just plain ol' require and got into the admin interface for a little while. Now, a blank white screen is all I see on the admin interface.

    My blog is working okay, though.

  7. Certificateno
    Posted 7 years ago #

    While installing trough FTP upload and refreshing the page several times I got snippets of the new interface, but after the upload is done it it goes completely blank...

    Seems to me some code is making WP2.7 go blank with PHP5.

  8. tin68
    Posted 7 years ago #

    I found a way which worked for me. Go went to "Design" menu and clicked in the list on the actual theme and saved the "new" configuration. Then everything worked normally.

  9. kmessinger
    Forum Moderator
    Posted 7 years ago #

    A blank page means a php problem and sometimes, depending on the browsers, you may not see the error message. So first always test in another browser.

    Check your config.php for errors - that is probably the communication error.

    I know this as on my install I white paged in IE7 but in FF3, there was the message about error connecting to db. Fixed a typo in the config.php file and now all is well.

  10. Niteblade
    Posted 7 years ago #

    I think there might be a problem defining ABSPATH when using php v5.2.8.

    in root/wp-admin/admin.php, I changed some code at the top to tell me if ABSPATH was not being defined.

    if ( defined('ABSPATH') ) {
    	require_once(ABSPATH . 'wp-load.php');
    	{ echo 'Cannot acquire information from ABSPATH variable to load wp-load.php.';

    And lo and behold, the information in ABSPATH isn't making it to admin.php.

  11. Niteblade
    Posted 7 years ago #

    In addition, because the variable ABSPATH isn't being defined in root/wp-admin/admin.php, it makes sense that the errors are compounding because root/wp-admin/admin.php relies on ABSPATH to call a very important file that loads the dashboard from root/wp-admin/includes/admin.php.

    <strong>require_once(ABSPATH . 'wp-admin/includes/admin.php');</strong>

    In other words, if ABSPATH is NOT being defined when loading /wp-admin/admin.php, then how can it be expected to be defined when calling /wp-admin/includes/admin.php ?

  12. Digg50
    Posted 7 years ago #

    Nightblade - Digg50 here - I've been following your posts around because you seem to be onto an answer, but I tried changing that code you have there at the top of /admin.php but I didn't see any change as yet.

    You have this string;
    require_once(ABSPATH . 'wp-admin/includes/admin.php');
    but where did you put it?

  13. neverblink
    Posted 7 years ago #

    Niteblade, thank you for your confirmation..
    but things just seems to be getting more and more strange:

    \\ inside install.php
    \\ filename relative to current file
    $wpload = dirname(dirname(__FILE__)) . "/wp-load.php";
    \\ check if file exists
    	echo "Yes, ". $wpload ." is a file!";
    	echo "No, ". $wpload ." is not a file!";
    \\ output: No, Server:/sites/www.mysite.com/test/wordpress/wp-load.php is not a file!

    Both absolute and relative paths don't seem to work. When PHP doesn't see the file.. how can it be included/required? Hmm..

  14. Certificateno
    Posted 7 years ago #

    I'm giving up and going to stick with 2.6.5 for a while. Maybe the next version of wordpress will work properly for me and the others.

    I've tried modifying my config.php with all possibilities described here and on Codex but nothing seems to work. Even static pages like install.php don't want to show up anymore from time to time.

    Quick and dirty this is my config file. Database and password are working for me, but obscured here. Same goes for the Secret keys.

    define('DB_NAME', 'my database name');
    define('DB_USER', 'my user name');
    define('DB_PASSWORD', 'my password');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('AUTH_KEY', 'Key #1');
    define('SECURE_AUTH_KEY', 'Key #2');
    define('LOGGED_IN_KEY', 'Key #3');
    define('NONCE_KEY', 'Key #4');
    $table_prefix = 'wp_';
    define ('WPLANG', '');
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');

  15. tin68
    Posted 7 years ago #

    Did you try my idea? Change to an other theme, save the configuration. Then go again the the design menu and change back to your theme you had before.

  16. hues
    Posted 7 years ago #

    You may get a hint of the error by seeing the source of the page
    View > Page Source

    Sometimes the files which you have downloaded may be corrupt. Try once again after downloading a fresh copy.

  17. Certificateno
    Posted 7 years ago #

    @t tin68: I cannot access the control panel.
    @t hues: Nothing shows up at the source, but all php files are uploaded correctly and can be edited in Plesk.

    I tried again;
    1) Downloaded the wordpress 2.7 package (tar.gz instead of zip which i tried before)
    2) Extracted it using the command-line tar application
    3) Uploaded the files in auto-mode with Cyberduck. No change of permissions or anything else. (but also have tried Filezilla (Win and Max), Transmit and commandline ftp in other attempts, with the same result.)
    4) Changed my config.php file to the correct settings and made a new mySQL database using Plesk.
    5) The Installation screen pops up at my domain (like it always does)
    6) I enter my information and get a username/password and e-mail confirmation.
    7) Everything goes blank after that.

    The same for upgrading, but it goes blank after the database upgrade.

  18. voodoo13
    Posted 7 years ago #

    I have the same problem as certificateno.

    I tried upgrading and a fresh installation.
    Admin-panel is inaccessible. So the theme can't be changed and can't be the problem. As on a fresh install the default theme is used.
    Often there are corrupt or outdated plugins a problem. But this can also be ignored on a fresh install as there are only akismet and hello. I even deacivated those just for a try but it changed nothing.
    The page source is empty so you can't really tell where it stops working.
    You can see it here http://blog.voodoomedia.ch

  19. Certificateno
    Posted 7 years ago #

    Still not working. But I noticed many php files have a blank line after the ending (?>) tag. I changed a few but none of the pages show up.

    I tried uploading them binary and ASCII but it doesn't work. UTF-8 encoding is standard on my webhost service and since it runs CentOS it uses Unix Line breaks.

    Maybe for those that have working 2.7 installations did you do something special with these settings?

  20. kmessinger
    Forum Moderator
    Posted 7 years ago #

    Certificateno Would you post a URL please?

    voodoo13 There seems to be a problem with your header file Fatal error: Call to undefined function language_attributes() in /home/httpd/vhosts/voodoomedia.ch/subdomains/blog/httpdocs/wp-content/themes/default/header.php on line 2

    This information <?php language_attributes(); ?> is not being completed. I don't know if this is the problem but header.php is used by many files.

  21. Certificateno
    Posted 7 years ago #

    @t kmessinger:
    My addres:

    And my PHP Settings (I know it's somewhat stupid to post it, but anyway)

  22. tin68
    Posted 7 years ago #

    I found in your phpinfo a very interesting detail - I reported the problem about very slow loading of the pages.

    DD32 found that it could be a problem with cURL - and the interesting detail now:

    On your server there is exactly the same version of libcurl:

    CURL Information libcurl/7.10.6 OpenSSL/0.9.7a ipv6 zlib/1.1.4

    I know this doesn't solve your problem but I think we found a hint that this libcurl version is not compatible with WordPress 2.7 - or the other way round.

  23. kmessinger
    Forum Moderator
    Posted 7 years ago #

    Certificateno I think you are working on the server as I access it so I will stop. This is one of the errors you were kicking out.
    Fatal error: Call to undefined function language_attributes() in /usr/local/psa/home/vhosts/pseudoknowledge.com/httpdocs/wp-content/themes/default/header.php on line 8

    My server path runs html/ourexcellentadventures.com/wp-content. I don't have a folder inbetween site and wordpress. Of course, this could be perfectly natural but just wanted to point out the difference.

  24. TaxPolicy
    Posted 7 years ago #

    After the 2.7 upgrade everything works great, except that the <blog_root> page is blank. When other URLs are loaded, everything is fine, except whichever page is configured as the default (the content displayed for the <blog_root> appears blank. I can switch the default pages around. Once a page is not the default, it loads fine and whatever the new default is goes blank. I tried without the plug-ins, with the default wordpress theme, verified that the permissions are okay, reinstalled the 2.7 update, injected code in <blog_root>/index.php ...


    ... to print any warnings, but I'm not getting any errors either. Nothing is broken except the [blog_root] and whatever page is defined to be the default content. I can switch the default content around - whatever was the default content displays fine from its permalink. The new default content shows a blank page from it's permalink. The [blog_root] always shows blank, even if it's configured to be the last ten posts. There's no content missing. Any ideas?

  25. kmessinger
    Forum Moderator
    Posted 7 years ago #

    TaxPolicy What is your URL?

  26. TaxPolicy
    Posted 7 years ago #


    I tried one thing that helped a little. I renamed [blog_root]index.php to __index.php so wordpress wouldn't be able to find it. Then I added a redirect index.html from [blog_root} to one of the pages. Everything broke, but after I put it back, wordpress loaded the default page from its permalink (though it spent a really long time bringing it up for the first time). Seems like some sort of caching effect.

    Anyway, the [blog_root] still shows up blank.

  27. TaxPolicy
    Posted 7 years ago #

    @TaxPolicy - it's working now. After renaming index.php to something that wordpress couldn't find, trying to access a permalink (which of course failed), putting [blog_root]index.php back, AND reloading the [blog_root], it displayed just fine. Had to be caching of some kind.

  28. TaxPolicy
    Posted 7 years ago #

    @TaxPolicy - it's working now. After renaming index.php to something that wordpress couldn't find, trying to access a permalink (which of course failed), putting [blog_root]index.php back, AND reloading the [blog_root], it displayed just fine. Had to be caching of some kind.

  29. Certificateno
    Posted 7 years ago #

    I decided not to waste any more of my time on getting 2.7 working. It's been my obsession to get it working since December 13th and i've tried countless of things, resulting in hours of time wasted, with no success. So I'll be staying with 2.6.5 for a while, it might be a little less flashy, but it's way better for my health.

    The problem probably lies with my hosts PHP configuration. They messed up the mod_security configuration for their free and 1-click installer 2.6.2 WordPress, that also impacts my own from scratch installation of 2.6.5. I'm not suprised they messed up more things that make 2.7 go, well.. white.

    If anyone is still troubled by this problem or facing it. Here's my PHP Config; http://pseudoknowledge.com/phpinfo.php maybe someone can find the problem by comparing it to others.

    Thanks for all help offered, i really appreciate it. I hope the best to all others facing the same trouble with their wordpress installations

  30. digitalramble
    Posted 7 years ago #

    Hello...Reading through this is rather interesting. After upgrading to 2.7 last week, what I have found is that some users can get in to the admin panel and others cannot. It is very consistent (but no obvious reasons for the two groups) -- one user will always get the light blue screen of death (as we started dubbing it) and another never does. Fortunately all our admin people had no problems, but a good number of our author and editors and plain subscribers can't get in. What perplexes me about that is that it would seem to contradict the notion that it's something in the code as described above - I would expect php/wp 2.7 incompatibility to result in something across the board (which seems to be what most of yo have). We've got something quite different, some users affected and some not. I've poked thru the databases on the *_users and *_usermeta and not seen anything untoward, but I'm seriosly thinking some kind of database corruption.

    I did get this error message at one point
    Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 35 bytes) in /my-wp-path/wp-includes/wp-db.php on line 636

    which is basically one of the generic retrieval routines, not sure which query tripped that, of course.

    Anyway, I am rolling back to 2.6 as I have no patience for even this much poking about, really, but hope maybe this sheds futher light. We tested pretty extensively with our different users on different browsers, clearing caches, cookies, etc. I did not attempt to change anything in the wp install itself apart from the upgrade steps. I can't see how any of the above pertains, because they should be across the board and as I have said, only some of our users are affected.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.