Support » Fixing WordPress » WordPress 2.6 Update Error

  • After upgrading my site from 2.51 to 2.6 I receive the following error messages:

    Warning: require_once(/***/***/*****/******/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /***/***/*****/******/wp-blog-header.php on line 12

    Fatal error: require_once() [function.require]: Failed opening required ‘/***/***/*****/******/wp-load.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /***/***/*****/******/wp-blog-header.php on line 12

    I have deactivated all plugins previously. Anyone having any ideas what could cause that error ?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The errors appear on the main site but also when trying to update the blog in wp-admin/update.php and the wp-admin directory.

    You probably have some missing files – you will have to simply go back and check which file is missing or not been replaced.

    ghacks:
    I got the same error message when I tried the Automatic upgrade. You will find the missing file “wp-load.php” in the main directory of WordPress 2.6. I copied “wp-load.php” to my wordpress root directory on the server, and everything worked fine.

    what do you mean by root directory?

    root directory (as applicable to wordpress) = where your wp-config.php lives

    Ooh, I think this may well solve my problem too. Can you tell me where to copy wp-load.php from? Can’t seem to find it

    its inside the 2.6.1 zip, just like all the other files 🙂

    hmm. must be blind. Ok done that, but still no joy 🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordPress 2.6 Update Error’ is closed to new replies.