WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 2.5.1 Still can’t upload images

WordPress 2.5.1 Still can’t upload images

  • I have upgraded per all instructions and still can not upload pics. This is crazy…what is going on? I though this update was to fix all this stuff.

Viewing 15 replies - 46 through 60 (of 96 total)
  • I too am having image/video upload problems even after modifying the php.ini file to accept >50 mb files for both post and upload max file size.

    Has anyone found a fix for this yet?

    VERY frustrating

    Just adding a “me too”. The tips in the sticky didn’t make any difference for me, same with two other upload plugins.

    Here is the last entry from my webserver error log, if this has anything to do with my problem (Otto42 et al, if you’re still following this topic 🙂

    [Wed May 7 01:46:32 2008] [error] [client 83.xx.xx.xx] mod_security: Access denied with code 406. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"] [hostname "acme.org"] [uri "/wp-admin/async-upload.php"]

    Same problem here.

    Virgin 2.51 installation both on a local server and online shared server.

    I have tried with MSIE 7, Opera and Firefox all with the same results. Image uploads and when one goes to insert the image into the article the “lightbox” goes blank and sits there. The image does not insert though the box can be closed.

    There is obviously an Ajax issue here. I have not had time to look at code. I am versed in PHP, Javascript, C++, C#, VB, ASP.NET on and on.

    I am surprised this was not caught before release but it happens.

    The work around is simple enough.

    Upload the image using the media upload. Copy the resultant URL to your clipboard (highlight it and do a CTRL-C or right click “copy”. Exit out of the media uploader. In the editor click the Insert Picture icon, paste the URL into it.

    SOLUTION:

    Like many others I couldn’t upload images since I upgraded to 2.5.1.

    I was discussing it with Marco Cimmino (Author of plugin Cimy User Extra Fields) and he assumed the reason could be the memory limit.

    So I tried to change from php4 to php5 and it works!

    I’m on 1&1 and put the following in the .htaccess:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Now everything works fine.

    Hope, it helps you.

    Greetings,
    Rita

    Hey,

    I’m having issues as well. I’m using firefox, and when I try to upload an image I would get a message saying: HTTP Error. Same goes when I try to use Safari.

    Otto42,

    Your .htaccess fix in the sticky worked for me.

    Thanks for your help.

    2.5 was my first experience with WordPress. At first, the image upload worked fine in IE 7. Then it just stopped – I got the “HTTP Error” and “Crunching” messages. So I tried Firefox, and it worked for a while. Then that stopped working, too. The screen would darken for the Flash uploader, and a progress bar would appear, but nothing would happen. Clicking anywhere on the browser would reset and take me back to my post.

    I downloaded 2.5.1, but got the same issues.

    I added the following to my htaccess file:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Now, the Flash upload screen appears, and I can search for an image to upload. But when I select “Show Image”, nothing happens. That’s in Firefox. In IE, nothing happens.

    Does anyone have any suggestions? I don’t have any coding experience, and this is really frustrating. It’s keeping me from even beginning my site.

    Also, I tried the No Flash Upload plugin, but even though it says it’s active, it doesn’t seem to be doing anything. It still tries to use the Flash uploader whenever I try to add media.

    Found something: The “simple tags” plugin version 1.5.7 interferes with image insertion and the workings of the WP tag system. I killed the plugin and WP 2.5.1 seems to be working OK now.

    GUYS.

    For the people who is using the following configuration or similar:

    Debian gnu/linux “lenny” + iceweasel/mozilla firefox

    “JUST update the Flashplayer plugin” the default version is 9.0.42, just upgrade to the latest version from macromedia (9.0.124), RESTART Iceweasel/mozilla firefox and that is.

    Is my first time installing my own wordpress and I really don’t know why you are talking about change the .htaccess

    May the development team did not specify the requirements for this latest version or may we have not read all requirements for this.

    best regards,

    Thanks Zetino, but I think you’re off the mark there.

    Does anyone from wordpress read these threads??????

    Just to say that disabling the Simple Tags plug-in has so far solved the problem for me…(two pics uploaded and thumbnails were created; no HTTP error with either). Here goes the third upload…

    I have now tried all htaccess suggestions and disabled every single widget and plugin – still get the 2MB error message.

    I love wordpress and the best part is that it’s free – but free is only a great deal if it works.

    Any other ideas?

    What I find odd is that sometimes it works and sometimes it doesn’t. I seem to have best results when I insert the image immediately. When I post slowly (and allow the auto-save function to kick in (?)) and attempt to insert the image last, that’s when I’m apt to get the white window. Generally, (especially when it comes to computers)either something works or it doesn’t. Not so (for me) in this case.

    What I find odd is that sometimes it works and sometimes it doesn’t.

    So do I. Killing the simple tags plugin did not solve everything. The flash thingy seems based on licensed properties.

    Hey board-senseless.com

    This is a comment from the latest swfupload.org’s actionscript source (the component used in wordpress):
    // Note: Flash Player does not support Uploads that require authentication.
    // Attempting this will trigger an IO Error or it will prompt for a username
    // and password and may crash the browser (FireFox/Opera)

    If it’s not the auth issue, then I’d suggest uninstalling your current flash player, and installing the latest version. That might fix it.

    Removing the old flash player plugin work for me on debian and ubuntu.

    regards,

    PS: And I’m using .htaccess too now

Viewing 15 replies - 46 through 60 (of 96 total)
  • The topic ‘WordPress 2.5.1 Still can’t upload images’ is closed to new replies.
Skip to toolbar