WordPress 2.5.1 Still can't upload images (97 posts)

  1. zetino
    Posted 7 years ago #

    Hey board-senseless.com

    This is a comment from the latest swfupload.org’s actionscript source (the component used in wordpress):
    // Note: Flash Player does not support Uploads that require authentication.
    // Attempting this will trigger an IO Error or it will prompt for a username
    // and password and may crash the browser (FireFox/Opera)

    If it’s not the auth issue, then I’d suggest uninstalling your current flash player, and installing the latest version. That might fix it.

    Removing the old flash player plugin work for me on debian and ubuntu.


    PS: And I'm using .htaccess too now

  2. ingejanse
    Posted 7 years ago #

    To my sheer and utter surprise, my problem is solved. I've given Otto42 my details for FTP and WordPress admin, he looked inside, noticed that my /upload/-folder was chmod 755 (and not 777), changed it to 777, and now the upload works.

    It's a miracle, since I've done that myself multiple times in the past too, but always placed it back to 755 if it didn't work, since (to the best of my knowledge) 777 would allow some vulnerabilities (please let me know if such is not the case).

    Maybe the chmod 777 trick works only in combination with worpdress 2.5.1; it might be the case that I've only tried 777 with WordPress 2.5.0.

    Anyway, my route to success seems to be:
    * do a clean install of WordPress 2.5.1 (keep the database, remove the files on your server)
    * chmod the folder /httpdocs/wp-content/uploads/ (and its subfolders and files) to 777

    One thing: I've mass-chmodded the folder uploads with filezilla, using the option 'file properties' -> '777' and the options 'apply to all sub folders' and 'apply to folders and files' ticked. Maybe this doesn't work properly, keeping certain folders or files in their old chmod state? It's worth to investigate on this if the problem persists in your case.
    * upgrade to 2.5.1

  3. Jo5329
    Posted 7 years ago #

    I upgraded to 2.5.1 to get my media library to work. Notta - can't upload, can't view files I manually upload ... I tried all the tricks (which we shouldn't have to do) noted in the previous comments ... nothing.

  4. Gene Belmont
    Posted 7 years ago #

    Maybe I bit off more than I bargained for when I went to WordPress.org.

    I've been reading all the posts about this "HTTP Error" "...try later", and I'm still baffled. The most baffling thing is that most website builders I've used have a no-brainer tool for uploading pics from your 'puter ... even with my lack of code skills. I've never seen so much confusion over one feature.

    I'm at the point where I'll actually pay someone to get my site fixed so I can upload pics ... my site is a wad of wet clay without pictures.

    I've been so impressed with WP up to this point. Got good coop from Brian Gardner's Revolution, too.

    One thing I've noticed with trying to operate the insert/edit feature, is that the little browser box doesn't allow you to choose JPEG, just "all files." Maybe that's normal.

    Anyone out there want to make a couple of bucks? Be gentle.


  5. marklaflamme
    Posted 7 years ago #

    Gene, what worked for me was simplicity itself. Under manage/miscellaneous, I changed the "store uploads in this folder" to the correct path. In my case, that was .../wordpress/wp-content/uploads. After trying all of the complex solutions offered up throughout the forums, this worked for me immediately and without further agitation. Good luck!

  6. ats00
    Posted 7 years ago #

    I am having the same problems. I have the blog active for a few weeks and all ws fine. Only in the last few days have I received the HTTP error with no image uploaded.

    I see no one has posted in regards to this for a week.....wondering if there has been any resolution to the problem?

  7. Gene Belmont
    Posted 7 years ago #

    Thanks, marklaflamme, for input, but didn't work for me. My "store uploads in this folder" was already in "wp-content/uploads", so I just added the wordpress in front + / and saved, but still came up with HTTP error.

    If you hear/see//know anyone who is willing to dive into my site and resolve this problem, I'd certainly appreciate knowing about it.

    I'd be willing to screw around with all those codes if it didn't require dismantling my site just to get a pic uploaded. Geez!

    Thanks again.


  8. marklaflamme
    Posted 7 years ago #

    Ah, bummer. Thought that might bail you out. Just one last thought on it: when I reset the upload folder under miscellaneous, I made sure it was absolutely right. Went to a photo on my blog, right clicked it and selected properties. There, I copied and pasted the address under "location" and pasted it into the appropriate box. Hacking off the photo title and whatnot, of course. Next time I tried to upload a photo, it worked perfectly.

  9. cwcgroup
    Posted 7 years ago #

    I can't insert pictures as well. Also, when I am writing a post, I cannot change from visual to html. It indicates visual, but is stuck on the html screen.

    This is extremely frustrating. I sure am thankful for WordPress and all the great work that has been done with it for my use, but I sure wish I hadn't upgraded. Other blogs I have I didn't upgrade and it works fine.

    A good example of "if it isn't broke, don't fix it."

  10. Gene Belmont
    Posted 7 years ago #

    Thanks again to marklaflamme, but this is my first attempt to upload a pic. Don't have any other pics uploaded.

    I guess I could just upload to Flickr or such. I don't know though, some of my best pics are from Creative Commons on Flickr. Whoops!

    Damn shame,though. Can't use a simple little tool like a pic browse and upload.

    Thanks again.


  11. marklaflamme
    Posted 7 years ago #

    Scribefire, the program, is a good way around the photo upload program. But the fact is, we shouldn't have to find alternative means to complete such a basic function. I really regret that the miscellaneous/upload folder trick didn't work for you because it was such a tidy fix for me. Like you, I'm not comfortable with the uber geek acrobatics promoted by some of the WP pros. I'd suggest messing around with that uploads folder to make sure you've got the path right. But of course, if you tried and it didn't work, maybe your issue is different than mine.

  12. Bald Man
    Posted 7 years ago #

    Was able to solve my problem by upgrading Flash to the latest version.

    WP 2.5.1
    Firefox 2
    Mac 10.5

    ISSUE: The image uploader would open. I could select A file but the file wouldn't upload. When I tried to upload from a PC, however, I had no troubles at all.

    Thanks to OliverC .

  13. Darren_S
    Posted 7 years ago #

    I had this problem, where I couldn't use the new Add Media feature -- white screen after clicking the "Insert into Post," and the "Show" links under Media Library did nothing. (Also, the thumbnails didn't show up under the Media Library.) Here is how I fixed it.

    I followed the advice in this post:

    I updated Java and Flash, rebooted, and -- here's the key -- disabled all my plug-ins. Suddenly the media manager was working just as it is supposed to.

    After systematically reactivating plug-ins, it looks like the culprit was FeedWordPress 0.993. I've posted over there and hopefully we'll get an updated fix that won't interfere with the media manager. I imagine there are buckets of plug-ins that are doing the same thing.

  14. crosinski
    Posted 7 years ago #

    Another member of the 1% here. I can upload but can't add an image to a post from the uploader in 2.5.1. I've tried all the fixes, but nothing has worked. I using the "paste image url into post" workaround. Oh, the No Flash Uploader plug-in didn't work for me either. Bummer.

  15. Andreas Beer
    Posted 7 years ago #

    There seems something more rotten than the flash uploader.

    Whenever the flash uploader doesn't work, the time stamp option for future posts doesn't work either.

    It just happened again on my site without any new plugins installed.

    Probably eddies in the space time continuum.

  16. the_takayuki
    Posted 7 years ago #


    I'm another user who can't upload an image. I'm using wp 2.5.1 w/ ubuntu and firefox.

    I tried most of the fixes listed on this thread to no avail.

    Here's what will fix the "i can't upload an image" problem:(previously mentioned above...)

    1. download the no-flash-uploader plugin http://trac.wordpress.org/attachment/ticket/6406/no-flash-uploader.php?format=raw
    2. put it in your wp-content/plugins folder
    3. log into the wordpress backend and click the "plugins" link on the right side of the page. (must be admin)
    4. you should see "no flash uploader" listed, click "activate".

    problem solved.

    thanks again to the poster above who mentioned this. it works.

    good luck!


  17. audiowurks
    Posted 7 years ago #

    I'm a "me too". I cannot upload any images. I've tried everything in the "media uploader problems" sticky. I also have had no luck with the "no flash uploader" plug-in (doesn't seem to alter anything).

    I'm not even sure where to turn at this point.


  18. dsyler
    Posted 7 years ago #

    Another "me too" here, partially at least.

    Vista Ultimate w/all updates
    IE7 with latest flash & java
    WP 2.5.0 on RedHat 5 w/php5 & mysql4

    For a twist, it works fine with both:
    & Safari 3.1.1
    on same machine & server

    Something in IE7 doesn't like the code as there is an error noted at the bottom of the browser:

    Line: 136
    Char: 2
    Error: object expected
    Code: 0

  19. davebyers
    Posted 7 years ago #

    3+ hrs. over the last 5 days, found MY answer:

    Latest Flash version 9,0,124.0

    OS X 10.4.9


    WP 2.5.1

    sorry to hear so many are having the same bug,

    Flash update did it for me.

  20. zzyzyva
    Posted 7 years ago #

    For what it's worth, I would get as far as the "crunching" box and then it would freeze. When I checked to see if the files had uploaded, they were there in the gallery but I couldn't get them into my blog. I'm using Firefox, so don't know if this applies to IE or other browsers but if I close all the browser tabs except the one with my blog, the files upload right into my blog. Can't imagine why multiple tabs would affect this but they do.

  21. audiowurks
    Posted 7 years ago #

    I fixed this error by downgrading back to 2.5. I'm back in business.

  22. novada
    Posted 7 years ago #

    I upgraded to 2.5 and 2.5.1 and was unable to load images in Firefox.

    As recommended above I chmod the folder /wp-content/uploads/ (and its subfolders and files) to 777.

    That didn't appear to work but when I tested with IE7 the image loaded. WooHoo. I tested again in Firefox and the image loaded. I chmod'd back to 755 and tested and the images still load. Bizarre.

    The only difference I can see is that before, when the image wouldn't load the folder /wp-content/uploads/2008/05 did not exist. Now it does and everything works fine. I'm guessing it may break again when June rolls around.

  23. iamthechosenone
    Posted 7 years ago #

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting "http error", but I know some people got "crunching" instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match "^Shockwave Flash" at HEADER("USER-AGENT") [id "***MY ID"][rev "1"] [msg "SpamBot UA"] [severity "CRITICAL"] [hostname "***MY-DOMAIN***"] [uri "/testing/blog/wp-admin/async-upload.php"]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

  24. phototristan
    Posted 7 years ago #

    The No Flash Uploader plugin fixed this perplexing problem for me. Nothing else I tried did (including changing the permissions of the upload folder to upgrading Adobe Flash).

  25. Alvaro Degives-Mas
    Posted 7 years ago #

    Frankly I'm baffled, too. I've tried everything in the book (i.e., the suggestions in Otto's sticky post, and the no-flash-uploader as well as the alternative flash uploader plugins) and no dice.

    Until it hit me: I've hardened my blog after a spade of nasty JavaScript induced hacks (highly recommended reading that!). Among many other things, I have tightened security by setting permissions for directories and files to 755 and 644 respectively - as they should.

    And now I have this problem, too. So just to make sure, I've (temporarily) set the root (!) web directory to 777 and wp-uploads to 777 and... that was the cause of the problem, as I could upload without a problem again.

    I sincerely hope there's a different way of uploading within WP than by relying on granting FULL public write permissions to vulnerable AJAX/JS, because that's just... well, plain nuts. Count me among the less-than-amused here.

  26. ubergiant
    Posted 7 years ago #

    I spent hours trying to solve this problem doing everything.

    And the way I solved it was: I wrote permissions of the 2008 folder in uploads to 777.

  27. rigdonia
    Posted 7 years ago #

    Thanks the_takayuki - that fix worked for me!

  28. phototristan
    Posted 7 years ago #

    The problem with the no flash plugin is that it only allows you to upload one image at a time. The built in flash plugin allows you to select multiple images to upload in a batch.

    If the no flash plugin could be updated to allow multiple image uploads, it would be perfect.

  29. sonnycool
    Posted 7 years ago #

    i seriously have no clue on it ...
    1. IS new installation and install twice in different domain. (both not working).
    2. My flash version is up to date.
    3. The files i try to upload is 5KB.
    4. no plugin until the no flash upload. (still no chance).
    5. ALL FOLDER on CHMOD 777
    6. I running on my own server.

    the best is the problem is not happen regular, it happen when it feel like it ...

  30. crystallyn
    Posted 7 years ago #

    I'm having the same issue. I can upload but can't post images.

    This is my error:

    Precondition Failed
    The precondition on the request for the URL /wp-admin/media-upload.php evaluated to false.

    Now the thing is that my default image directory isn't wp-admin, it's wp-content and it does show up correctly in settings/misc.

    I've updated flash, tried the no flash, did everything in Otto's note, CHMOD'd them all to 777, you name it. No clue what to do.

    Even trying to link the image gives me the same error.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.