WordPress 2.5.1 Still can't upload images (97 posts)

  1. When I try to upload a 1.2MB video, I get "Your file is too big. Your php.ini upload_max_filesize is set to 16MB."

    Two filesize settings actually control that, the "bug" here is in the message only.

    If the "post_max_size" setting in PHP is set too small (smaller than your file), you'll get the same message.

    This is not a WordPress problem, your server is set too low for the uploads to work.

  2. digitalKaren
    Posted 7 years ago #

    @Otto42 I thought it might be an add-on so I removed them but it didn't solve the problem. Also tried it on 2 different computers, one of which doesn't have add-ons for IE or Firefox.

  3. wkessel
    Posted 7 years ago #

    Yeah, it's set too low: 8MB. Gotta fix that...

  4. PAArchivist
    Posted 7 years ago #

    Just adding my name to the list of folks with image insert problems. Perhaps this will push the count from 1% to 2%. And there could be others who have decided to do without images and haven't bothered to seek out a fix. My blog is totally image dependent and I'm at a stand still until I can get a fix that works.

    I continue on my hunt - with no coding experience but using all my intuition and trial and error.

  5. ziovanja
    Posted 7 years ago #

    I fixed the problem, in the end, but just going over a new installation. I must say that I had upgraded (apparently) successfully from a 2.5.0 that was previously upgraded from an up-to-date 2.3, so the problem was introduced during the last upgrade process. Anyway, try this:

    0) backup everything (db and files)
    1) make a full export through /wp-admin/export.php
    2) install WP 2.5.1
    3) copy old files and plugins into the newly installed WP directory
    4) import the saved copy through wp-admin/import.php

    Worked for me.

  6. perlmunger
    Posted 7 years ago #


    I appreciate your work on this and your responses here, however, I have to say that as a fellow programmer the "it works on my box" mantra is not helpful to users. I have had this same problem people are describing on Mac OS X on Safari 3.1.1 and Firefox and on Windows on Firefox while using WP 2.5 and now 2.5.1 and all with the same results--no file uploaded.

    I just now tried it on Windows with IE 7 (7.0.5730.11IC) and it finally worked. This suggests it is a browser and/or platform issue, not a server issue. Not only have I gotten rid of my cache and tried to upload again on Mac OS X Firefox and Safari, but I've deleted the profiles from the system files completely and started over and I still get the same problem.

    You were saying that you need someone with technical expertise to provide some suggestions. Well, I won't help debug the code, but I am telling you on behalf of others here who may be non-technical--something in the file upload code is broken. If you start from there, it may be beneficial for everyone.

    Thanks and best regards,


  7. GinnyRED57
    Posted 7 years ago #

    I just wanted to add that the suggestion about logging in via the meta link rather than directly via a URL worked for me, two posts in a row. Also, it works under Safari 3.1.1 (and looks much nicer than it does in Firefox).

    Strangely, the media upload images are not visible for me on IE 6 or IE 7 (I'm stuck with the former at work, no possibility of reprieve).

  8. perlmunger: If you're willing to trust me, email me with a link to your site and the admin login (I'll also need the FTP details if I need to look at the files themselves). I'll try it out for myself and see if I can discover your specific problem.

    So far, I have a 100% success rate in fixing these issues manually. That's not bragging, I'm just saying that I've yet to see an issue that is the code rather than the configuration.

    I almost always solve them by following the instructions I posted in the sticky post, but when I find a new cause, then I edit the sticky post to include it. Found one yesterday, in fact.

    Same goes for anybody else who has "tried everything". I'm willing to take a look and see if I can help. Might not be today, but as soon as I can get around to it. Shoot me an email.

  9. teddyp
    Posted 7 years ago #

    Hi -

    Having problems uploading images. Trying what I can.

    I'm interested in the no-flash uploader, 'cause I really need to put some images out there in the meantime.

    I just don't know what to do after downloading the no-flash installer file.

  10. ingejanse
    Posted 7 years ago #

    @ Otto42: thank you for your generous offer. I've just emailed you.

  11. Johnwgillis
    Posted 7 years ago #

    I'm also having problems uploading images, but of a different sort. When the image starts crunching, the window turns into a login screen saying "Please log in again". When I enter the credentials, I get a 404 page, because it is looking for blogroot/wp-admin/wp-login.php.

    Don't know why it's asking for a new login, or why it's looking in the wrong place for wp-login.php.

    If anyone can think of something I might have misconfigured, I'd appreciate suggestions.


  12. terrybugs
    Posted 7 years ago #

    The .htaccess file was the Ticket to solving my Uploading problems with FF and IE!
    I read your post above about adding something to the Sticky Post and went to re-read it....
    Noting that it shows the Sticky Post,
    last updated 1 month ago so I hadn't bothered to recheck it...thinking there was nothing new...

    Question now is, apparantly it is a Mod Security issue...do I just leave the .htaccess file or do I have to tweak something else?


  13. redchickadee
    Posted 7 years ago #

    If you have this weird bug and really need to upload images, do what I've been doing.. Upload the image manually within your FTP client, then go into WordPress and create a good ol' fashioned image link in HTML Mode. Kind of a hassle, but it's a pretty easy work-around until this issue is sorted out.

  14. deus62
    Posted 7 years ago #

    Or use MS Live writer. I've never used anything like this before (and wasn't planning on doing so), but a link in another forum plus a load of frustration took me over there. I gave it a try and have absolutely no problems anymore. Once they fix issues with the WP uploader, I'll can LW again.

  15. Jay Mayu
    Posted 7 years ago #

    no flash uploader helped me!

  16. nmarques
    Posted 7 years ago #

    Guys one more here
    I can't post picture as well
    sometimes I can't even post text, the auto-save button works automatically and destroy the layout.
    Sometimes you save but the post does not appear.

    I have tried with windows live writer but it does not work as well.

  17. Board-Senseless.com
    Posted 7 years ago #

    I too am having image/video upload problems even after modifying the php.ini file to accept >50 mb files for both post and upload max file size.

    Has anyone found a fix for this yet?

    VERY frustrating

  18. Class
    Posted 7 years ago #

    Just adding a "me too". The tips in the sticky didn't make any difference for me, same with two other upload plugins.

    Here is the last entry from my webserver error log, if this has anything to do with my problem (Otto42 et al, if you're still following this topic :)

    [Wed May 7 01:46:32 2008] [error] [client 83.xx.xx.xx] mod_security: Access denied with code 406. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"] [hostname "acme.org"] [uri "/wp-admin/async-upload.php"]

  19. tssdesignwebs
    Posted 7 years ago #

    Same problem here.

    Virgin 2.51 installation both on a local server and online shared server.

    I have tried with MSIE 7, Opera and Firefox all with the same results. Image uploads and when one goes to insert the image into the article the "lightbox" goes blank and sits there. The image does not insert though the box can be closed.

    There is obviously an Ajax issue here. I have not had time to look at code. I am versed in PHP, Javascript, C++, C#, VB, ASP.NET on and on.

    I am surprised this was not caught before release but it happens.

    The work around is simple enough.

    Upload the image using the media upload. Copy the resultant URL to your clipboard (highlight it and do a CTRL-C or right click "copy". Exit out of the media uploader. In the editor click the Insert Picture icon, paste the URL into it.

  20. nickrita
    Posted 7 years ago #


    Like many others I couldn't upload images since I upgraded to 2.5.1.

    I was discussing it with Marco Cimmino (Author of plugin Cimy User Extra Fields) and he assumed the reason could be the memory limit.

    So I tried to change from php4 to php5 and it works!

    I'm on 1&1 and put the following in the .htaccess:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Now everything works fine.

    Hope, it helps you.


  21. chuckstuff
    Posted 7 years ago #


    I'm having issues as well. I'm using firefox, and when I try to upload an image I would get a message saying: HTTP Error. Same goes when I try to use Safari.

  22. Geoserv
    Posted 7 years ago #


    Your .htaccess fix in the sticky worked for me.

    Thanks for your help.

  23. Scratch Lightning
    Posted 7 years ago #

    2.5 was my first experience with WordPress. At first, the image upload worked fine in IE 7. Then it just stopped - I got the "HTTP Error" and "Crunching" messages. So I tried Firefox, and it worked for a while. Then that stopped working, too. The screen would darken for the Flash uploader, and a progress bar would appear, but nothing would happen. Clicking anywhere on the browser would reset and take me back to my post.

    I downloaded 2.5.1, but got the same issues.

    I added the following to my htaccess file:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Now, the Flash upload screen appears, and I can search for an image to upload. But when I select "Show Image", nothing happens. That's in Firefox. In IE, nothing happens.

    Does anyone have any suggestions? I don't have any coding experience, and this is really frustrating. It's keeping me from even beginning my site.

    Also, I tried the No Flash Upload plugin, but even though it says it's active, it doesn't seem to be doing anything. It still tries to use the Flash uploader whenever I try to add media.

  24. Andreas Beer
    Posted 7 years ago #

    Found something: The "simple tags" plugin version 1.5.7 interferes with image insertion and the workings of the WP tag system. I killed the plugin and WP 2.5.1 seems to be working OK now.

  25. zetino
    Posted 7 years ago #


    For the people who is using the following configuration or similar:

    Debian gnu/linux "lenny" + iceweasel/mozilla firefox

    "JUST update the Flashplayer plugin" the default version is 9.0.42, just upgrade to the latest version from macromedia (9.0.124), RESTART Iceweasel/mozilla firefox and that is.

    Is my first time installing my own wordpress and I really don't know why you are talking about change the .htaccess

    May the development team did not specify the requirements for this latest version or may we have not read all requirements for this.

    best regards,

  26. Board-Senseless.com
    Posted 7 years ago #

    Thanks Zetino, but I think you're off the mark there.

    Does anyone from wordpress read these threads??????

  27. AndrewRH
    Posted 7 years ago #

    Just to say that disabling the Simple Tags plug-in has so far solved the problem for me...(two pics uploaded and thumbnails were created; no HTTP error with either). Here goes the third upload...

  28. Board-Senseless.com
    Posted 7 years ago #

    I have now tried all htaccess suggestions and disabled every single widget and plugin - still get the 2MB error message.

    I love wordpress and the best part is that it's free - but free is only a great deal if it works.

    Any other ideas?

  29. LewiePaine
    Posted 7 years ago #

    What I find odd is that sometimes it works and sometimes it doesn't. I seem to have best results when I insert the image immediately. When I post slowly (and allow the auto-save function to kick in (?)) and attempt to insert the image last, that's when I'm apt to get the white window. Generally, (especially when it comes to computers)either something works or it doesn't. Not so (for me) in this case.

  30. Andreas Beer
    Posted 7 years ago #

    What I find odd is that sometimes it works and sometimes it doesn't.

    So do I. Killing the simple tags plugin did not solve everything. The flash thingy seems based on licensed properties.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.