Support » Fixing WordPress » WordPress 2.5 Uploader Issues

  • Resolved stitzelj


    I’ve an instance of WordPress that returns the following error when I try to upload an image:

    Unable to create directory /wp-content/uploads/2008/04. Is its parent directory writable by the server?

    I’ve already checked directory permissions and they’re set properly. I’ve also disabled all plugins to make sure I don’t have a conflict. I’ve got several other instances installed on my server, and they all work fine, with the exception of this one.

    Frankly, I’m stumped at this point. Any thoughts or suggestions?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Anyone had a chance to consider this request?

    i am struggling with the same problem. I’ve read about someone who temporary solved it by using Opera browser, but it doesn’t works for me at all – i tried all the browsers.
    The very interesting part of the story is that i have a mirror image of my blog stored on different hosting – there is no problem like this and everything is working properly. So i think it might be something that comes from the hosting we use.

    Which persmission you choosed?

    It’s a 777 on the wp-content directory (as it is on all my installations) and same with the uploads directory. No reason I can see why it shouldn’t upload just fine, but it continues to return the error above.

    what about the 2008 and what about the 04 directories in the uploads directory what are those permissions?

    the same

    In this case, this is not because of your file permissions. PHP is simply not allowed to write to that directory. Most often this is because of file permissions but there can be other reasons.

    I suggest you get in contact with your Administrator to figure out. Maybe you can figure out as well on your own. Which user is executing the Webserver? Which is executing the PHP script? Does the PHP Configuration permitt access to certain functions? Does the PHP Configuration only allow to create and access files in certain directories (Safemode)?

    No dice. Checked with the support desk for my webhost and everything on the server is configured properly. It’s clearly a WordPress issue.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    It’s clearly a WordPress issue.

    Sorry, but it’s not. PHP is telling you that it cannot create the directory. WordPress can’t fake that.

    The only person who can fix this is your host.

    Suggestions? I’m at a loss. And all my other WP installations on my account work fine.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    We have no idea. We cannot see your system like you can. It could be a permissions issue, it could be that the file already exists, the filesystem could be full, you could have reached your quota… I mean, the possibilities are endless. We don’t have any information upon which to base a suggestion. It’s a filesystem and/or hosting issue, not a WordPress issue. We have no way to tell you anything at all.

    Create the directory yourself manually or something. I dunno.

    OK, FYI for future reference – make sure that the file upload location in the Miscellanious options screen does NOT have a leading slash. Turns out one of the other admins that uses this installation tried to change the file location and added the slash, and I just didn’t get it until now. Problem resolved. Add this one to my personal checklist of “duh” mistakes and one of the first things I look for the next time sometime like this happens.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Hah! I never would have thought of that one.

    Good to know for future reference.

    Yeah well the message was:

    Unable to create directory /wp-content/uploads/2008/04. Is its parent directory writable by the server?

    That is starting in the Root directory: /wp-content/uploads/2008/04

    I did overlook it as well, but it was already documented in the first post 😉

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WordPress 2.5 Uploader Issues’ is closed to new replies.