WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 2.5 Inserting Images Issue

WordPress 2.5 Inserting Images Issue

  • Hi everyone, I love the new wordpress version with the exception of the fact that it is much harder for me to insert images now. The new “add medi” option does not want to work for me.

    1. When I go to upload an image, that works fine but I can’t seem to be able to insert said image into a post without switching to the code part of wordpress and inserting the IMG tags and having to type out the really long link to the image manually? I really miss the old way of inserting images into posts, is that buried in 2.5 somewhere? I was using 2.33 originally before this

Viewing 15 replies - 1 through 15 (of 21 total)
  • I am also having problems inserting images into my posts.

    There is a lot of odd behavior using the Add Media functionality. I am able to upload images, but inserting an image is not working well. I have tried IE7, IE6, and Firefox in a windows environment.

    Inserting an image can end in any one of several undesireble results. I have not found a way to make it work the same way every time.

    What I am doing temporarily is to copy the html from previous posts and changing the various values for the current image.

    having trouble with inserting images too. I am getting a blank window popup with

    Are you sure you want to do this?

    Please try again.

    When I click on Please try again I get the write post inside that popup window.

    when I click on the button with the little tree to add an image I just get a smaller empty window with nothing in it.

    I like the look of 2.5 but I doo need to be able to insert images

    Images seem to upload, but 2.5 says it cannot create the necessary folders for image storage, although test posts (without images) display the correct folder hierarchy in a browser bar. (wp/wp-content/2008/04) I think that the database is converting the info to display in a browser, but not actually creating those folders, which compounds trouble shooting, for me anyway! When I look with FTP, there are NO Folders!

    That that is… is
    That that is not… is not
    Is not that it? It is!

    Thanks and good luck to all!

    my problem appears this way:

    after choosing an image from my desktop to upload i get redirected to the login screen which looks a bit weird:
    http://i106.photobucket.com/albums/m268/defaulty/uploadproblem1.jpg

    after filling in name and passwort an error appears inside the flash window:
    http://i106.photobucket.com/albums/m268/defaulty/uploadproblem2.jpg
    “the requested url was not found on the server”

    and the images did not appear in the upload-folder (wp-content/uploads/2008/04). there isn’t a solution for me yet except of uploading the pictures via ftp to the server.

    i tried all of the possible solutions in the sticky post, except of the no-flash-plugin. i am going to try this now.

    If I try to upload an image from my computer using the Add Media function, I just get an HTTP Error and the message “There was an error uploading your file please try later”

    I am having issues too in 2.5 with it giving me the login screen after crunching and then when you log in, it says that the post is not on the server. It is a problem for safari, opera, and firefox. The only one that works a little is IE& with the IE-fix on the sticky. But at the most I can still only upload 10 images or so before I get the infamous http error. I’ve been trying and I still can’t get a grip on what is causing it. I’ll just keep trying. I’ve lost a couple days at least trying to figure it out.

    weird stuff.
    but i did try the no-flash-plugin from the sticky post now (did you?) and i can perfectly live with it now. it still looks better than in older versions of wordpress. i think i’ll stick with the no-flash-option.
    actually: all in all i am pretty pleased that the upgrade to 2.5 worked pretty well, far better than i expected.

    buntstift:

    When I enable the no-flash plugin it only lets me upload one at a time. I wanted to upload 50 or 100 at a time for the gallery function without getting the http error. Are you able to upload more than one photo at a time when you have the no-flash plugin enabled?

    I have started this reply over 3 times now…. never mind!

    @ photolord: no, i can’t. i am not dealing with galleries. sorry i misunderstood you.

    As crianp said “I love the new wordpress version with the exception of the fact that it is much harder for me to insert images now. The new “add medi” option does not want to work for me.” I feel the same thing. it’s not working I can upload but from there to the post no way.
    I’m seriously thinking of going back to an older version of WP where the inserting of image was much more simple and worked.
    But at present: I have reupload wp even in a different place but nothing helps and get no error message it just don’t work, so for the moment I manualy upload my images and insert them manualy with html code.
    Is there solution to this nightmare or do hope for a version of wp to solve this problem?

    This worked for me with 2.5 –

    Check if you have the ‘uploads’ folder in
    wp-content, create it manually if not.
    Set permissions on the folder to 777.

    Add this to your htaccess file –

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Your done! 😉

    hth

    DUSTMAGIC…. YOU ARE MY HERO!!!!

    THANK YOU!!!!

    I did all the things that dustmagic recommended, the uploaded image is clearly in the uploads folder but I still cannot see how to put the image into the post! It is in the Gallery but how do i get it from the gallery into the post! please

    How do you add to your htaccess file?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘WordPress 2.5 Inserting Images Issue’ is closed to new replies.