WordPress 2.2.1 (57 posts)

  1. RobinQu
    Posted 9 years ago #

    my god, the latest.zip contains 2.0,not 2.2.1~ after i updated the system broke down with k2...after that, the there apears something strange on the homepage.

  2. projectego
    Posted 9 years ago #

    Upgraded all my sites yesterday to the latest version and everything went nice and smooth. :)

  3. whooami
    Posted 9 years ago #


    as of right now, the latest zip does NOT contain 2.0, I just downloaded and looked.

    christian-s, you are very welcome :)

  4. Root
    Posted 9 years ago #

    All this if_home malarkey started when Kubrick was shoe horned into WP without consultation with anyone who knows about this stuff. The whole upgrade / plugin / over riding or not of the default has been a mess ever since. In WP 2.2 although widgets are built in the Classic theme has not been upgraded.

  5. Rok
    Posted 9 years ago #

    O.K. Lots of talks on 2.2.1 has already taken place. Here I would like to address the plugin section.

    The feature "Deactivate all plugins" is there, but "Activate all plugins" is missing.

  6. johntynes
    Posted 9 years ago #

    I upgraded from 2.1.3 to 2.2.1 today (yes, backed up everything first). When I try to upload an image, I get this error and the image is not uploaded. (I've redacted part of the path to disguise my server directories for security reasons.)

    The uploaded file could not be moved to [redacted]wp-content/uploads/2007/06. Warning: Cannot modify header information - headers already sent by (output started at [redacted]wp-admin/admin-functions.php:1986) in [redacted]wp-includes/functions.php on line 1346

    Any idea what this means?

  7. channeldoubler
    Posted 9 years ago #

    Hi. I run upgrade.php and I get that nothing is needed, etc.
    Yet at the admin section I call from the menu the Widgets section and although the page is visible it doesn't work.

    I mean I see a Javascript error in line 270 of widgets.php and also the previously draggable boxes for the 2 sidebars (akismet, calender, etc) are not draggable any more.

    Can you provide a solution?

  8. Root
    Posted 9 years ago #

    On a new 2.2.1 install I am getting:

    Fatal error: Call to undefined function: did_action() in /home/more404/public_html/anig/wp-includes/functions.php on line 1345

  9. bmayzure
    Posted 9 years ago #

    I'm having problems with plugins and widgets that previously worked fine under 2.2. The most notable is WP Lightbox 2.

    Whatever "security" issue the developers fixed in 2.2.1 must have been around for a long time, because fixing it has caused havoc with a lot of plugins and widgets.

  10. jgomula
    Posted 9 years ago #

    Please help, I just installed a fresh new WordPress with no content yet, and then upgraded. I can't change the theme, despite having uploaded 2.2.1 ready themes into the wp-content theme directory - the presentation tab just doesn't see any themes including the default and classic ones. Instead I get this across the top of the page, and several others in the admin section.

    Warning: array_keys(): The first argument should be an array in /home/liquidne/public_html/stuff/wp-includes/theme.php on line 276

    It looked like someone had a similar problem and deleted the classic and default themes? I tried this and got a white, blank page, so I put the default folder back. Is there somewhere I can tell it to go use a different theme?

    Thanks for any help, sorry if this is in the wrong area.

  11. doog
    Posted 9 years ago #

    Just a bit of good news to the noble and patient support people I've been reading.

    My upgrade went flawlessly - I followed the detailed directions and it went without a hitch.

    As expected, the King Plugins did NOT want to work, but the built-in widgets do very much of what I was using them for. I was done in 30 minutes and most of that was waiting for the DB and WP-Content to DL to me for backups.

    I'm sure the King Plugins developer will update his documentation to compensate and then all will be as it was.

    Gotta love this platform.

    I've read a great deal of hoo-haw about the reasons behind 2.2.1 being required. Golly. The developers are human beans(sic) and made an error. Get a helmet folks, life is never safe. The alacrity of the fix puts all the 'real companies' to distant and pathetic shame.


    WHOO HOO!!!!!!!

  12. amberlina
    Posted 9 years ago #

    Upgraded to WordPress 2.2.1 and my 'sideblog' plugin no longer works. It comes up with this error

    Aside category not selected. Please provide a category slug if you're using non-dynamic sidebar.

    If worst comes to worst I'm perfectly at ease with not using this plugin.

    But my other issue is that my current blog post 'Mad Dash For The Loo' is appearing 3 times on my blog. Can anybody help, especially with the latter problem?

    To see the problem: http://avarae.dispiacere.org

  13. wannaplay
    Posted 9 years ago #

    Hi, after a generally succesful upgrade to 2.2.1 for my blog at http://www.wannaplay.it, there are two glitches annoying me:
    - it seems that with my hosting I can't use many plugins. Sometimes I got those blank pages after posting or managing posts. Same thing if I localize my WP. Anyway I solved it using only what I really need and lowering resources.

    - the main issue are those accented characters in the feed that give me errors and "??" substitution. You can evaluate it (if you're able to figure out italian accented letters) at

    Posts work properly and everything is correctly showed on the site. Always using UTF-8.
    Any ideas? It drives me crazy.
    Thanks a lot!

  14. miguknamja4
    Posted 9 years ago #

    After upgrading, I have the following problems:

    1. I cannot use Live Writer or Zoundry to post.
    2. I cannot view my plugin page on the dashboard.
    3. My RSS feeds no longer show the name of the blog.

  15. Root
    Posted 9 years ago #

    @jgomula. I have experienced that error. But by revisiting admin a reselecting the same theme it clears spontaneously. Incidentally I am now installing using SSH. I think the zip and the tar might be borked.

  16. chaney
    Posted 9 years ago #


    I'm having the exact same issue as channeldoubler above - with previously draggable widgets in 2.2 now visible, but not draggable. everything else in the upgrade is working just fine.

    fantastic work to all you, and thanks for catching those security issues for us small fry.

  17. AndreyTepaykin
    Posted 9 years ago #

    In reply to any who get errors such as
    Unknown column 'name' in 'order clause'
    I learned code and finded that for some reason variable $orderby didn't clear in wp-includes/category.php line 31
    just before function extract($r, EXTR_SKIP);
    I installed WordPress on my local and on the server. On my local machine it work fine, but only on the server got error. May be because there are different PHP versions. I have 4.3.3 on local and 4.3.2 on server. I didn't learn this problem deeper, just added line
    before function extract($r, EXTR_SKIP);
    seems works

  18. miguknamja4
    Posted 9 years ago #

    FYI: I had a security block on my xml-rpc file that my domain provider placed because of the security vulnerability identified with 2.2 or 2.2.1. I had to put code into my htaccess file to remove the block. If anyone has a similar problem, contact your provider.

    All resolved.

  19. manfredeye
    Posted 9 years ago #

    I have just upgraded to 2.2.1. Im having a difficult time with several issues.
    One is that when I try to insert a link. My own URL is added. and Im finding no place to delete or change that.
    Heres an example:
    If you look at the address for "free trade agreements" you will see my addy there at the begining. All the other links are fine, but this post was created after the upgrade.
    and Im still seeing the funny 'a''s at certain times.
    what a mess. I wish Id just left it alone...hehe.

  20. Griff Wigley
    Posted 9 years ago #

    I'm also not able to get Live Writer or Zoundry's autodiscover feature to work with 2.2.1, though I'm able to configure Zoundry manually.

  21. sportech
    Posted 9 years ago #


    Finally! A fix that works. Thanks for your help AndreyTepaykin.

    Much appreciated.

  22. shahin
    Posted 9 years ago #


    I define a Custom Field and whenever a person makes a comment that custom field got reset.
    I didn't have this problem with 2.0.5 but with 2.2.1 I have.


  23. wdg
    Posted 9 years ago #

    A person needs to leave breadcrumbs. My problem was missing blogroll, database error, unknown link count in where clause. MichaelH steered me in a good direction for part of it here on this thread, which turns out to be not a support thread. He told me to read about wp_list_bookmarks ( ). From another thread I can't seem to get back to I read about adding missing categories to my SQL database. Thanks MichaelH, thanks to all. The objective is to have this software operating in the background without thought so the focus is on the business at hand.

  24. prabhukrish
    Posted 9 years ago #

    I have a strange problem. Even when there are comments for the posts, it appears as 'No Comments'. The URL is http://prabhukrish.net. Could this be a template problem, or something to do with 2.2.1?

  25. iso247
    Posted 9 years ago #

    Well, I am in trouble with WordPress (2.2.1), because this line "<?php if (have_posts()) : while (have_posts()) : the_post(); ?>" does not seems to work anymore.
    In short, I am working on the i3Theme to meet the needs of a customer (mostly turning static menus on both sides into dynamic menus + removing commenting features).
    The goal is to use the powerful features of WP, to build a "classic" website (not a blog) with data (either posts or pages) shown one by one, which implies the menu(s).

    I have used PHP and MySQL for nearly 5 years now (and Oracle a few years before), and the functions I am implementing work fine on other themes of WP 2.2.1,
    so I do not think this is due to a lack of experience on my side (except with WP, whose I have used for less than one year).

    The links look this way:

    (Note: "http://pouplard.net/~fludor/fr/" is the root of the website, but pouplard.net is an alias of my computer, so you cannot see the trouble on the Net).

    Of course, the links exist. I have dropped and rebuilt the database, too, as I thought it was perhaps out of date, but the only change is that now, I get error messages
    (until that, I only got an empty #content zone)

    In clicking on the URL above (or ANY url with a "?p=xx" suffix), I get this message:

    Erreur de la base de données de WordPress : [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY post_date ASC LIMIT 1' at line 1]
    SELECT ID, post_title FROM fr_posts WHERE post_date > '' AND post_type = 'post' AND post_status = 'publish' AND ID != ORDER BY post_date ASC LIMIT 1

    I have noticed that the request is malformed (there is no value at "AND ID !=" !!!), but I was not expecting this query, anyway, because I ask for a post in giving its ID :)

    So, I am trying to understand the "internals" of WP (I have difficulties at it -- i don't understand a lot the WP_Query class), and I would like to know how
    I can shortcut the "have_posts()/the_post()" block, in order to show the pages/posts I need: either one full page/post, or exerpts of results in case of search...

    PS: My plugins are "akismet" and "hello" (they came with WP), plus "wp-db-backup" (added).

  26. pixelmania
    Posted 9 years ago #

    hi all!

    i have updated to 2.2.1 and now the thumbnail option when uploading an image is missing.
    Did anyone else made this experience. are there any bug fixes for this issue?

    thanks in advance

  27. epsilonsa
    Posted 9 years ago #

    I’ve been having some trouble getting the visual editor (TinyMCE) to work. After searching for hours, It seems as though TinyMCE was broken entirely with wordpress 2.2.1

    This would be consistent with my experiences so far as I have done a clean install of wordpress on an entirely new server and can’t even get the basic visual editor to work before I install the advanced plugins.

    Can anyone confirm that TinyMCE still works with wordpress 2.2.1? (that is NOT hosted on wordpress.com) So far, I have had no luck on two clean installations on two different servers.

Topic Closed

This topic has been closed to new replies.

About this Topic