Support » Fixing WordPress » WordPress 2.1.1 Category Add Ajax Not Working

  • Resolved parksobong


    Hi, I recently upgrade all my blogs to 2.1.1, and the AJAX that adds the categories is completely borken.

    I type in a category and click on the ADD button, and it doesn’t do anything. The same goes for both the post window and the manage categories window.

    What could it be? I tried deleting all the files and re-uploading a clean version of 2.1.1.

    Thanks in advance

Viewing 15 replies - 1 through 15 (of 15 total)
  • Bumping this thread.

    I’m having this same problem. Anybody have any ideas how to fix it.

    I could really use some help with this. I have tried replacing all the files and also taking off all the plugins/widgets and it still does the same thing. However, if I delete the prototype.js from the wordpress includes directory ajax does start working on the manage categories tab. But, it does not work on the write new/edit a post portion. Deletion of this required file also causes the widget panel not to work correctly. So, right now I have to delete the file to add categories and then go back and upload it again so everything else works right.

    Surely someone could lend some advice?

    2.1.1 has security issues, the first thing you need to do is install 2.1.2

    I am upgraded to 2.1.2 now. Same problem.

    Anymore ideas?

    I am still having this issue although I am at version 2.1.3 now.

    I’ve got the same problem here…

    I’m using firefox on Mac OS X
    Word Press 2.1.3

    heres my server info, tho I doubt its anything to do with this!!
    windows 2003 server with apache and PHP version 5.0.4

    Me, too. The bug is random: I have three blogs with 2.1.3. Two blogs work ok, one blog (one the same site!) doesn’t add categories or comments.
    Tried various browsers; Linux server.

    There is one difference, however: when I’m trying to close add categories page, it gives a warning “do you want to navigate away from this page?” Working blogs show no such warning.

    I have this problem too with the newest WordPress 2.2 in Firefox, but it does work in IE/Opera.

    I also have problems with the pop up windows being blank for such actions as adding links, inserting images, etc.

    I thought it had something to do with Javascript not working properly so I have cleared all caches and reinstalled but still the same problems.

    I think these two things are related so I am looking for some type of solution. Please help!

    I also have this problem. I installed a fresh 2.1.3 added some categories added some posts. Then I tried to add a new category from the write/post page and then the problem stared. Upgraded to 2.2 and same issue.

    I can now no longer add new categories either in the write sections or in the manage categories section.

    I have searched quite a bit on this problem and someone mentioned somewhere it might have to do with mod-security being installed on the web server.

    The symptoms of this problem are
    -not being able to add a new category
    -getting the “Are you sure you want to navigate away from this page” message after attempting to add a new category.

    This is an extremely annoying problem…

    Same problem here. I was able to get it to work by firing up my copy of IE 7 (WinXP OS). The ajax worked. Weird. I don’t want to have to use IE but one keeps it around for just such situations.

    Normally I’m using firefox – I never saw the dialog box “Are you sure you want to navigate away from this page?” until I tried to add a category. I can edit the two that existed from the install, but nothing else.

    I just did a fresh scrub and install of WordPress 2.1.3 on my midphase account via their fantastico service.

    Sounds like something, somewhere between WordPress 2.1.3 and firefox is not getting along well.

    Any help here? I’m having the same problem, I think. When I type in the name of a new category and click on “add”, the form clears but nothing is added.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘WordPress 2.1.1 Category Add Ajax Not Working’ is closed to new replies.