Support » Installation » WordPress 2.0.4 to 2.1 Issues

WordPress 2.0.4 to 2.1 Issues

  • I’ve upgraded my installation from 2.0.4 to 2.1.

    The original WordPress installation was 2.0.4 installed via cPanel Fantastico. I have read all the relevant information on the subject of upgrading a fantastico installation.

    The installation went through without a hitch, easily installed no errors and all plugins turned on correctly.


    Now when I log into the admin section I have reduced features!

    For a Start…

    Writing a post DOES have the tabs, Yet there are a heap of things missing, (all extended buttons eg images/links/alignment.) there are no options!

    I cannot see the new Upload area.

    So there are a heap of things that the new version (2.1) touts that do not show up for me.

    Is there something that I need to change to fix this?

    Any help on this would be great!

Viewing 15 replies - 1 through 15 (of 51 total)
  • Oh I forgot to mention that these are the versions of my PHP and MySQL:

    PHP version 4.4.4
    MySQL version 5.0.24-standard’

    I am experiencing the exact same thing with the TinyMCE, and it seems that we’re not the only ones. I don’t get any particular javascript errors in Firefox — just lots of icons missing. The only ones present are bold, italics, split, spell check and help.

    Here’s a screenshot

    Yep thats exactly what I get, also the extended features of the installation (2.1) are not present, aka the new upload area and other nice things!

    I sure hope there is an easy fix for this!

    Ditto the above. Posting works fine, but the editor was missing all but the functions mentioend in the previous post.

    I reverted to 2.0.7 so that I could regain the functionality, but somehow all the javascript in the Write screen broke and one image plugin stopped working entirely. Fun times tonight.

    I’m having similar problems in Firefox 2.0 (Mac). I see the buttons TimKing does; the photo uploader does appear for me, but I haven’t even seriously considered trying it yet.

    EDIT: I upgraded by hand through FTP. Everything else appears to be working fine, other than a hiccup in my recent posts listing that I assume has to do with syntax changes(?).

    I just had a friend tip me off that he sees the full menu in IE, so this seems like a Firefox incompatibility, since his Firefox doesn’t show it either.

    Edit: Huzzah! By going into my Firefox settings, I’ve been able to get the TinyMCE menu to re-appear in OS X:

    Firefox > Options > Content > Enable Javascript > Advanced > Make sure all these options are checked.

    Credit goes to dracolich for this fix. Hope this works for everyone!

    Thank you, thank you, thank you both!

    YMMV on this one, but just to experiment I checked all the boxes, reloaded the Write page, and the buttons were there. I unchecked all the boxes, reloaded it again…and they were still there. I shut down and reopened Firefox (everything still unchecked)…still buttons. I couldn’t begin to guess why that is, but it worked. ๐Ÿ™‚

    Hmm, ah… pages in the manage page view are now listed in reverse order of importance? Is that right?

    I’m using Firefox on OS X 10.4.8. I experienced the same problem with the buttons post editor. Clearing my browser cache solved the problem for me.

    Based on experience trying to deal with issues like this for the company that I work for I would suggest as a last resort trying to clear your cache. I would suggect not doing this as your first troubleshooting step because it does not reallly narrow down the problem too much.

    Unfortunately, I’m relatively unfamiliar with debugging client side code in Firefox (IE only product where I work) so after trying a few things suggested here I thougth I’d see if clearing the cache helped.

    For the record I had version 2.0.6, 2.0.7, 2.1 RC 1 and 2.1 RC 2 on my web for testing. I didn’t pick this up because I primarily use safari.

    If there is no resolution to this soon I’d be happy to see if its a combination of previous versions pages cached in firefox on my PC that caused the problem, but I’m unable to get to this for a couple of days.

    Anyway, hope this helps someone.

    AWESOME, so we have a couple of solutions.

    Just remember that you can press CTRL + F5 to dump the cache of ONLY the page that you are on in Firefox, if you do that to your write post page you won’t have the problem any more!

    I had the same problems and they were fixed when I replaced the wp-admin/post-new.php file. Don’t know why. Just worked.

    After i got all the tiny editor buttons back to life i have a new problem.

    I can’t edit URLs in WYSIWIG mode. There is no “okay” and “cancel” button in Firefox The “x” to close that windows does not work too!

    Am I only one who is missing “Show HTML” button in Rich-editor? It was on place with 2.0.7 but in 2.1 itโ€™s missing. Code-editor is not showing full HTML.

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘WordPress 2.0.4 to 2.1 Issues’ is closed to new replies.