Support » Fixing WordPress » WordPress 2.0 htaccess File

  • Hi all,

    I just installed WP 2.0 and I realised that the htaccess file it generate only contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php
    </IfModule>

    # END WordPress
    So where did the rest went?

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Mark (podz)

    (@podz)

    Support Maven

    That, I believe, is it.

    okie i just read the http://codex.wordpress.org/Function_Reference/WP_Rewrite, guess that it is all in the PHP code =(

    Hello
    Have a look at this topic…!

    podz: anyidea how do I add in my set of htaccess rules to the wp_rewrite rules array?

    so V2.0 is out? why I only see the old version from Download section?

    I am using the RC3, i need to convert my plugins asap so I downloaded the RC3 to convert.

    Still debugging the class wp-rewrite.

    This should work…

    <Limit GET POST>
    order allow,deny
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>

    Options FollowSymLinks

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    TheFuzzyBear

    (@thefuzzybear)

    Hi,

    I’m not sure this will help or not. But on Hamby’s post I’m thinking the line

    Options FollowSymLinks

    should instead read

    Options +FollowSymLinks

    at least that’s what I read in the WP Docs. I may be wrong on that.

    Christopher

    OK, this is really getting my blood boiling.

    I put this in to my .htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /WordPress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /WordPress/index.php [L]
    </IfModule>

    so that now the whole file looks like this:

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /WordPress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /WordPress/index.php [L]
    </IfModule>
    AuthName cecsearch.com
    AuthUserFile /home/cecsearc/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/cecsearc/public_html/_vti_pvt/service.grp
    Redirect /blog/cc-blog.htm http://cecsearch.com/WordPress/index.php
    Redirect /blog/executive-restaurant-recruiter-blog.htm http://cecsearch.com/WordPress/index.php
    Redirect /blog/rss.xml http://cecsearch.com/WordPress/wp-rss2.php
    Redirect /hot_jobs.htm http://www.cecsearch.com/restaurant_jobs.htm
    Redirect /blog/atom.xml http://cecsearch.com/WordPress/wp-atom.php
    ErrorDocument 403 /v-web/errdocs/403.html
    ErrorDocument 401 /v-web/errdocs/401.html
    ErrorDocument 500 /v-web/errdocs/500.html
    ErrorDocument 400 /v-web/errdocs/400.html
    ErrorDocument 404 http://www.cecsearch.com/404-cec.htm

    BUT with the WP entry in the htaccess file, FrontPage won’t connect and let me publish files. It gets a 403 error.

    If I remove the htaccess file entry, then FrontPage will let me publish, but now the links in my WP Blog are all broken.

    What the heck is going on? Please help.

    Carl Chapman
    carl@cecsearch.com
    Website: http://www.cecsearch.com
    Blog: cecsearch.com/WordPress

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WordPress 2.0 htaccess File’ is closed to new replies.