Support » Installation » WordPress 1.5 on Os X 10.4 Server (solved!!!)

WordPress 1.5 on Os X 10.4 Server (solved!!!)

  • Hi all,

    Having encountered a few problems getting WordPress working on 10.4 Server (was working fine on 10.3!), I have managed to get it working again. None of the problems relate directly to WordPress, rather it is an incompatability between the PHP and MySQL versions that ship with 10.4. Apparently MySQL 4.1.10a and PHP 5.03 do not play well together (something to do with password authentication).

    Solution? Upgrade PHP to 5.04 and MySQL to 4.11. I used entropy’s PHP 5.0.4 package (http://www.entropy.ch/phpbb2/viewtopic.php?t=1900) and MySQL’s latest installer (http://dev.mysql.com/downloads/mysql/4.0.html). Both installed without a hitch, but make sure you turn off MySQL before installing.

    Ok, so you then need to create a symbolic link from ‘/var/mysql/mysql.sock’ to ‘/tmp/mysql.sock’ and move your databases from /var/mysql/ to /usr/local/mysql/data… So here’s a quick copy and paste for you:

    ln -s /tmp/mysql.sock /var/mysql/mysql.sock

    and then:

    cd /usr/local/mysql/data
    cp -Rp /var/mysql/your_mysql_database_name ./

    (where you replace “your_mysql_database_name” with whatever your database is called and repeat for each database you want to move…) and Robert’s your mother’s brother!

    Hope this helps someone, it had me f*xed for a couple of days!


Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress 1.5 on Os X 10.4 Server (solved!!!)’ is closed to new replies.
Skip to toolbar