Support » Fixing WordPress » WordPress 1.0.1 RC1 Upgrade Trouble

  • Anonymous

    I just upgraded to the latest version of WordPress from WordPress 1.0.1 RC1.
    I encountered this error when I clicked on the calender and archives:
    Warning: Missing argument 2 for zeroise() in /home/mysitecom/public_html/weblog/wp-includes/functions-formatting.php on line 241
    Any idea on how to troubleshoot this.
    I just copied the latest files on to my server and ran the upgrade script.
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Anonymous

    This is the section of the script that appears to be causing the trouble?!?
    function zeroise($number,$threshold) { // function to add leading zeros when necessary
    $l=strlen($number);
    if ($l<$threshold)
    for ($i=0; $i<($threshold-$l); $i=$i+1) { $number=’0′.$number; }
    return $number;
    }

    Anonymous

    Solution:
    template-functions-general.php
    Revised with :
    $thismonth = ”.zeroise(intval(substr($m, 4, 2)), 2);

    NuclearMoose

    (@nuclearmoose)

    Anon,
    Good to see you found a solution. I was wondering if you might be interested in upgrading to 1.02? 😀 It should fix a number of odds and ends from the 1.01 branch.

    Anonymous

    I am not sure what you mean.
    I am currently running version v=1.2-alpha

    NuclearMoose

    (@nuclearmoose)

    Anon,
    My mistake…I mis-read your original post..I thought that you had upgrade TO 1.o1 RC1 and not FROM 1.01 RC1…DOH!
    <slaps forehead>
    My apologies. I’ll just shut up now! 😀
    Craig.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress 1.0.1 RC1 Upgrade Trouble’ is closed to new replies.