Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Wordpess update 3.7 Nextgen not working

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author photocrati

    (@photocrati)

    @equineadoption: Was the exact same shortcode already working before the update, then you updated to 3.7, and then it stopped working? Also is it just that shortcode, or all singlepic shortcodes, or all shortcodes in general?

    In the meantime a few suggestions:
    *Go to Manage Gallery and confirm you haven’t clicked “Exclude” for image with ide 950. That will block an image from displaying in a singlepic.
    *I was just reading another issue on the forum about a singlepic shortcode not working, and the user traced it back to wp-typography. If you are using that plugin try deactivating it.
    *Try momentarily deactivating all other plugins to see if the shortcodes work again. If so, it’s a conflict and we just need to identify the culprit.

    Thanks. (Erick)

    Hi Erick,

    Thanks for the quick help 🙂

    It’s all singlepic shortcodes.
    Check not excluded.
    Turned off all plugins made no difference.
    I rolled back Nextgen to 2.0.31 still have same problem.

    Site http://www.riftdimension.com/

    Thanks

    Hi Erick,

    Read the resolved post about shortcodes not working it did not resolve my problem. The slideshow was also not working after the update.

    I rolled back to 1.9.13 as suggested works fine now with wordpress 3.7 hopefully there will be a fix sometime soon.

    Thanks

    Erick,

    Updated my other website having the same problem with any update of Nextgen after 1.9.13. I updated all my other plugins and did not update wordpress to 3.7 Nextgen was working. However as soon as I updated to 2.0.33 it quit working.

    Thanks

    john

    (@johnpaulbeaver)

    I agree with Equine, there is definitely a problem with Nextgen on WordPress 3.7 I’m using Nextgen 2.0.33 and it killed the site when I upgraded to the wordpress 3.7 I had to roll back to the previous version of wordpress to get the site working.

    Nexgen’s causing WordPress 3.7 to throw this error:

    “Call to undefined function wp_get_current_user() in wp-includes/user.php on line 21”

    Use Nextgen Versión 2.0.0 and upgrade from 3.6.1 to WP 3.7

    Site crashed with message “xxx/wp-includes/user.php on line 215”

    Found post http://wordpress.org/support/topic/problem-upgrading-to-37

    And manually rename Nextgen directory to deactivate it, the site works again

    I had the same problem and fixed it by

    1. Through ftp, change the nextgen-gallery plugin folder name to nextgen-galleryzzzzz
    You should be able to go in the admin section of the site now.

    2. makes sure wordpress has updated to 3.7 then update nextgen plugin.

    3. go and change the plugin name back to nextgen-gallery.

    Hope this helps others with the same issue.

    Plugin Author photocrati

    (@photocrati)

    @all: As far as I can tell, every user posting in this thread has a different problem, although they’re all potentially related to 3.7. That makes things hard to respond to. In the future, if you have a different issue from the original poster (ie, in this case, singlepics not working), can you please post in a new thread?

    @equineadoption: When you first reported this problem, you had updated to NextGEN 2.0.33 from which version? From 1.9.13 to 2.0.33, or from one of the other 2.0.x versions? I just want to know if singlepics were working for you at all with one of the 2.0.x versions.

    In any case, since we don’t know of any other person having all singplepic shortcodes broken that’s not related to a plugin conflict, we’d need to get WP and FTP credentials to troubleshoot further. I’ know you’ve rolled back now. If you like you can submit credentials, and then when ready, our devs will update you and fix any issues at that time. http://www.nextgen-gallery.com/report-bug/

    Plugin Author photocrati

    (@photocrati)

    @john: The error you are seeing has been thrown for many people updating to 3.7 who are *not* using NextGEN Gallery. There’s one proposed fix for a similar conflict with WP 3.7 and Reed Write plugin here: http://wordpress.org/support/topic/breaks-wordpress-37?replies=7#post-4803996

    We did have one person connect a similar error to NextGEN Gallery and had a developer look at it. It *is* possible that earlier versions of NextGEN before about 2.0.30 would trigger this.

    So question one: are you running NextGEN 2.0.33? And if so, question two: are you positive this is NextGEN? For example, have you tried deactivating other plugins one by one to see if it goes away and specifically traced it to NextGEN. If you are using 2.0.33 and have traced it directly to NG, we’d ask you to submit a bug report with WP and FTP login credentials so we can trouble shoot. Thanks! (Erick)

    Plugin Author photocrati

    (@photocrati)

    @aarcos: Looks like you are running 2.0.0, and if you read my response to @john above, you’ll note that I mention this error could occur with WordPress 3.7 plus earlier versions of NextGEN. So for you, I’m assuming this issue (and lots and lots of others) will be resolved by updating from 2.0.0 to 2.0.33. 2.0.0 was the very first release of a major overhaul of NextGEN and has many known issues. The latest version is dramatically more stable.

    Plugin Author photocrati

    (@photocrati)

    @haleeben: Thanks for posting a fix. That’s always much appreciated.

    I’d like to clarify which issue you were having though. I assume that you means you had an error that looked kind of like “Call to undefined function wp_get_current_user()…” referencing some line number? If so, were you running NextGEN 2.0.33 when you had it?

    I’m also confused because in step #2 above, you update to WordPress 3.7, but I’m assuming you only had this issue after you update to WordPress 3.7 in the first place, right? So did you roll back your WP version, and then run through your three steps above?

    Thanks for any clarification! (Erick)

    @photocrati: yes it was the wp_get_current_user() issue, step 2 was just a check. I was running NextGEN version 2.0 when updated to wordpress 3.7

    Plugin Author photocrati

    (@photocrati)

    @haleeben: You said 2.0 – just to confirm you mean 2.0.0, right? If so, that plus @aarcos probably confirms that this error will occur with WorddPress 3.7 plus older versions of NextGEN Gallery. Right now, I’m still assuming that if you update from NextGEN 2.0.0 to 2.0.33 first, and then update WordPress, you won’t see this error.

    Thanks for coming back to post the additional details.

    @photocrati: Information you requested has been sent to your devs.
    Thanks Erick

    @photocrati I’ve read right through this thread – I don’t think a new thread was started regarding the 3.7 update issue?

    I have the Call to undefined function wp_get_current_user() error after upgrading to 3.7 – nextGen was on 2.0 when I upgraded.

    I’ve confirmed its the nextGen plugin as I’ve checked each one in turn and only nextGen active is causing the error – I currently have the folder renamed.

    Is there a workaround?

    Thanks,
    Clare.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Wordpess update 3.7 Nextgen not working’ is closed to new replies.